summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-vol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/coinor-vol
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/coinor-vol')
-rw-r--r--sci-libs/coinor-vol/Manifest5
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild67
-rw-r--r--sci-libs/coinor-vol/metadata.xml13
3 files changed, 85 insertions, 0 deletions
diff --git a/sci-libs/coinor-vol/Manifest b/sci-libs/coinor-vol/Manifest
new file mode 100644
index 000000000000..a59abc4bf7b5
--- /dev/null
+++ b/sci-libs/coinor-vol/Manifest
@@ -0,0 +1,5 @@
+DIST Vol-1.4.4.tgz 3205621 SHA256 060e2cdd20443507b219192b26bcf8d2559cff2f3061225bb1343a9e569493be SHA512 20e04efac09694ddfa035496ec9b2920ef702e5a2ec4515cd88c52129c783efd3c25e044e6c2cec67ad800b297ebd03f3c3c377f58829790109d8d6dcb40cc39 WHIRLPOOL 01d2a07666bb7fc36eb7539e525ba095ae5efbfaee6c927f9d70d476f05815c1f0737acb6d398357ed0105913b4f4649539a3f5413a833b5e06862897ae5db8d
+EBUILD coinor-vol-1.4.4.ebuild 1557 SHA256 343e4430df502e2f67a9a0732d58b88f00c0b5ce07506a14b035ab02070a74e6 SHA512 63ccdab1c71c09820ff2e019e9dd671a476bd8acaa51117f02db916050ac63ed474162deae84bae65707fa2afcffb56b8d15077b2ac9047dbd7733e3df9e73a7 WHIRLPOOL 821de6c4734f16e99c20c5dfe3bde129b3f61b28b0404b477ad7e2f93f56a77b2394488976482046f5e8728c6334cd6398e18128be1d613a23c4033b98483a6b
+MISC ChangeLog 2436 SHA256 fba5ddfd6fd244cad0efd8bc31388e692d7696001f0d1adea3c3ff9fe876fd39 SHA512 c1fae571b5922e83fb5ace47a709376d95e0590f2daf6bc56448cf4897aa1eda665e4a95e1eb9339d2bb870c3a5d8ee3edc7ceec073368286a2be8df12806b58 WHIRLPOOL bd0e0bd038ae1cd5e9948ea8601c1f345acfe755f72b85dd15e3aded10b0c63a52e4ad611d2153857107a34bb57ca0675810b826c2bce290eb6e935e36e4b626
+MISC ChangeLog-2015 1424 SHA256 261712b4f5c725820276b80ce08dc505dd67f6173b416f89bade8098e15abbdb SHA512 47515ab5dd3a9ccc9ab8ccc4a1e15be9a6fae75119bf74f421e61ea9df2d3f69e13f0ce5c8e8d59ceef71129e75c374995fde721d13a363e18cb20a829d6c2ca WHIRLPOOL aa598f6d5344f7adc8eb1c434111be5a0c1f6e0efc26d5815892e1817c4ac2314723535676862e5417abc916986420573d03e766910b754166b73988c03f5b83
+MISC metadata.xml 499 SHA256 cd6ca99004fc0673a0c1742daa4a001669fc122fc2bd8455caa505cd246bbe4f SHA512 d629ecca944f6b9d53179044aeff93c5c2fac766766f7c0fa3a7f31a7c2efc44b920460139eb5fb333c8537d3b9d4c59f33461124e0f6fdc53640e4511d121f5 WHIRLPOOL c5aa220a5110ea0610ca6237737cfd3307c30180c910b2fe8b4153277359920a8069650c63273dee4d3d19853ec812e3db0fa2cfc3cd59d5fe47c66c500af04a
diff --git a/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
new file mode 100644
index 000000000000..58bba00bd35c
--- /dev/null
+++ b/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Vol
+
+DESCRIPTION="COIN-OR Volume algorithm linear programming solver"
+HOMEPAGE="https://projects.coin-or.org/Vol"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ # hack for parallel build, to overcome not patching Makefile.am above
+ autotools-utils_src_compile -C src libVol.la
+ autotools-utils_src_compile all $(usex doc doxydoc "")
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install -C src install-am
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-vol/metadata.xml b/sci-libs/coinor-vol/metadata.xml
new file mode 100644
index 000000000000..ac5905e9c285
--- /dev/null
+++ b/sci-libs/coinor-vol/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ Volume Algorithm is part of COIN-OR (COmputational INfrastructure
+ for Operations Research) project. Vol is an implementation of a
+ subgradient method that produces primal as well as dual solutions.
+</longdescription>
+</pkgmetadata>