summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-smi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/coinor-smi
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/coinor-smi')
-rw-r--r--sci-libs/coinor-smi/Manifest5
-rw-r--r--sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild70
-rw-r--r--sci-libs/coinor-smi/metadata.xml21
3 files changed, 96 insertions, 0 deletions
diff --git a/sci-libs/coinor-smi/Manifest b/sci-libs/coinor-smi/Manifest
new file mode 100644
index 000000000000..47516b6d96eb
--- /dev/null
+++ b/sci-libs/coinor-smi/Manifest
@@ -0,0 +1,5 @@
+DIST Smi-0.93.4.tgz 4907130 SHA256 e63ee0f6f6fd20cd7481d7c88fa60980fc1ce8334032a8f4baaad3a88e63004b SHA512 9439b7421475cf5d0c85f529305657e04d1ebb3eca28399b0df0352b52df315e9dceb3f1410ada0b7a6f9447b0e383116fb208d6447994ce1611f019fcace007 WHIRLPOOL a6f6814420111b2e6cf6ae6251aef44f327372bcbe4dff1f9159f95ec4967a77d7912c10d503f480da91143a94a552993a59b9931e893e6c32c21956f93786e9
+EBUILD coinor-smi-0.93.4.ebuild 1494 SHA256 47382db0bfa7995f75cad2825ce4d11ee436caf122fe5628305e79f0bdcc881f SHA512 744f28ce09afd81c17629a750369556337196b1581744e2c093c3a0d98f30305fd3c248c549ad075a6d929e8f69b165e996effc0a9ca29642a3c3f80109e4f34 WHIRLPOOL f8bd298091dfb3a06d843eb727e9116f8e4d596da92cb7b2b7406a7c1688b223a01a4c951126ae7edfe99a24541064e761abc6640852357160558e50ce6542da
+MISC ChangeLog 2438 SHA256 93c2635f3467013646ff38dbcf377dbf1c05310a501ee0c0aa866b937f850c23 SHA512 a4d50ecd6486b1a2ee032f508c2d23290ae1bb12c0da2c7393d51ca8be2616ccd20d1ce52d0ec680f44177740c263b300372f72290fb2a80479fa84deac3485e WHIRLPOOL d7b90a1107acaba95d2ab44b8cf51798c9022c1ed25165d51f15efcc78e0d81a002c67f9703d21ce07ed71983c4a0df2a7e2d8011c36a930cda4de06647f1efb
+MISC ChangeLog-2015 944 SHA256 8512fa4b88a8bc7182540016e1c45ca985c747b6f7e3396b6f48701ef629975c SHA512 7c86d7e1f706069f88d7410b2f1646ece826fd0ab5a8a1275ac6973ccbd3f686c522e3764d5de3e08a8aaf0aa45a1e1e91577ceb1ece473ded42e9ed338e60b4 WHIRLPOOL 496b380e03ecc8ccb9621f9cd00fc71da89c00ab29eb2a2df33c1dc8695c36a3f9474310446a9a33c33292529865d05622e07deffd03e8b23df86144a38b4a33
+MISC metadata.xml 976 SHA256 bb42b384e8bd84b2de02f2c938fc7f245e600aef3e05b2f70aaa7da8d37399c6 SHA512 b1bec8ccad40e9081d0444de4755b66fca94e515f379a7db2414c45a11f4801eb28bd5aa124eb85b6ab4811b21c6a6453188523a49c391fe5d41a1fb2cd951b8 WHIRLPOOL 1dcaaf41e63c8c09c882472cfe6b591dab24995f9752420189489936194263f8bad469e85966dd456af2461d1308bd866495d7ae119eaff4b536809bc06af4d6
diff --git a/sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild b/sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild
new file mode 100644
index 000000000000..1db6ff49b5e2
--- /dev/null
+++ b/sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+inherit autotools-utils multilib
+
+MYPN=Smi
+
+DESCRIPTION="COIN-OR Stochastic modelling interface"
+HOMEPAGE="https://projects.coin-or.org/Smi/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-cbc:=
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-flopcpp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ cd "${WORKDIR}/${MYPN}-${PV}/doxydoc" || die
+ doxygen doxygen.conf || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${WORKDIR}/${MYPN}-${PV}/doxydoc/html/")
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples flopcpp_examples
+ fi
+}
diff --git a/sci-libs/coinor-smi/metadata.xml b/sci-libs/coinor-smi/metadata.xml
new file mode 100644
index 000000000000..9918603b2e88
--- /dev/null
+++ b/sci-libs/coinor-smi/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ The COIN-OR Stochastic Modeling Interface (SMI) is an interface for
+ problems in which uncertainty and optimization appear
+ together. There are many modeling and algorithmic approaches that
+ could belong here, like: recourse programming, chance constrained
+ programming, stochastic control and dynamic programming, robust
+ optimization, etc, etc. SMI is intended to be like OSI in the sense
+ that an SmiXX object is an implementation derived from a base class
+ that takes care of a number of commonly encountered programming
+ issues, like handling probability distributions, managing problem
+ generation, interacting with solvers to obtain solution information,
+ etc.
+</longdescription>
+</pkgmetadata>