summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-couenne
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sci-libs/coinor-couenne
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sci-libs/coinor-couenne')
-rw-r--r--sci-libs/coinor-couenne/Manifest3
-rw-r--r--sci-libs/coinor-couenne/coinor-couenne-0.5.8-r1.ebuild4
-rw-r--r--sci-libs/coinor-couenne/files/coinor-couenne-0.5.8-fix-build-with-gcc11.patch43
3 files changed, 49 insertions, 1 deletions
diff --git a/sci-libs/coinor-couenne/Manifest b/sci-libs/coinor-couenne/Manifest
index 2784662aa182..43c0218ff534 100644
--- a/sci-libs/coinor-couenne/Manifest
+++ b/sci-libs/coinor-couenne/Manifest
@@ -1,3 +1,4 @@
+AUX coinor-couenne-0.5.8-fix-build-with-gcc11.patch 1497 BLAKE2B edc1886a22c886a667181b42bd8d764f368af22c424a96d326a878104a01600a7b1f155c6a0ae66ccd0b09df39a44d8e6e6acb02ead8cd8c359cd7e173b02463 SHA512 f5a2b371129b5e50567d06794a4907cfc64c688518f931518b653159929c322ec070298d66e45d7443cd9af1cb394d9349b5a8322aa23f4bdb0eff2e3fb1bd9a
DIST coinor-couenne-0.5.8.tar.gz 1321163 BLAKE2B 841a4af3d76fd308ef5abe481157fa1ecf307e7fae03fa0cb931483be74443febc7eb1ba7e85f47c3dca5d5447a74ae86dc0f3dbeb6c0f0032f543861462e0a1 SHA512 bf474503bd77be6536f9d00b40ff45041b3976ea2167d64e667fa580aa8ed6a383861ec67d57eec83623b6542f7779ed7d50d9b72347c3f77ef36a194a3f9e71
-EBUILD coinor-couenne-0.5.8-r1.ebuild 1247 BLAKE2B a0f2baa8d2708464933dd5b10150d83cca76401848a24a3f392d964307e0b0510a5116608925bb30b77fff7691054961bf45c7b73ac4152976dec7e5504c10e5 SHA512 3b6d1de91b30e507a032c467cd70c11fbba63e23e017e074ae035ada6f9882498115373ab8bc562eac92b4f724b78907e41db3210f7dbb8f9cce3ecf3dfac2a0
+EBUILD coinor-couenne-0.5.8-r1.ebuild 1314 BLAKE2B 18b8c8fccced626330a6aabd72c1f1656951c8710a6f85a1481e6f50caedbaef664b4ab5a30daa7adbd9950281810e3db2af95d4f4b5c0bc8f5c359184905b88 SHA512 b3f67f357dce7aa682eb1684ae18012aa76f7868cdf98aff457489ec31b9b9906d2068e92962cbe57a924f9893f95fa51a89adaccab6cda7585240033ade0f50
MISC metadata.xml 700 BLAKE2B 945c3aafd3cc6b2280c64b664cc9a49ccc5be8b9d6dd33c4bb4730c7367e1ad15b25f9fefb968b69f29f2b5cf1e57d8cae3f990db8948d8436385bea67e34212 SHA512 641fa4e5a9bd4f66e42aa86960141e3de0d8f68bc9b01d8235a6be90c1b2c60a262221b0253a366491ed161b8acf114df8549affbc30acd250b89ca3d65105fc
diff --git a/sci-libs/coinor-couenne/coinor-couenne-0.5.8-r1.ebuild b/sci-libs/coinor-couenne/coinor-couenne-0.5.8-r1.ebuild
index 63bb046a3073..cd577558b1c2 100644
--- a/sci-libs/coinor-couenne/coinor-couenne-0.5.8-r1.ebuild
+++ b/sci-libs/coinor-couenne/coinor-couenne-0.5.8-r1.ebuild
@@ -32,6 +32,10 @@ BDEPEND="
virtual/latex-base
)"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.8-fix-build-with-gcc11.patch
+)
+
src_prepare() {
default
# Prevent unneeded call to pkg-config that needs ${ED}'s in path.
diff --git a/sci-libs/coinor-couenne/files/coinor-couenne-0.5.8-fix-build-with-gcc11.patch b/sci-libs/coinor-couenne/files/coinor-couenne-0.5.8-fix-build-with-gcc11.patch
new file mode 100644
index 000000000000..339ce1a0e903
--- /dev/null
+++ b/sci-libs/coinor-couenne/files/coinor-couenne-0.5.8-fix-build-with-gcc11.patch
@@ -0,0 +1,43 @@
+https://bugs.gentoo.org/792798
+
+From debc5de2d0ac9654c01db080448df064b808c56e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 15 Jun 2021 04:24:22 +0000
+Subject: [PATCH] Fix build with GCC 11
+diff --git a/src/problem/CouenneProblem.hpp b/src/problem/CouenneProblem.hpp
+index e5b54a5..db28cfd 100644
+--- a/src/problem/CouenneProblem.hpp
++++ b/src/problem/CouenneProblem.hpp
+@@ -74,7 +74,7 @@ class Nauty;
+ #define COUENNE_EPS_SYMM 1e-8
+
+ struct myclass0 {
+- inline bool operator() (register const Node &a, register const Node &b) {
++ inline bool operator() (register const Node &a, register const Node &b) const {
+
+ return (( a.get_code () < b.get_code ()) ||
+ (( a.get_code () == b.get_code () &&
+@@ -120,7 +120,7 @@ class Nauty;
+
+
+ struct myclass {
+- inline bool operator() (register const Node &a, register const Node &b) {
++ inline bool operator() (register const Node &a, register const Node &b) const {
+ return (a.get_index() < b.get_index() );
+ }
+ };
+
+--- a/src/cut/sdpcuts/CouenneMatrix.hpp
++++ b/src/cut/sdpcuts/CouenneMatrix.hpp
+@@ -69,7 +69,7 @@ namespace Couenne {
+
+ struct compare_scalars {
+ inline bool operator() (register CouenneScalar * const &a,
+- register CouenneScalar * const &b)
++ register CouenneScalar * const &b) const
+ {return a -> getIndex () < b -> getIndex ();}
+ };
+
+--
+2.32.0
+