summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-couenne
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/coinor-couenne
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/coinor-couenne')
-rw-r--r--sci-libs/coinor-couenne/Manifest5
-rw-r--r--sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild58
-rw-r--r--sci-libs/coinor-couenne/metadata.xml15
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-libs/coinor-couenne/Manifest b/sci-libs/coinor-couenne/Manifest
new file mode 100644
index 000000000000..7c29de634cca
--- /dev/null
+++ b/sci-libs/coinor-couenne/Manifest
@@ -0,0 +1,5 @@
+DIST Couenne-0.4.7.tgz 12487353 SHA256 23d058aba7564878ec65cdf8aaba6bec83e3809b31520be1ca014444f25badf6 SHA512 ae87ebee778d6782fffe9e6f6c7c8f604140f6134e29824f89e4f87bb86ac00ac1b2d8de274b23de16078a48a1444fbe7960b15ffefdc1798dca8972a8946deb WHIRLPOOL 21d0d1ff4f9d1ea7daf6976546faf6eeaece5205a171763c71813872bd828696bce6b99d7b222e4dd61a637ee053bf5c1271794815eb4e027e5eecac3ace70de
+EBUILD coinor-couenne-0.4.7.ebuild 1397 SHA256 002301857a8aebfa71090c6fd99c7b2ce9f73e57d26a20c7c4425255afe88d7a SHA512 e3c41e059cd6f55b79623b3beea791374af75f0d84960cfb608f759727edb367fa23e1c20d25b5e4dd74c9778cdb20fef46c6e2d47c858cda41d8c7099b129b1 WHIRLPOOL 3527456c8a0d4c3d296db046c398789d8a876463003cf9e1b68a5882c56cee8c122d5c7de5dde44cfd86879716bc6b77a5f7c6150ee4df3a120a5590897acc59
+MISC ChangeLog 2448 SHA256 5c6339c93dcceabda2bd274ef28dc4374f4f667995913720a18e2d4d11e11fc1 SHA512 0c695814f29b5367143c39c8cbe0a30b3177b195aefdf1fcd32c8159e1e949297507e52eb657d16baf4a3f9044fd1b169c428e907332abd1a9028967db3a24e7 WHIRLPOOL 131459bf31656659a8a4734abbf51517f695c18ecef9eb78b67cd59b12834d3187b0f172bc39579ebb171f964d857d4cb8205a0c2c507db6d017d599c99a58a9
+MISC ChangeLog-2015 697 SHA256 fcc3b64be4017457b2e402e81e268d526816401198b730c1414835dafcbb91a6 SHA512 68e7ddf71c6b49b30ea50adc30df6659565c14a3c9fd302043769848f62378c434a849d7db4460be425187f8eeae20e625bf50d5cbed3e067eae45e10921d11a WHIRLPOOL e2f656c877a526a51093a450c47061c11862154ec8889199539a1c9c6aef13eedbc51f608dc88572e0a3b1b46eb0396d07a9351b2f5f7a5cb5a12dc95cc7498a
+MISC metadata.xml 614 SHA256 1e46ca0c01924b5c32c728fbe278c5468164be23440fc56f60662f48675bd331 SHA512 cdd31b248c01e3ab6c94f4542dd1b5b9cf069d2694e65896031d3457730ae3b5c605661730de615cf46881f776680ee5e3faee16df9fa10b13f288501650b372 WHIRLPOOL c001972594fe73c2d34d281d379b22aa1a376be2ffecb27761059f8407f09a8f5bcd73504ada17f8e3e82003537b425874ef39e04e106a17d43bb813adf8f370
diff --git a/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild b/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild
new file mode 100644
index 000000000000..bff100009493
--- /dev/null
+++ b/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Couenne
+
+DESCRIPTION="COIN-OR Convex Over and Under ENvelopes for Nonlinear Estimation"
+HOMEPAGE="https://projects.coin-or.org/Couenne/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs test"
+
+RDEPEND="sci-libs/coinor-bonmin:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ # resolve as-needed
+ # circular dependencies between libCouenne and libBonCouenne :(
+ pushd "${BUILD_DIR}"/src > /dev/null
+ rm libCouenne.la main/libBonCouenne.la || die
+ emake LIBS+=" -Lmain/.libs -lBonCouenne" libCouenne.la
+ emake -C main
+ popd > /dev/null
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc doc/couenne-user-manual.pdf
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+}
diff --git a/sci-libs/coinor-couenne/metadata.xml b/sci-libs/coinor-couenne/metadata.xml
new file mode 100644
index 000000000000..923d15cb415a
--- /dev/null
+++ b/sci-libs/coinor-couenne/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ Couenne (Convex Over and Under ENvelopes for Nonlinear Estimation)
+ is a spatial branch and bound algorithm that implements linearization, bound
+ reduction, and branching techniques for Mixed-integer, Nonlinear
+ Programming (MINLP) problems. The purpose of Couenne is to find global
+ optima of nonconvex MINLPs.
+</longdescription>
+</pkgmetadata>