summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-cgl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/coinor-cgl
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/coinor-cgl')
-rw-r--r--sci-libs/coinor-cgl/Manifest5
-rw-r--r--sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild67
-rw-r--r--sci-libs/coinor-cgl/metadata.xml15
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-libs/coinor-cgl/Manifest b/sci-libs/coinor-cgl/Manifest
new file mode 100644
index 000000000000..1c47cdcdef20
--- /dev/null
+++ b/sci-libs/coinor-cgl/Manifest
@@ -0,0 +1,5 @@
+DIST Cgl-0.58.6.tgz 5331274 SHA256 1a690475f3dcd5830949d67dae3669ade4b1b5f8415b30d0759b161c26b9a476 SHA512 28fe2e570cb2ebfa3109ca53e5ebb7dd3a38e2ddcfda4d7a9a1d78d4784abe1b6ab79734e6cbcee48e21791fe8353658df47d11253b04366ccb66c3e566db585 WHIRLPOOL 60627feebe64cedfe26c56aae7c432d409e2136d5a5090569577914343a1248b1e8b695d99808676931bb5b27e7cd4270de2aef0db198fb03b3494e23ff382f8
+EBUILD coinor-cgl-0.58.6.ebuild 1452 SHA256 0ae5b97476353e1e6df88d27b879eb023aab4912d500bae5b03b7248f8fea7f3 SHA512 58b84a1d2b0170a8594f4d7b7da5c9b0673c4664d51c2e75c0b85d48a3e90f9521034203c6afae020dac030913d7d1b2843a24b75fa55afce5d29c677c7cf097 WHIRLPOOL eb094a2b035fa9aaea14178fbb5d8ce46f04141812b3e5a12eb78255a1c23a38acd9361feb57f6c5009088082a66019dbc647ab9345c8aecc34b787b2e40f80c
+MISC ChangeLog 2438 SHA256 d24e362ee1a156315a8aaa43821ace115d262b46edb008280bf46889b60dd5ad SHA512 39cdb67566b9fa5970e9bdffa0abfa59d067594e684e81f097d254c43a2b602cb2a5a1f8efcd7196c98ff4139487b71bc45e4686e867a43469cbda483234d622 WHIRLPOOL 51bfdc3ace0b971565af68c6dcac96e0720699e0e7c876e53fdfd7010b5d56d31c273cd60a1ecce3fcfcd332dab2fca5fe63999adcbb08e2d0e5bcd6a9fc2541
+MISC ChangeLog-2015 1908 SHA256 775add9143c9d70441ffe6a097ae9d3057f98fe8a11d14cc0a8ac2dc7c63ca22 SHA512 1992be0133ee57d5776cdf502c9d6d2d984bb7fb8bed941caa1562c07280d01e44d187cd340273b3c9c22f12cd71c7061450933405e3312fad82370d4faaf3f2 WHIRLPOOL 616e916c1de972a0eeb122f45fa9a61b9e78f284fab125e00a8ade16e869c8f829039a9ea534ad9baec8209c7cfd0c4c0aac7db5d09d5aa612c43e25f3eec3ad
+MISC metadata.xml 583 SHA256 96b13676d6117c3cfcd12ffb6098ed715846a501b3e06dcccfb7556056185410 SHA512 80bc5b8688aef02cf6c095765b226b13212b18023aa8911dcf20f9f194882434a5c5d6e3d2d243800c5149305b275b494450ae1206efe0ebf44b10180a3deec6 WHIRLPOOL 97e83c89d5611b6beb28afaf98b28e439b9bb3662cc8450b78656a4beb9e96fc669786eeebf7f94c1eeeca9ecaae19310b932cbff41548a487dacd58e8445db0
diff --git a/sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild b/sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild
new file mode 100644
index 000000000000..d165c14a2d71
--- /dev/null
+++ b/sci-libs/coinor-cgl/coinor-cgl-0.58.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Cgl
+
+DESCRIPTION="COIN-OR cutting-plane generators library"
+HOMEPAGE="https://projects.coin-or.org/Cgl/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-dylp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-vol:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(usex doc doxydoc "")
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-cgl/metadata.xml b/sci-libs/coinor-cgl/metadata.xml
new file mode 100644
index 000000000000..02a1c876c860
--- /dev/null
+++ b/sci-libs/coinor-cgl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ The COIN-OR Cut Generation Library (Cgl) is an open collection of
+ cutting plane implementations ("cut generators") for use in teaching,
+ research, and applications. Cgl can be used with other COIN-OR
+ packages that make use of cuts, such as the mixed-integer linear
+ programming.
+</longdescription>
+</pkgmetadata>