summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-cbc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sci-libs/coinor-cbc
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sci-libs/coinor-cbc')
-rw-r--r--sci-libs/coinor-cbc/Manifest6
-rw-r--r--sci-libs/coinor-cbc/coinor-cbc-2.10.5.ebuild81
-rw-r--r--sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild74
-rw-r--r--sci-libs/coinor-cbc/metadata.xml14
4 files changed, 93 insertions, 82 deletions
diff --git a/sci-libs/coinor-cbc/Manifest b/sci-libs/coinor-cbc/Manifest
index 8599e2ad1d62..4540587388ec 100644
--- a/sci-libs/coinor-cbc/Manifest
+++ b/sci-libs/coinor-cbc/Manifest
@@ -1,3 +1,3 @@
-DIST Cbc-2.8.9.tgz 8231882 BLAKE2B 1af837ae04fa129b605b00d91f80019d4d21148660fa64bd9ae8d7e928ba46508072d0f1e4ff70f30a0bb71f68b716b9d0cbc179900a9da3f58d5bf4fca545ba SHA512 ff537a46a8a266767817bc28d61f4541cfda6e8617c857fa0abef4c0b4ef8fbc728dd195645898d94130dfaedb258789bf55e189a0b9665590958355135f020e
-EBUILD coinor-cbc-2.8.9.ebuild 1818 BLAKE2B 02c82a02efd05dbf406555e762cdb29f0a1945f2edbdff2a4001a85c9bf68616b03831af0db0d06b135aec987af3634a2bbdc9f4c0d7c51727d0afaf6491cdda SHA512 cb028f3dfc609dd808d83de98063d16183e428a3da266dddec36b9db4e13c5d565f8bc2aa3b11c7c5bd41ea4b2f95528aaca3025c5ece4841ba283acdec31c04
-MISC metadata.xml 542 BLAKE2B 55fb8a6a4dc83e233b8e7cc04db618fd400649c253d08132b3aa6eabdbaa00248545948a0d2a15c33aa1587ede280db0a071e8d9f8a9cb08a8bbfd8f8bb185a7 SHA512 194a75891d6f076bf9771fdb55638db5dc0e94fbed8ea0bfaa8ca7b08634fe406635e58bf8773df9c6a54bbf85c0fe829ef8db675044dd899a1eed8020776bc1
+DIST coinor-cbc-2.10.5.tar.gz 1639188 BLAKE2B 92321f0fc0b6eedbb5ebd37cc44d7f10d91d272109474f5ec343e1648b2684dd5cf7002c05d0f72cada1636f9642503ac85165b23ba68caae906fdcad8bcd8f2 SHA512 114ee23ee6e53c337d17bc0930f62d4438e761115e0bf48a04b67732cd82f63dbcc51c3e5b8069bc99bd2e1197b5116ec0be0c2a0a897619c5b79bc1d1751a4e
+EBUILD coinor-cbc-2.10.5.ebuild 1952 BLAKE2B 064e6a4b51b8a39f43f08b2c0349406e6263bd0ac82b5b61a164acc7740170ba20c622872eb077786274ade0458526d9bab3611513edc76e1c0a6820d7ef1589 SHA512 a46b75ff49636db114761818138abb9f8f3b7a392334f1997d00a35c9f9d58a6f13f810699a54bb022578516a0892a6c2d9474fd51eee849f26828c21e1751f9
+MISC metadata.xml 633 BLAKE2B 618045082e1b54cdb063906459597ae42ce6621e9b0da855e7d3d80143fdebb3108b308d37fc7e34426c8baa7ec9cb6fca9349efc81f44af92c25e2e8508dddf SHA512 2abe15b65366a909ed8f2318dcf3feb1b3c7996b27fc1276e28cbe6c9c8853ada176002e13985d9741c6b3254e57c7be3eef85319d3fc91f9e699804ca7e38dc
diff --git a/sci-libs/coinor-cbc/coinor-cbc-2.10.5.ebuild b/sci-libs/coinor-cbc/coinor-cbc-2.10.5.ebuild
new file mode 100644
index 000000000000..694d822204fe
--- /dev/null
+++ b/sci-libs/coinor-cbc/coinor-cbc-2.10.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=Cbc
+
+DESCRIPTION="COIN-OR branch-and-cut mixed integer program solver"
+HOMEPAGE="https://github.com/coin-or/Cbc/"
+SRC_URI="https://github.com/coin-or/${MY_PN}/archive/releases/${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="EPL-1.0"
+
+# major soname component
+SLOT="0/3"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+RESTRICT="!test? ( test )"
+
+# Fortran is NOT needed, but the ./configure scripts for all of the CoinOR
+# packages contain a check for it. Gentoo bug 601648 and upstream issue,
+#
+# https://github.com/coin-or/CoinUtils/issues/132
+#
+BDEPEND="virtual/fortran
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+DEPEND="sci-libs/coinor-clp:=
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-dylp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-vol:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+
+src_prepare() {
+ # Needed to make the --with-coin-instdir in src_configure happy.
+ dodir /usr
+
+ # They don't need to guess at this, but they do, and get it wrong...
+ sed -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ -i configure \
+ || die "failed to fix the pkgconfig path in ${S}/configure"
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}/usr"
+ $(use_with doc dot)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc "")
+}
+
+src_test() {
+ # NOT redundant! The build system has a "make check" target that does
+ # nothing, so if you don't specify "test" here, you'll get a no-op.
+ emake test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+
+ emake DESTDIR="${D}" install
+
+ # Duplicate junk, and in the wrong location.
+ rm -r "${ED}/usr/share/coin/doc/${MY_PN}" || die
+
+ use examples && dodoc -r examples
+}
diff --git a/sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild b/sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild
deleted file mode 100644
index 14beedc5d08e..000000000000
--- a/sci-libs/coinor-cbc/coinor-cbc-2.8.9.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib flag-o-matic
-
-MYPN=Cbc
-
-DESCRIPTION="COIN-OR Branch-and-Cut Mixed Integer Programming Solver"
-HOMEPAGE="https://projects.coin-or.org/Cbc/"
-SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
-
-LICENSE="EPL-1.0"
-SLOT="0/3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- sci-libs/coinor-clp:=
- sci-libs/coinor-cgl:=
- sci-libs/coinor-dylp:=
- sci-libs/coinor-osi:=
- sci-libs/coinor-utils:=
- sci-libs/coinor-vol:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
- test? ( sci-libs/coinor-sample )"
-
-S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
-
-src_prepare() {
- # needed for the --with-coin-instdir
- dodir /usr
- sed -i \
- -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
- configure || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-dependency-linking
- --with-coin-instdir="${ED}"/usr
- $(use_with doc dot)
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- # hack for parallel build, to overcome not patching Makefile.am above
- autotools-utils_src_compile -C src libCbc.la
- autotools-utils_src_compile -C src libCbcSolver.la
- autotools-utils_src_compile all $(usex doc doxydoc "")
-}
-
-src_test() {
- autotools-utils_src_test test
-}
-
-src_install() {
- use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
- # hack for parallel install, to overcome not patching Makefile.am above
- autotools-utils_src_install -C src install-am
- autotools-utils_src_install
- # already installed
- rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sci-libs/coinor-cbc/metadata.xml b/sci-libs/coinor-cbc/metadata.xml
index 4826a4e31bb4..24b280f305a5 100644
--- a/sci-libs/coinor-cbc/metadata.xml
+++ b/sci-libs/coinor-cbc/metadata.xml
@@ -6,9 +6,13 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
- COIN-OR Branch-and-Cut is a Mixed integer linear programming
- solver. It uses many of the COIN-OR components and is designed to be
- used with COIN-OR CLP or COIN-OR Dylp. It is available as a library and as a
- standalone solver.
-</longdescription>
+ COIN-OR Branch-and-Cut is a Mixed integer linear programming
+ solver. It uses many of the COIN-OR components and is designed to be
+ used with COIN-OR CLP or COIN-OR Dylp. It is available as a library and as a
+ standalone solver.
+ </longdescription>
+
+ <upstream>
+ <remote-id type="github">coin-or/Cbc</remote-id>
+ </upstream>
</pkgmetadata>