summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-bcps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/coinor-bcps
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/coinor-bcps')
-rw-r--r--sci-libs/coinor-bcps/Manifest5
-rw-r--r--sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild56
-rw-r--r--sci-libs/coinor-bcps/metadata.xml16
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-libs/coinor-bcps/Manifest b/sci-libs/coinor-bcps/Manifest
new file mode 100644
index 000000000000..f93bba715982
--- /dev/null
+++ b/sci-libs/coinor-bcps/Manifest
@@ -0,0 +1,5 @@
+DIST Bcps-0.93.10.tgz 6270009 SHA256 22c6fbd415fc2a4ca1c98a21c0a909e9fb0fbd8ed472e14bf031f474e0a4fa37 SHA512 4e9348dc1bf75fd9afb74078b55ae0f9a84a99236886552256d7548013c8af4695a4fcc2787ffb0228eba2a870b1cb78c068234048c8650f7d504e1e8d17c549 WHIRLPOOL 7dce76e8bde0d4b266ac597563f04a1e2a290e6d0c1ac9a3ff164a559681f72def1c3009f1b8024b97bac365f0c0b4e63deebfdc2d93f60e9c53075387b85283
+EBUILD coinor-bcps-0.93.10.ebuild 1131 SHA256 4e268dff8a3f1b3175d1073fe49ef035c58cf2dbe8ae622446eca3a3f74db58c SHA512 eeee240cfefd456c18cb8990d2bb381181db256c4dc01c57e619a111c31e545c26e8a199cb97f2a1194bb7a2f7a716548e3b8efd768370de2ffbf3566294d708 WHIRLPOOL 1ebf8b9222d007df4de70de401477204dda4a9fa1aa7360b1703fcc79842277b25b206ac1a1fa544cec6a6bf5638036c2422bba46c86867983aa9b63945da0d7
+MISC ChangeLog 2443 SHA256 67517984f578142b05a024ad683f81be765165a438ba438834d2625cdefdeee5 SHA512 dbc3ec2873ceb8dabf56cf11c3b5f42effe5d73db2bbda4afc3a68b829c96f129c1180e782e93f64124f03bc11d428fc43cc61195b6d9b8a601183c1027534bf WHIRLPOOL b99b928778de0a72b932a01b92fa587e8841ba141a644a1c721ee923aea47f6c7c5338cf5d2853e34c86cd414077cccc722e34092d4355ea7d732b988304f943
+MISC ChangeLog-2015 1219 SHA256 ebf4d452fbe42125d7124b523e95927f7f8a0142f0e859098ffee08e56dc073b SHA512 92659756d6c44423cacf3589f520799a18fed5416eb53bd8939ecba04ddb79d53b20327fed8bc39b5f304b4f5578c45e74335fc05dd8965b5ed4345cb2aae593 WHIRLPOOL 52ba1df6989f1441bac76dcb234cae09e82ba6aa807f1330d1d094c64a1dc62c7c4bf948456bef9f2858a4f7dd91702bcb323a6ba273b4dde7b02a6d9227a394
+MISC metadata.xml 665 SHA256 bcddc0bb8ff7eb1e7cecf0be3f848e81cdcb3b87bd84ef8417cf181758b361b1 SHA512 24ec521cb8142888d8caf95e22399938522da245e167c8adde1cc244e12e0a3dde7d8c4365b03a1890eed9d25ef1f52ff7c75c2a4a7003fba50bd8bc2a2ed3d1 WHIRLPOOL fdccb2250fb19d041247b22a8082a5e86a888f90fc7443b7ada079096d53cf94b98b1b85e45ccabf32a53929864ca56d8fe449a2f98c598db95e124ffe092c49
diff --git a/sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild b/sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild
new file mode 100644
index 000000000000..f9333455ef1b
--- /dev/null
+++ b/sci-libs/coinor-bcps/coinor-bcps-0.93.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Bcps
+
+DESCRIPTION="COIN-OR BiCEPS data handling library"
+HOMEPAGE="https://projects.coin-or.org/CHiPPS/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-alps:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-bcps/metadata.xml b/sci-libs/coinor-bcps/metadata.xml
new file mode 100644
index 000000000000..7f491993f450
--- /dev/null
+++ b/sci-libs/coinor-bcps/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ CHiPPS is the COIN-OR High-Performance Parallel Search Framework, a
+ framework for implementing parallel algorithms based on tree
+ search. The current CHiPPS architecture consists of three
+ layers. The Branch, Constrain, and Price Software (BiCePS) is a data
+ management layer built on top of ALPS for implementing
+ relaxation-based branch and bound algorithms.
+</longdescription>
+</pkgmetadata>