summaryrefslogtreecommitdiff
path: root/sci-libs/cmpfit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sci-libs/cmpfit
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sci-libs/cmpfit')
-rw-r--r--sci-libs/cmpfit/Manifest2
-rw-r--r--sci-libs/cmpfit/cmpfit-1.4.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/cmpfit/Manifest b/sci-libs/cmpfit/Manifest
index 4b09c0e907f6..ba65284ae88a 100644
--- a/sci-libs/cmpfit/Manifest
+++ b/sci-libs/cmpfit/Manifest
@@ -1,3 +1,5 @@
DIST cmpfit-1.2.tar.gz 30431 BLAKE2B 3613fc307b0f1cd792ea9b1436109da77960dcb1985920de2c97e3b8f22d49d68358c0077dd3af5c6d2ea6e7b172d715643221b8df8f84a704688fda2f1ef51a SHA512 232a39538396f166efd9c7a9fc687e0ac8fd3090f871f54fb0c131a1ed02cc05a60904894d853d8eb76d88e70a1fbab4bce3ad0b5990408c77d5a6028a3b466c
+DIST cmpfit-1.4.tar.gz 30659 BLAKE2B f076f69e83d1eb78eda2894cded85f920cef1c95bcb60b042e98d33919e12cac62ffe4ad76ddc9ca0ef17f887289dc37b0bde969e4e04470b491b03b841bbeea SHA512 0a0c869bcf202a0dbc9fd6b6939a6382cc8701f09ca9aada90dde809135c2a8436709a84a8be53696e8d09f49f1d14f80c9d4c8c1c6cd418260939fc0ec5dced
EBUILD cmpfit-1.2-r1.ebuild 1113 BLAKE2B 337ec245d43379a061e9ebdfe3b6f452cf9bac62f33b4c918ae599ba7bc1cf1174fd395a30e17f6eebbdd4138d9962b513c0bd865d528cee508fbe2b829b2b37 SHA512 7b5f03cdf045396ec88611dcc75e8776cb1313d707273a538cd05a10ff61c8f99c7cf5db425f1928d0950be627d0a2cee30156476c7df4ee111fd64a8dc3d54e
+EBUILD cmpfit-1.4.ebuild 896 BLAKE2B 7ee10f67c79d0ba016e53ae5e8dc79fd9fad8d97460d20fa92461976a57024ce9a9d41017d0d67cacdcb625f7d1d8b4b797eddc56f19f99d20a1883641d7a658 SHA512 e1ebcc31bf049818154cde4d96b9197444f0ceeca2c9be7752c057b12915c3c9de8e5cb98b774f7334411e60cf602f41f95f5d1425608e3975d5826bec4bf635
MISC metadata.xml 622 BLAKE2B 28a0413ff6666359d8d905c6a057f53a489f8314b32411de6737e4876c2916a4a48f034f33278aeab54e7d6adc79af8584e40d71af7174b0b90f00ba362e740a SHA512 90f290806ede879fb12e180453c46f76e9f505e7bb61deb72a8a127a8493f08daa6f1b432288e0400b44ceef6346e5cc760940ce45ec1a8a5e5ef80305f6d9e7
diff --git a/sci-libs/cmpfit/cmpfit-1.4.ebuild b/sci-libs/cmpfit/cmpfit-1.4.ebuild
new file mode 100644
index 000000000000..ff93f77a140c
--- /dev/null
+++ b/sci-libs/cmpfit/cmpfit-1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MINPACK-1 Least Squares Fitting Library in C"
+HOMEPAGE="http://www.physics.wisc.edu/~craigm/idl/cmpfit.html"
+SRC_URI="http://www.physics.wisc.edu/~craigm/idl/down/${P}.tar.gz"
+
+LICENSE="public-domain minpack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README DISCLAIMER )
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} -fPIC -c mpfit.c -o mpfit.so || die "PIC compilation failed"
+ $(tc-getCC) ${LDFLAGS} -shared -Wl,-soname=libmpfit.so mpfit.so -lm -o libmpfit.so || die "linking failed"
+}
+
+src_test() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} testmpfit.c -L. -lmpfit -lm -o testmpfit || die
+ LD_LIBRARY_PATH=.:${LD_LIBRARY_PATH} ./testmpfit || die
+}
+
+src_install() {
+ dolib.so libmpfit.so
+ doheader mpfit.h
+ einstalldocs
+}