summaryrefslogtreecommitdiff
path: root/sci-libs/clblast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/clblast
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/clblast')
-rw-r--r--sci-libs/clblast/Manifest3
-rw-r--r--sci-libs/clblast/clblast-0.10.0.ebuild67
-rw-r--r--sci-libs/clblast/metadata.xml25
3 files changed, 95 insertions, 0 deletions
diff --git a/sci-libs/clblast/Manifest b/sci-libs/clblast/Manifest
new file mode 100644
index 000000000000..16d646c1dedb
--- /dev/null
+++ b/sci-libs/clblast/Manifest
@@ -0,0 +1,3 @@
+DIST clblast-0.10.0.tar.gz 508763 SHA256 29914462155dba3f5e4f858f6b36601eb77880e4c04bb7ade48e30afb9bf729b SHA512 da1fc659dd470c02c25be0a009b7f5e2333bc590715ac6b90e09e57a25d764479d7e4ecf398f17d0ac0e6bb2eaf24c09082c7f047fb7b3044f4a987e294494ee WHIRLPOOL 115687fae11cb7586993d0f336bf60644ec3ed8eb3566c8e28921779ee7cf66617259f85cb612638ed888391c7d49209f409dbb0dc4b51aa210388a7c42f3dce
+EBUILD clblast-0.10.0.ebuild 1506 SHA256 410bb22903291a5ff68cfcba7ffa6764824fe3a4a1e5e1756b05b4bf070c8001 SHA512 fc6b562cba51fdc93f80a266857d33d733d4132d4e7c84d1c8ecac5c7daa8881fed4856f498f56f21674b24a7d98bbe295c46038c4c67ff864160168f6562de5 WHIRLPOOL 84dc6903a75889404ccca42a964f2e59a48ceccedd6bc5ee3ccfcd5ed4f8a2d635a8d477ce9fc87ad93283cf4e2a85668b0dfabf938aadc8873f2e71fdfb1aa3
+MISC metadata.xml 954 SHA256 d7425d86ed45f383f7d90cd3909a018fe8dfcb34fc82343507f5b3d2807c8d6a SHA512 32637508226381a330fbc29874d5d6a157860f16846b0927f9530cc8f2a36c64f40c483ea89d27671f13f600fd560b1d0314846d55a73cf8a2263c7c5860564c WHIRLPOOL aced26e89906f526cdf57eda7b1485d825706e1ded54b60e9bacf573ed49bd8f33d7551878bf84f49988add48195b6b2829d95cd096785bec1e6dd4ab1db6c2b
diff --git a/sci-libs/clblast/clblast-0.10.0.ebuild b/sci-libs/clblast/clblast-0.10.0.ebuild
new file mode 100644
index 000000000000..0327840fce5b
--- /dev/null
+++ b/sci-libs/clblast/clblast-0.10.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs
+
+MYPN="CLBlast"
+
+DESCRIPTION="Tuned OpenCL BLAS"
+HOMEPAGE="https://github.com/CNugteren/CLBlast"
+SRC_URI="https://github.com/CNugteren/${MYPN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="client doc examples test"
+
+RDEPEND="virtual/opencl"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/cblas
+ virtual/pkgconfig
+ )
+"
+S="${WORKDIR}/${MYPN}-${PV}"
+
+src_prepare() {
+ # no forced optimisation, libdir
+ sed -e 's/-O3//g' \
+ -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/g' \
+ -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=ON
+ -DSAMPLES=OFF
+ -DCLIENTS="$(usex client)"
+ -DTESTS="$(usex test)"
+ )
+ if use test || use client; then
+ mycmakeargs+=(
+ -DNETLIB=ON
+ -DCBLAS_INCLUDE_DIRS="$($(tc-getPKG_CONFIG) --cflags-only-I cblas| awk '{print $1}' | sed 's/-I//')"
+ -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs cblas)"
+ -DREF_LIBRARIES="$($(tc-getPKG_CONFIG) --libs cblas)"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test alltests
+}
+
+src_install(){
+ cmake-utils_src_install
+ dodoc README.md CONTRIBUTING.md CHANGELOG
+ use doc && dodoc -r doc
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/sci-libs/clblast/metadata.xml b/sci-libs/clblast/metadata.xml
new file mode 100644
index 000000000000..d5ff3a6625c9
--- /dev/null
+++ b/sci-libs/clblast/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ CLBlast is a modern, lightweight, performant and tunable OpenCL
+ BLAS library written in C++11. It is designed to leverage the full
+ performance potential of a wide variety of OpenCL devices from
+ different vendors, including desktop and laptop GPUs, embedded
+ GPUs, and other accelerators. CLBlast implements BLAS routines:
+ basic linear algebra subprograms operating on vectors and
+ matrices.
+ </longdescription>
+ <use>
+ <flag name="client">
+ Enable compilation of the clients to test and compare performance with reference libraries
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">CNugteren/CLBlast</remote-id>
+ </upstream>
+</pkgmetadata>