summaryrefslogtreecommitdiff
path: root/sci-libs/clapack/clapack-3.2.1-r8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/clapack/clapack-3.2.1-r8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/clapack/clapack-3.2.1-r8.ebuild')
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r8.ebuild b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
new file mode 100644
index 000000000000..ac9a2c73f97e
--- /dev/null
+++ b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic cmake-utils
+
+DESCRIPTION="f2c'ed version of LAPACK"
+HOMEPAGE="http://www.netlib.org/clapack/"
+SRC_URI="http://www.netlib.org/${PN}/${P}-CMAKE.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/libf2c-20090407-r1
+ virtual/blas"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-CMAKE
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix_include_file.patch"
+ "${FILESDIR}/${P}-noblasf2c.patch"
+ "${FILESDIR}/${P}-hang.patch"
+ "${FILESDIR}/${P}-findblas-r7.patch"
+)
+
+# bug 433806
+RESTRICT="test"
+
+src_prepare() {
+ rm INCLUDE/f2c.h F2CLIBS/libf2c/f2c.h || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ filter-flags -ftree-vectorize
+ # causes an internal compiler error with gcc-4.6.2
+
+ local mycmakeargs=( -DENABLE_TESTS=$(usex test) )
+ cmake-utils_src_configure
+}