summaryrefslogtreecommitdiff
path: root/sci-libs/cgcode/cgcode-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/cgcode/cgcode-1.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/cgcode/cgcode-1.0-r2.ebuild')
-rw-r--r--sci-libs/cgcode/cgcode-1.0-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/cgcode/cgcode-1.0-r2.ebuild b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
new file mode 100644
index 000000000000..90160c444ea9
--- /dev/null
+++ b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Conjugate gradient Codes for large sparse linear systems"
+HOMEPAGE="http://fetk.org/codes/cgcode/index.html"
+SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="virtual/blas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+
+ cat >> make.inc <<- EOF
+ F77 = $(tc-getFC)
+ FFLAGS = ${FFLAGS}
+ BLASLIBS = $($(tc-getPKG_CONFIG) --libs blas)
+ EOF
+}
+
+src_install() {
+ dobin goos good
+ dolib.so src/lib${PN}.so*
+ dodoc INTRODUCTION NOTE README
+}