summaryrefslogtreecommitdiff
path: root/sci-libs/cddlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /sci-libs/cddlib
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'sci-libs/cddlib')
-rw-r--r--sci-libs/cddlib/Manifest2
-rw-r--r--sci-libs/cddlib/cddlib-094m-r1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/cddlib/Manifest b/sci-libs/cddlib/Manifest
index 79a9f0b72419..85fe4eaae6e5 100644
--- a/sci-libs/cddlib/Manifest
+++ b/sci-libs/cddlib/Manifest
@@ -1,3 +1,5 @@
DIST cddlib-0.94j.tar.gz 1364746 BLAKE2B 60e81fccf8abd8d60fb7261d1d2d61b7ad2b60285e7dfa760905e2cb5b01f1570c27920728c12fc6994135e4b29ba8e1709066ddf2e2eff00f8f48b093ebd43e SHA512 b82d5e06538a29143a79f7ba7287a1784292e28f086071041e500fd81387a30c3fca6fae9049752f57b62d50b385d73681276d42d24941e3a43893da00452ea6
+DIST cddlib-0.94m.tar.gz 1351298 BLAKE2B 0e1931ba94771f0dcae0ee10b003940ca331839eb8ce001ab02c4f1b382dde74d7dfcf74f4c62e1ae7214a3139547c09f56ef0cba5df74fc03a63ab741b64690 SHA512 50997bda38c36990456345881dc1eac65b1880aa510ea3812ae46a122ba7696bf3577f2b6976ff16811ee00f0a920c8ed6f1e7de0a4060bfaa96def11bab816e
EBUILD cddlib-094j.ebuild 1396 BLAKE2B 032b697c46fd170dea85951451389f30fafe5ec67cee387583514bc8cff83ee8e5bf570308078f14deb88d42821bfaae6f8f847aa4e8df83827a00f81f413f2b SHA512 3fe5afeedefabaae12a1becc1ec735020802cf4b4b8184591a4b51c34147b087fbcf1a4a46c246ddf84a7dd320c056f70d6739a13c76d662776755e9dc125c74
+EBUILD cddlib-094m-r1.ebuild 1399 BLAKE2B fec8c8359926846a124768cbdc19980875d3eee21dadeb222b80d1ff5d84d9378ad1a86e81166c9c29b6610e27e6f81fdabe6abf49a0b19d459f8f160dd74740 SHA512 ccfb6aff7ea4070c2f692a827331f7a4e1d8e9efd40b1940cdec82b146efbc8b930ecd50c78986b40a8344b8d5272ae8e26ab92d8ecf2ec7ed2d4ee1d872395c
MISC metadata.xml 1817 BLAKE2B 3a75a0a27708d31cf58ec067ad25ffce663b3d52f90dd2437ce529bb4babf49a6e0461eee6841ef836f37caa2f7e4f62a762ea61094213fe10f9cd1e16951d99 SHA512 a50ed995ba248cf59ae3b2c2d5a8f91df9b08bd03cb48a14de0eabc79b44091d425b41d980952ac3eea6182e12ca235985f347bb67ac109993a47a545d1c4289
diff --git a/sci-libs/cddlib/cddlib-094m-r1.ebuild b/sci-libs/cddlib/cddlib-094m-r1.ebuild
new file mode 100644
index 000000000000..0bacae1be5cb
--- /dev/null
+++ b/sci-libs/cddlib/cddlib-094m-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This should have been dealt with versionator in the direction
+# 0.94x -> 094x - now we are screwed.
+MY_PV="0.94m"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="C library implementing the Double Description Method"
+HOMEPAGE="https://www.inf.ethz.ch/personal/fukudak/cdd_home/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs tools"
+
+DEPEND="dev-libs/gmp:0"
+RDEPEND="dev-libs/gmp:0="
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use tools; then
+ rm "${ED}"/usr/bin/* || die
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ # Nobody wants the dvi/ps manual...
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.{dvi,ps} || die
+
+ # since the PDF manual is installed by default.
+ if ! use doc; then
+ rm "${ED}/usr/share/doc/${PF}"/cddlibman.pdf || die
+ fi
+
+ # The docs and examples are *both* installed by default, so we
+ # have to remove the examples if the user doesn't want them.
+ docompress -x "/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d}
+ if ! use examples; then
+ rm -r "${ED}/usr/share/doc/${PF}"/examples{,-ext,-ine,-ine3d} || die
+ fi
+}