summaryrefslogtreecommitdiff
path: root/sci-libs/ccolamd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 07:15:41 +0100
commit7d1fc8f13082082c2539f20beadcf37089543b8e (patch)
treefda7c412f8ace82836e911da18f1b0f6eaf8bc55 /sci-libs/ccolamd
parentbc4457d8e0e53a2e43c4254d08053ba9708663e1 (diff)
gentoo auto-resync : 20:06:2023 - 07:15:40
Diffstat (limited to 'sci-libs/ccolamd')
-rw-r--r--sci-libs/ccolamd/Manifest4
-rw-r--r--sci-libs/ccolamd/ccolamd-3.0.3.ebuild39
-rw-r--r--sci-libs/ccolamd/metadata.xml3
3 files changed, 45 insertions, 1 deletions
diff --git a/sci-libs/ccolamd/Manifest b/sci-libs/ccolamd/Manifest
index 3dfa3b82f5c8..0a408504c26f 100644
--- a/sci-libs/ccolamd/Manifest
+++ b/sci-libs/ccolamd/Manifest
@@ -1,3 +1,5 @@
+DIST SuiteSparse-7.0.0.gh.tar.gz 64884962 BLAKE2B 06c6cf54ffae188f5179e0cd45523700448d8999b44d6b1aeb3dfb99ccf34a570f6aff600988a144c68a4a2d8f41e32f7145e09349aed3bd889501ea031c8340 SHA512 50b1cd7bab6e4c063984162ed803fd13b69df7f67efe8ce7af15eace6b0ccd1669b6e57daa59511fd9531a847433cda49c1f52bfff234031af0d79e7fbd6423e
DIST ccolamd-2.9.6.tar.bz2 305744 BLAKE2B 0d741ead328a1e888715672ddb617cc96a559f46f2379e1d7792b70868dd290de19b3047e3ed4dd2711084c9afc523d18ecb375aa4ee8a4a12950cee08f238b8 SHA512 cf6f210d26ddb1be454cac377a773b73b75261a74e1e3985565f57f45659b1c11b747829c5bbe99c4bc3e8b364d7b2b3c109e00f6d7e8e41afd713312ebf103c
EBUILD ccolamd-2.9.6.ebuild 668 BLAKE2B c6896bb58d48e25208ff70abb75e43987dcb0642e1484c2ae1652c141c65d50a0c3e43294ed3ed0f3b215bfc18baccb01234020a9e740d040afc311a807bd390 SHA512 76b30d1702c9c4b1af08f7f68c6d03daaefe8287fae24b2b8f5d85d0a29a1079926c152ed6c63aa435ea11d5829744fb906e7e8907d2f2d9ec8893e151c6c432
-MISC metadata.xml 473 BLAKE2B 92cd065e76780f675bf6fad90be6a6e7716470967311a44f53fd53386d904a31831ba63aecf37e2d4c6a0f0f35ba24b930300caeba094f6c5689d051047eaf97 SHA512 d8ef080f457b756ea12a610f0dbb70fd6b58c019807beabe6efeb673f8303ac1c61d0ff36390c7bcf8e1305395f452729b08823ecbcd63fb39b4b4b8399e0e2b
+EBUILD ccolamd-3.0.3.ebuild 1280 BLAKE2B cf174de15f0eaee0d3b7dd8a1e60f7bd5d78775bb1e52931bb3d5097ee6ceb0c5346551737dd671d1f80f97527a65c38c32e44e57bee1e0466250283741f7633 SHA512 a4c6e36fd8c1faa7e390365c3537bcba7aa4b08744f71047ff6b7a842339413112bdc87e669aaf1c4c646f45369dc28ee6219d44b392724e1ee40a79d9477196
+MISC metadata.xml 573 BLAKE2B 8bab3f7e16cef01f3c01bb2ea89cb3295566a065b2fcf65aed74514081532e389340b23510d49329986adcaa0d166343a7dad6f81c0a740e90dfc9149346f4c5 SHA512 739b9296bbe2dd51fa6e1ae2de7792fa7bab305276ce38964cf6cb460dd37d50be2e549509012d3ee7542afe010b6bea066c92e0cb4622f2508868f6ca1d38d0
diff --git a/sci-libs/ccolamd/ccolamd-3.0.3.ebuild b/sci-libs/ccolamd/ccolamd-3.0.3.ebuild
new file mode 100644
index 000000000000..30e5af46ce42
--- /dev/null
+++ b/sci-libs/ccolamd/ccolamd-3.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+Sparse_PV="7.0.0"
+Sparse_P="SuiteSparse-${Sparse_PV}"
+DESCRIPTION="Constrained Column approximate minimum degree ordering algorithm"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-libs/suitesparseconfig-7.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${Sparse_P}/${PN^^}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNSTATIC=ON
+ -DDEMO=$(usex test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ # Run demo files
+ ./ccolamd_example > ccolamd_example.out || die "failed to run test ccolamd_example"
+ diff "${S}"/Demo/ccolamd_example.out ccolamd_example.out || die "failed testing ccolamd_example"
+ ./ccolamd_l_example > ccolamd_l_example.out || die "failed to run test ccolamd_l_example"
+ diff "${S}"/Demo/ccolamd_l_example.out ccolamd_l_example.out || die "failed testing ccolamd_l_example"
+}
diff --git a/sci-libs/ccolamd/metadata.xml b/sci-libs/ccolamd/metadata.xml
index 412ff61d06aa..ba6e076c8fbd 100644
--- a/sci-libs/ccolamd/metadata.xml
+++ b/sci-libs/ccolamd/metadata.xml
@@ -10,4 +10,7 @@
algorithm, (like COLAMD), but it can also be given a set of ordering
constraints.
</longdescription>
+ <upstream>
+ <remote-id type="github">DrTimothyAldenDavis/SuiteSparse</remote-id>
+ </upstream>
</pkgmetadata>