summaryrefslogtreecommitdiff
path: root/sci-libs/camd/camd-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/camd/camd-2.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/camd/camd-2.3.1.ebuild')
-rw-r--r--sci-libs/camd/camd-2.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/camd/camd-2.3.1.ebuild b/sci-libs/camd/camd-2.3.1.ebuild
new file mode 100644
index 000000000000..acd75e0feb53
--- /dev/null
+++ b/sci-libs/camd/camd-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/camd/"
+SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc)
+ )
+ autotools-utils_src_configure
+}