summaryrefslogtreecommitdiff
path: root/sci-libs/branca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
commita2210d6624510ad5825191a26603b73bbc096b98 (patch)
tree532ae6f32e362993fd926b040ad57cabe1c8d4e8 /sci-libs/branca
parent7ab79528a3e9a77497eb58022bb0e775e7440885 (diff)
gentoo auto-resync : 27:12:2023 - 01:38:47
Diffstat (limited to 'sci-libs/branca')
-rw-r--r--sci-libs/branca/Manifest4
-rw-r--r--sci-libs/branca/branca-0.6.0-r1.ebuild2
-rw-r--r--sci-libs/branca/branca-0.7.0.ebuild30
3 files changed, 34 insertions, 2 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
index a910c064a92e..357b0ec6a0fb 100644
--- a/sci-libs/branca/Manifest
+++ b/sci-libs/branca/Manifest
@@ -1,4 +1,6 @@
AUX branca-0.6.0-test.patch 333 BLAKE2B bdf1a556ff4b2e8b023a216a84af4b97cefe1c86177504f93882f1f68d66647de120ca58c8a40322a908e7fd03ea5ca96933fb8618457bb6b2fc18dd2983825b SHA512 eeb8c56922a5e35cb092d5362bec3fdf4f516ba38e7febdb37d672686f21165bcb5213d739ca52494eca2d5017736bb4a3495d91aa80612413fd86d900ffe0dd
DIST branca-0.6.0.tar.gz 40167 BLAKE2B 23cbe442862e9575d84dfb5bb1760acf2a1301be0f68bedc9965d9d3a8be090755f78640ed919b5ba8521ab30e8c52c69ea87ff2772d9fd6b3e338680b5219bb SHA512 e80b3d173bc487857ab42d10365540e91cb6fc5def61bb76f418e2da8e74c9bf69e0ca46f86a47f96f5db48d0e98d6ad3091107dd1a5ca479c52adbfa3a79a9c
-EBUILD branca-0.6.0-r1.ebuild 769 BLAKE2B fc2fcf07b90f5aae786780307fc325d26cfa62a5c78583a1f237200f7daf2895dd2d95cc2ea3efad6dd13fe15a1badbf4391105193959ce297a90a29fcd06587 SHA512 c7787873e98d452d61606e60a821267af96db41c2f1173b8b18b429c72c33aee1938cf99db086740211dcacd5b114dc082b4f4ff4ab9440cad0f1ce19e45670d
+DIST branca-0.7.0.tar.gz 42990 BLAKE2B b8de083b0b94d35dbb6df5d230e388832fe027d756767d24ae8091f25d9846ac1f2ae72799aa83583c99ec02d955c7f8cb80183f1543e503d0a802ce051acac5 SHA512 bfe6afd93752dda57e55ba7bdd433e079b51798056b2be8d9c19d4ccc4ed94cc95b733cabf0981c908887c1f8a96e16bd11cb1b495243ac91df4c1c1c1253282
+EBUILD branca-0.6.0-r1.ebuild 794 BLAKE2B 22cba0727b61934e27353d64747c992f12858cb0832a538b946ab149ce3866739b659f19112dfeff7cc114672e39d4c00eadb0521689c7219db823dc09a35f9f SHA512 5fca1b75a0b668447c8bbaaf4584a6d6a7285b3075e2328ed7b6997ecc7451fa58681adf787e66637664be00e443022e91107402f39fca7594266e81ad1c86be
+EBUILD branca-0.7.0.ebuild 801 BLAKE2B e93f738635bfff9cea91aef20fb41bdc9b454ac4528b9a9683ea09ebcdb82fcd1fc81c63807f1da4a0a64c6b7fa0f0f51e070c1c79b771b26058b8e78a6c28a5 SHA512 79f9d377cb55fb540dd6989a0d1c7fed445dfd268e2e58519be7905c0ab71ad209918e4d684869760cfdbc0b61f1623ac45ce86fb0df7c4846d43bd28783060e
MISC metadata.xml 567 BLAKE2B a65dec67ea324de3bd665152174cd5d8ca121d2775e9e6db7d15f2c1a2b60058f8788769d2cd4ae54d454b667b9581fe84006b2eebfde99ccdb63ed5d015ff6c SHA512 9cff06968cb58902bc68dab33859310746e7fba3420a53f04c6fa45c5aeda061a68c41343b71240670b21d116d80fe9e6d40c7ba281e2910b7a95caebfcd5dd8
diff --git a/sci-libs/branca/branca-0.6.0-r1.ebuild b/sci-libs/branca/branca-0.6.0-r1.ebuild
index 91ea6850fcc5..7403664fb4dc 100644
--- a/sci-libs/branca/branca-0.6.0-r1.ebuild
+++ b/sci-libs/branca/branca-0.6.0-r1.ebuild
@@ -21,7 +21,7 @@ PATCHES=( "${FILESDIR}"/${P}-test.patch )
RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/selenium[${PYTHON_USEDEP}] )"
-BDEPEND=""
+BDEPEND="dev-python/setuptools-scm"
distutils_enable_tests pytest
diff --git a/sci-libs/branca/branca-0.7.0.ebuild b/sci-libs/branca/branca-0.7.0.ebuild
new file mode 100644
index 000000000000..7b3846dbca34
--- /dev/null
+++ b/sci-libs/branca/branca-0.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features"
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.0-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/selenium[${PYTHON_USEDEP}] )"
+BDEPEND="dev-python/setuptools-scm"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not headless'
+}