summaryrefslogtreecommitdiff
path: root/sci-libs/blas-reference/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/blas-reference/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/blas-reference/files')
-rw-r--r--sci-libs/blas-reference/files/blas-reference-20070226-autotool.patch243
-rw-r--r--sci-libs/blas-reference/files/blas-reference-20070226-pkg-config.patch11
-rw-r--r--sci-libs/blas-reference/files/eselect.blas.reference4
-rw-r--r--sci-libs/blas-reference/files/eselect.blas.reference-r14
-rw-r--r--sci-libs/blas-reference/files/lapack-reference-3.6.0-fix-build-system.patch92
-rw-r--r--sci-libs/blas-reference/files/lapack-reference-3.7.0-fix-build-system.patch56
6 files changed, 410 insertions, 0 deletions
diff --git a/sci-libs/blas-reference/files/blas-reference-20070226-autotool.patch b/sci-libs/blas-reference/files/blas-reference-20070226-autotool.patch
new file mode 100644
index 000000000000..8d8192fc0254
--- /dev/null
+++ b/sci-libs/blas-reference/files/blas-reference-20070226-autotool.patch
@@ -0,0 +1,243 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2007-07-16 10:14:29.000000000 +0100
+@@ -0,0 +1,14 @@
++AC_PREREQ(2.59)
++AC_INIT(blas, 20070226, lapack@cs.utk.edu)
++AM_INIT_AUTOMAKE([foreign])
++
++AC_LANG(Fortran 77)
++AC_PROG_F77
++AC_PROG_LIBTOOL
++
++AC_CONFIG_FILES([Makefile
++ BLAS/Makefile
++ BLAS/SRC/Makefile
++ BLAS/TESTING/Makefile
++ BLAS/blas.pc])
++AC_OUTPUT
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2007-07-16 01:51:11.000000000 +0100
+@@ -0,0 +1 @@
++SUBDIRS = BLAS
+--- BLAS/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ BLAS/Makefile.am 2007-08-14 11:38:42.000000000 +0100
+@@ -0,0 +1,7 @@
++SUBDIRS = SRC TESTING
++
++pkgconfigdir = $(libdir)
++pkgconfig_DATA = blas.pc
++
++EXTRA = blas.pc
++
+--- BLAS/blas.pc.in 1970-01-01 01:00:00.000000000 +0100
++++ BLAS/blas.pc.in 2007-08-17 11:38:23.000000000 +0100
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: Basic Linear Algebra Subprograms F77 reference implementations
++Version: @PACKAGE_VERSION@
++URL: http://www.netlib.org/blas
++Libs: -lblas
++Libs.private: -lm
+--- BLAS/SRC/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ BLAS/SRC/Makefile.am 2007-07-16 01:50:12.000000000 +0100
+@@ -0,0 +1,153 @@
++lib_LTLIBRARIES = libblas.la
++
++libblas_la_SOURCES = \
++ caxpy.f \
++ ccopy.f \
++ cdotc.f \
++ cdotu.f \
++ cgbmv.f \
++ cgemm.f \
++ cgemv.f \
++ cgerc.f \
++ cgeru.f \
++ chbmv.f \
++ chemm.f \
++ chemv.f \
++ cher2.f \
++ cher2k.f \
++ cher.f \
++ cherk.f \
++ chpmv.f \
++ chpr2.f \
++ chpr.f \
++ crotg.f \
++ cscal.f \
++ csrot.f \
++ csscal.f \
++ cswap.f \
++ csymm.f \
++ csyr2k.f \
++ csyrk.f \
++ ctbmv.f \
++ ctbsv.f \
++ ctpmv.f \
++ ctpsv.f \
++ ctrmm.f \
++ ctrmv.f \
++ ctrsm.f \
++ ctrsv.f \
++ dasum.f \
++ daxpy.f \
++ dcabs1.f \
++ dcopy.f \
++ ddot.f \
++ dgbmv.f \
++ dgemm.f \
++ dgemv.f \
++ dger.f \
++ dnrm2.f \
++ drot.f \
++ drotg.f \
++ drotm.f \
++ drotmg.f \
++ dsbmv.f \
++ dscal.f \
++ dsdot.f \
++ dspmv.f \
++ dspr2.f \
++ dspr.f \
++ dswap.f \
++ dsymm.f \
++ dsymv.f \
++ dsyr2.f \
++ dsyr2k.f \
++ dsyr.f \
++ dsyrk.f \
++ dtbmv.f \
++ dtbsv.f \
++ dtpmv.f \
++ dtpsv.f \
++ dtrmm.f \
++ dtrmv.f \
++ dtrsm.f \
++ dtrsv.f \
++ dzasum.f \
++ dznrm2.f \
++ icamax.f \
++ idamax.f \
++ isamax.f \
++ izamax.f \
++ lsame.f \
++ scabs1.f \
++ sasum.f \
++ saxpy.f \
++ scasum.f \
++ scnrm2.f \
++ scopy.f \
++ sdot.f \
++ sdsdot.f \
++ sgbmv.f \
++ sgemm.f \
++ sgemv.f \
++ sger.f \
++ snrm2.f \
++ srot.f \
++ srotg.f \
++ srotm.f \
++ srotmg.f \
++ ssbmv.f \
++ sscal.f \
++ sspmv.f \
++ sspr2.f \
++ sspr.f \
++ sswap.f \
++ ssymm.f \
++ ssymv.f \
++ ssyr2.f \
++ ssyr2k.f \
++ ssyr.f \
++ ssyrk.f \
++ stbmv.f \
++ stbsv.f \
++ stpmv.f \
++ stpsv.f \
++ strmm.f \
++ strmv.f \
++ strsm.f \
++ strsv.f \
++ xerbla.f \
++ zaxpy.f \
++ zcopy.f \
++ zdotc.f \
++ zdotu.f \
++ zdrot.f \
++ zdscal.f \
++ zgbmv.f \
++ zgemm.f \
++ zgemv.f \
++ zgerc.f \
++ zgeru.f \
++ zhbmv.f \
++ zhemm.f \
++ zhemv.f \
++ zher2.f \
++ zher2k.f \
++ zher.f \
++ zherk.f \
++ zhpmv.f \
++ zhpr2.f \
++ zhpr.f \
++ zrotg.f \
++ zscal.f \
++ zswap.f \
++ zsymm.f \
++ zsyr2k.f \
++ zsyrk.f \
++ ztbmv.f \
++ ztbsv.f \
++ ztpmv.f \
++ ztpsv.f \
++ ztrmm.f \
++ ztrmv.f \
++ ztrsm.f \
++ ztrsv.f
+--- BLAS/TESTING/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ BLAS/TESTING/Makefile.am 2007-07-16 01:50:12.000000000 +0100
+@@ -0,0 +1,27 @@
++TESTS = blas_tests
++
++blas_tests:
++ @install -m0755 blas_tests.sh blas_tests
++
++check_PROGRAMS = \
++ xsblat1 xdblat1 xcblat1 xzblat1 \
++ xsblat2 xdblat2 xcblat2 xzblat2 \
++ xsblat3 xdblat3 xcblat3 xzblat3
++
++LDADD = $(top_builddir)/BLAS/SRC/libblas.la
++
++xsblat1_SOURCES = sblat1.f
++xdblat1_SOURCES = dblat1.f
++xcblat1_SOURCES = cblat1.f
++xzblat1_SOURCES = zblat1.f
++
++xsblat2_SOURCES = sblat2.f
++xdblat2_SOURCES = dblat2.f
++xcblat2_SOURCES = cblat2.f
++xzblat2_SOURCES = zblat2.f
++
++xsblat3_SOURCES = sblat3.f
++xdblat3_SOURCES = dblat3.f
++xcblat3_SOURCES = cblat3.f
++xzblat3_SOURCES = zblat3.f
++
+--- BLAS/TESTING/blas_tests.sh 1970-01-01 01:00:00.000000000 +0100
++++ BLAS/TESTING/blas_tests.sh 2007-07-16 01:50:12.000000000 +0100
+@@ -0,0 +1,9 @@
++#!/bin/sh
++
++for t in cblat1 sblat1 dblat1 zblat1; do
++ ./x${t}
++done
++
++for t in cblat2 sblat2 dblat2 zblat2 cblat3 sblat3 dblat3 zblat3; do
++ ./x${t} < ../${t}.in
++done
diff --git a/sci-libs/blas-reference/files/blas-reference-20070226-pkg-config.patch b/sci-libs/blas-reference/files/blas-reference-20070226-pkg-config.patch
new file mode 100644
index 000000000000..14190f41e7d5
--- /dev/null
+++ b/sci-libs/blas-reference/files/blas-reference-20070226-pkg-config.patch
@@ -0,0 +1,11 @@
+diff --git a/BLAS/blas.pc.in b/BLAS/blas.pc.in
+index 367c87b..44b86db 100644
+--- a/BLAS/blas.pc.in
++++ b/BLAS/blas.pc.in
+@@ -7,5 +7,5 @@ Name: @PACKAGE_NAME@
+ Description: Basic Linear Algebra Subprograms F77 reference implementations
+ Version: @PACKAGE_VERSION@
+ URL: http://www.netlib.org/blas
+-Libs: -lblas
++Libs: -L@libdir@ -lblas
+ Libs.private: -lm
diff --git a/sci-libs/blas-reference/files/eselect.blas.reference b/sci-libs/blas-reference/files/eselect.blas.reference
new file mode 100644
index 000000000000..edb10ddd10d9
--- /dev/null
+++ b/sci-libs/blas-reference/files/eselect.blas.reference
@@ -0,0 +1,4 @@
+blas/reference/libblas.so /usr/@LIBDIR@/libblas.so
+blas/reference/libblas.so.0 /usr/@LIBDIR@/libblas.so.0
+blas/reference/libblas.a /usr/@LIBDIR@/libblas.a
+../blas/reference/blas.pc /usr/@LIBDIR@/pkgconfig/blas.pc
diff --git a/sci-libs/blas-reference/files/eselect.blas.reference-r1 b/sci-libs/blas-reference/files/eselect.blas.reference-r1
new file mode 100644
index 000000000000..f032181beb67
--- /dev/null
+++ b/sci-libs/blas-reference/files/eselect.blas.reference-r1
@@ -0,0 +1,4 @@
+blas/reference/libblas.so /usr/@LIBDIR@/libblas.so
+blas/reference/libblas.so.3 /usr/@LIBDIR@/libblas.so.3
+blas/reference/libblas.a /usr/@LIBDIR@/libblas.a
+../blas/reference/blas.pc /usr/@LIBDIR@/pkgconfig/blas.pc
diff --git a/sci-libs/blas-reference/files/lapack-reference-3.6.0-fix-build-system.patch b/sci-libs/blas-reference/files/lapack-reference-3.6.0-fix-build-system.patch
new file mode 100644
index 000000000000..8661709d369b
--- /dev/null
+++ b/sci-libs/blas-reference/files/lapack-reference-3.6.0-fix-build-system.patch
@@ -0,0 +1,92 @@
+--- lapack-3.6.0/BLAS/blas.pc.in
++++ lapack-3.6.0/BLAS/blas.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: blas
+ Description: Basic Linear Algebra Subprograms F77 reference implementations
+--- lapack-3.6.0/BLAS/CMakeLists.txt
++++ lapack-3.6.0/BLAS/CMakeLists.txt
+@@ -2,7 +2,7 @@
+ if(BUILD_TESTING)
+ add_subdirectory(TESTING)
+ endif(BUILD_TESTING)
+-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/blas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/blas.pc)
++configure_file(${CMAKE_CURRENT_SOURCE_DIR}/blas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/blas.pc @ONLY)
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/blas.pc
+ DESTINATION ${PKG_CONFIG_DIR}
+--- lapack-3.6.0/CBLAS/cblas.pc.in
++++ lapack-3.6.0/CBLAS/cblas.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: lapacke
+ Description: C Standard Interface to BLAS Linear Algebra PACKage
+--- lapack-3.6.0/CBLAS/CMakeLists.txt
++++ lapack-3.6.0/CBLAS/CMakeLists.txt
+@@ -71,7 +71,7 @@
+ ${LAPACK_BINARY_DIR}/cblas-config.cmake @ONLY)
+
+
+-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cblas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/cblas.pc)
++configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cblas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/cblas.pc @ONLY)
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/cblas.pc
+ DESTINATION ${PKG_CONFIG_DIR}
+--- lapack-3.6.0/CMakeLists.txt
++++ lapack-3.6.0/CMakeLists.txt
+@@ -333,7 +333,7 @@
+ ${LAPACK_BINARY_DIR}/lapack-config.cmake @ONLY)
+
+
+-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc)
++configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc @ONLY)
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc
+ DESTINATION ${PKG_CONFIG_DIR}
+--- lapack-3.6.0/LAPACKE/CMakeLists.txt
++++ lapack-3.6.0/LAPACKE/CMakeLists.txt
+@@ -65,7 +65,7 @@
+ endif(BUILD_TESTING)
+
+
+-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapacke.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapacke.pc)
++configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapacke.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapacke.pc @ONLY)
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/lapacke.pc
+ DESTINATION ${PKG_CONFIG_DIR}
+--- lapack-3.6.0/LAPACKE/lapacke.pc.in
++++ lapack-3.6.0/LAPACKE/lapacke.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: lapacke
+ Description: C Standard Interface to LAPACK Linear Algebra PACKage
+--- lapack-3.6.0/lapack.pc.in
++++ lapack-3.6.0/lapack.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: lapack
+ Description: FORTRAN reference implementation of LAPACK Linear Algebra PACKage
diff --git a/sci-libs/blas-reference/files/lapack-reference-3.7.0-fix-build-system.patch b/sci-libs/blas-reference/files/lapack-reference-3.7.0-fix-build-system.patch
new file mode 100644
index 000000000000..70f7cb0ee926
--- /dev/null
+++ b/sci-libs/blas-reference/files/lapack-reference-3.7.0-fix-build-system.patch
@@ -0,0 +1,56 @@
+diff --git a/BLAS/blas.pc.in b/BLAS/blas.pc.in
+index 7fd6f1e..e52f3ad 100644
+--- a/BLAS/blas.pc.in
++++ b/BLAS/blas.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: BLAS
+ Description: FORTRAN reference implementation of BLAS Basic Linear Algebra Subprograms
+diff --git a/CBLAS/cblas.pc.in b/CBLAS/cblas.pc.in
+index 4a938fe..311aed9 100644
+--- a/CBLAS/cblas.pc.in
++++ b/CBLAS/cblas.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: CBLAS
+ Description: C Standard Interface to BLAS Basic Linear Algebra Subprograms
+diff --git a/LAPACKE/lapacke.pc.in b/LAPACKE/lapacke.pc.in
+index 028f8da..dc092b1 100644
+--- a/LAPACKE/lapacke.pc.in
++++ b/LAPACKE/lapacke.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: LAPACKE
+ Description: C Standard Interface to LAPACK Linear Algebra PACKage
+diff --git a/lapack.pc.in b/lapack.pc.in
+index 878efc2..2cca4c2 100644
+--- a/lapack.pc.in
++++ b/lapack.pc.in
+@@ -1,5 +1,7 @@
+-prefix=@prefix@
+-libdir=@libdir@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/include
+
+ Name: LAPACK
+ Description: FORTRAN reference implementation of LAPACK Linear Algebra PACKage