summaryrefslogtreecommitdiff
path: root/sci-libs/blas-reference/blas-reference-20161223.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /sci-libs/blas-reference/blas-reference-20161223.ebuild
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'sci-libs/blas-reference/blas-reference-20161223.ebuild')
-rw-r--r--sci-libs/blas-reference/blas-reference-20161223.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sci-libs/blas-reference/blas-reference-20161223.ebuild b/sci-libs/blas-reference/blas-reference-20161223.ebuild
index 65ef230c1372..f9afcc3aec12 100644
--- a/sci-libs/blas-reference/blas-reference-20161223.ebuild
+++ b/sci-libs/blas-reference/blas-reference-20161223.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,9 +17,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="doc"
-DEPEND="app-eselect/eselect-blas"
-RDEPEND="${DEPEND}
- doc? ( app-doc/blas-docs )
+RDEPEND="
+ app-eselect/eselect-blas
+ doc? ( app-doc/blas-docs )"
+DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/${LPN}-${LPV}"
@@ -54,6 +55,11 @@ src_compile() {
cmake-utils_src_compile -C BLAS
}
+src_test() {
+ local BUILD_DIR="${WORKDIR}/${P}_build/BLAS"
+ cmake-utils_src_test
+}
+
src_install() {
cmake-utils_src_install -C BLAS