summaryrefslogtreecommitdiff
path: root/sci-libs/alglib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sci-libs/alglib
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sci-libs/alglib')
-rw-r--r--sci-libs/alglib/Manifest2
-rw-r--r--sci-libs/alglib/alglib-3.17.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/alglib/Manifest b/sci-libs/alglib/Manifest
index d37d206ede6b..3cd8bf30d28b 100644
--- a/sci-libs/alglib/Manifest
+++ b/sci-libs/alglib/Manifest
@@ -1,5 +1,7 @@
AUX CMakeLists.txt-3.8.2 1159 BLAKE2B bd12bd65ddc7e60d1e84b04d5c01391420accf099f17801680446856e817bd606315ee54a44b0bd559fe0a9fce35dfab8b9dfa2dd7edc406d57563ea0f77999a SHA512 193661b9f949972048132bc07b4619c2f0d38135d6f0030621cd8aabf87e9e78a6bec18cdb4fb9cb9e547fee9f4387e21ba3a02d45c41033a9c0be9221cf7d3c
AUX alglib-3.10.0-disable-minlm-test.patch 709 BLAKE2B 160bd6a598eb9c822b16da6455bae980cf6bfd77c9889c0d2385b896ec502030741c1f6a929f48a49c73fe35e696cf83b97d72a007e91899bd61d369b195b9e9 SHA512 00d62278a65f30d97dd7df8ac20d17dbc40117c25e2cef64652f2afd0bda7c277f8600ccfa7036da8a4a4173e0f0f433d898b87c04ab6d2d89e2547f8a305ee9
DIST alglib-3.10.0.cpp.gpl.tgz 1991101 BLAKE2B 884b80becce676285b7bc1f26ed8917c4c82f53b41c0350dfc8bff6573e2e6f12183e82fc317b54a8021b1f931eb7d5b55944902d0816f7097fdc05632128bdc SHA512 f02b3db5ab8dee841f27186b6693997c4e6876e75310b0a31a04593dbcb41d300920404e32e7aecb39c8dd15e54cfee05b725caa27397a67b453f6e64cd1ef5e
+DIST alglib-3.17.0.cpp.gpl.tgz 3065026 BLAKE2B bc939568a6bfb5e2717995e31b9d7cb485885217ff8d15c2bea3185b1ef62536766f80e02d43999c016e24b10181bddd4ad4ff27611ab19ebcc778a5cb15d55e SHA512 0e4b943b03707950813aea707ae3569ce75a22216c9a4b256b646db16609995b3b63a958b0b8fbe3d7d623d5ac03efbe7c4b1589961f2ca9cdefbd7e1cc0c721
EBUILD alglib-3.10.0-r1.ebuild 747 BLAKE2B d308644af5f0d8cd54e3b9d97d0cfd7bb5904a6994509a2d1316710833d6f59433a021b44e01e5aa58048622f5dabcf20c2e4aa5ab5f1c1120273b45d2feeed7 SHA512 cb9cf3f23a1b13377eb15db1e6c37835eaa5ad9957cdcedaf6391725061bc0e233b8e6924edc7c0a63a3bbc3477f03a780c206538816625dcd32148424993270
+EBUILD alglib-3.17.0.ebuild 670 BLAKE2B 77d22786af5b1ebac75439c13264e494632151ee3d6333dc158c154c1f751bb6d4a10734175af90c88061644fa4d529ba3ea50531b81e0257ea42e0b00a2620f SHA512 a957a3cece3cde5d3913f68e79228408ca56c4b9ada48f57515ec0db972027eb5636a54af268dc82d6fbe0aa4771f8559a247ee93c85174478f682c26fc8ab69
MISC metadata.xml 1592 BLAKE2B 96df655b24fc1e27a90f6a31388135e9ec14965eef850c14468797dbb19670ef4695219459b2af337613a92cc25a7eb12a1b07f95a3e1e4b058d9f9c38ded770 SHA512 e16165304d85c3201c428b46bb85006281a2faac170f6b7f2966bc683f57387a0d4b68eddd6ad2d4ed9d26af992f4f9b2616c761f0bf1102c6749a8025478844
diff --git a/sci-libs/alglib/alglib-3.17.0.ebuild b/sci-libs/alglib/alglib-3.17.0.ebuild
new file mode 100644
index 000000000000..6f520c619d21
--- /dev/null
+++ b/sci-libs/alglib/alglib-3.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Numerical analysis and data processing library"
+HOMEPAGE="https://www.alglib.net/"
+SRC_URI="https://www.alglib.net/translator/re/${P}.cpp.gpl.tgz"
+S="${WORKDIR}"/cpp
+
+LICENSE="GPL-2+"
+SLOT="0/3.8"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt-3.8.2 CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ use x86 && append-cflags -ffloat-store
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test)
+ )
+ cmake_src_configure
+}