summaryrefslogtreecommitdiff
path: root/sci-libs/adolc/adolc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-libs/adolc/adolc-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-libs/adolc/adolc-9999.ebuild')
-rw-r--r--sci-libs/adolc/adolc-9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/sci-libs/adolc/adolc-9999.ebuild b/sci-libs/adolc/adolc-9999.ebuild
index bae60dcf2ee8..dc6d88c74f35 100644
--- a/sci-libs/adolc/adolc-9999.ebuild
+++ b/sci-libs/adolc/adolc-9999.ebuild
@@ -1,24 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools toolchain-funcs eutils git-r3 ltprune
-
-MYPN=ADOL-C
+inherit autotools toolchain-funcs eutils
DESCRIPTION="Automatic differentiation system for C/C++"
HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/adol-c/adol-c.git"
+ EGIT_REPO_URI="https://github.com/coin-or/ADOL-C"
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+ SRC_URI="https://github.com/coin-or/ADOL-C/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${MYPN}-${PV}"
+ S="${WORKDIR}/ADOL-C-releases-${PV}"
fi
LICENSE="|| ( EPL-1.0 GPL-2 )"
@@ -59,5 +57,5 @@ src_test() {
src_install() {
default
- use static-libs || prune_libtool_files --all
+ use static-libs || find "${D}" -name '*.la' -type f -delete || die
}