summaryrefslogtreecommitdiff
path: root/sci-geosciences
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
commitf9fff8823e0cd1f6570b01337ac99e5bd49c824a (patch)
tree2a69b85ea6ba19c3a6b492d49ee8cd14c887472d /sci-geosciences
parentd117172e3b48fc4be82b7623ffc40bb6070ef361 (diff)
gentoo auto-resync : 26:12:2022 - 02:06:21
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/GeographicLib/GeographicLib-1.52.ebuild105
-rw-r--r--sci-geosciences/GeographicLib/Manifest1
-rw-r--r--sci-geosciences/Manifest.gzbin11228 -> 11228 bytes
-rw-r--r--sci-geosciences/qmapshack/Manifest2
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.16.0-r1.ebuild46
5 files changed, 0 insertions, 154 deletions
diff --git a/sci-geosciences/GeographicLib/GeographicLib-1.52.ebuild b/sci-geosciences/GeographicLib/GeographicLib-1.52.ebuild
deleted file mode 100644
index 52e3cdd8b428..000000000000
--- a/sci-geosciences/GeographicLib/GeographicLib-1.52.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit cmake distutils-r1
-
-MY_PN="${PN,,}"
-
-DESCRIPTION="C++ library for converting geographic coordinate systems"
-HOMEPAGE="https://sourceforge.net/projects/geographiclib/"
-SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/19"
-KEYWORDS="~amd64 ~arm"
-IUSE="doc examples python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- >=app-doc/doxygen-1.8.7
- >=dev-lang/perl-5.26.1-r1
- >=dev-python/sphinx-1.6.3-r2
- >=sys-apps/util-linux-2.31
- )
-"
-
-distutils_enable_tests setup.py
-# there are additional docs in the python dir
-distutils_enable_sphinx python/doc
-
-src_prepare() {
- cmake_src_prepare
-
- if use python; then
- pushd "python" || die
- distutils-r1_python_prepare_all
- popd || die
- fi
-}
-
-src_configure() {
- export GEODATAPATH="/usr/share/${MY_PN}"
-
- local mycmakeargs=(
- -DGEOGRAPHICLIB_DOCUMENTATION=$(usex doc ON OFF)
- -DGEOGRAPHICLIB_LIB_TYPE="SHARED"
- -DGEOGRAPHICLIB_DATA="${GEODATAPATH}"
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use python; then
- pushd "python" || die
- python_foreach_impl distutils-r1_python_compile
- popd || die
- fi
-}
-
-src_test() {
- cmake_src_test
-
- if use python; then
- pushd "python" || die
- python_foreach_impl python_test
- popd || die
- fi
-}
-
-src_install() {
- cmake_src_install
-
- # remove python things added by the cmake_src_install function
- rm -r "${D}/usr/$(get_libdir)/python" || die
- # if use python we re-add these python files for each implementation
- if use python; then
- pushd "python" || die
- python_foreach_impl distutils-r1_python_install
- popd || die
- fi
-
- #TODO: find out if java stuff need something
-
- # Installs to wrong doc dir for some reason
- # Also happens with USE="-doc"
- mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die
-
- if use examples; then
- dodoc -r examples
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-
- insinto "/usr/share/maxima/${MY_PN}"
- doins -r maxima/.
-
- find "${D}" -name "*.la" -delete || die
-}
diff --git a/sci-geosciences/GeographicLib/Manifest b/sci-geosciences/GeographicLib/Manifest
index 6f47c7b7b4ea..217a0a4ec289 100644
--- a/sci-geosciences/GeographicLib/Manifest
+++ b/sci-geosciences/GeographicLib/Manifest
@@ -1,4 +1,3 @@
DIST GeographicLib-1.52.tar.gz 2432658 BLAKE2B 87328de1774ab9aec05355362c9a1760cf62864135b97a3e9cb1382b0ec9825b032f6c67a5e02b762c3009a3876a9cd995e3a49a3ad3c051dcd36446b55d0191 SHA512 98a4d33764db4a4755851a7db639fd9e055dcf4f1f949258e112fce2e198076b5896fcae2c1ea36b37fe1000d28eec326636a730e70f25bc19a1610423ba6859
EBUILD GeographicLib-1.52-r1.ebuild 2126 BLAKE2B de3551d0c5cdcaf98897eee5b0042c113fbae11a0c719ca66c77249bf5df810fbd86e3ccd03369d2504e0f51420236b0df0ceefa63f970cf7fa203275db8dbae SHA512 cd5ae878f64bb422d0f0e4be4f9b003bcd03194f3893102898b3cc1f645ca34869637983678d05edb59f4c25bc7c82b4e874614a95d57908fa511dd348fe4a0b
-EBUILD GeographicLib-1.52.ebuild 2182 BLAKE2B 1840313b9b73175c1c73b765b789f26105d29aa7ba615b287264216ac11a793f35c94980790702031161af06411378d5e107b1d24d3ed54616fdb9fc5470c069 SHA512 1a52c4c4dae62bbcac21f0f2dcdb06332f0729c51b14c370b1190714079943985fc0166427d97ffeb2a1c8cea187378e3efd555b3d4a4199c775538237149ed9
MISC metadata.xml 875 BLAKE2B c383ecf94641b3ebdcb225b61eaec0077f83a03647306af59142fa633e8865ec46e809bd75410258dd9141cdca1141efd94f0a005ab273dfa2039811d419db24 SHA512 800b4153192b66e848a79a3e5ce915b21d61008d4b43e0f8c5da34142823af15367220589db1a04a8e3cddeb3ad0d300f002c2264e71408200595c67bcc7a625
diff --git a/sci-geosciences/Manifest.gz b/sci-geosciences/Manifest.gz
index e938a2cf80e9..9a9c18a67880 100644
--- a/sci-geosciences/Manifest.gz
+++ b/sci-geosciences/Manifest.gz
Binary files differ
diff --git a/sci-geosciences/qmapshack/Manifest b/sci-geosciences/qmapshack/Manifest
index 167eab3134eb..dc2b535ca832 100644
--- a/sci-geosciences/qmapshack/Manifest
+++ b/sci-geosciences/qmapshack/Manifest
@@ -1,5 +1,3 @@
-DIST qmapshack-1.16.0.tar.gz 54233332 BLAKE2B 8507018e65072856455e500aae59db146f68b7a1cf5eb2311ee3526044f8fafcec0034ac4f7a473c95ac71bcad8eb057bfc6724f3c80caff51aadba9e16fc412 SHA512 768fe7331d2bc2f2bbadd8c9296012e718f52863c4dfc29f000a5417ccf83297791333be9a20b9d49dcc7b92a779184503e8315b1f7ca258efc9f539ef7262f4
DIST qmapshack-1.16.1.tar.gz 54433326 BLAKE2B 58d3fff752187418552cba1d89b3ebd0082af379204b3c0b79cb8f8096cd422d3a9d347f7b91379868b37092469c5ef6187e67bfb7d0c3c07e18a65df0b488f1 SHA512 cd6c1818c2468a4654222d165bfa7278dea01890d4065a359942ce16ee1c643b54f86a94a30632bc414a1ec22e04ea340109fc89ca6c340eb717f8e86468e281
-EBUILD qmapshack-1.16.0-r1.ebuild 975 BLAKE2B 499b4e57719b8e0124b7da8877ab2d7af98b8f571142659befd5287d23d959a0999ddcace20005e55fe6137d738ecc9585da0879e79739e8331e3d84d994d8df SHA512 4fdea3e7965262bc837634fb3b2f98df6d11ffaa5cca99fa45871f2b31c0c8728adad800226384e99be924c72a6828906cae6e79e2061ee8c472816631ae1e52
EBUILD qmapshack-1.16.1-r1.ebuild 975 BLAKE2B 499b4e57719b8e0124b7da8877ab2d7af98b8f571142659befd5287d23d959a0999ddcace20005e55fe6137d738ecc9585da0879e79739e8331e3d84d994d8df SHA512 4fdea3e7965262bc837634fb3b2f98df6d11ffaa5cca99fa45871f2b31c0c8728adad800226384e99be924c72a6828906cae6e79e2061ee8c472816631ae1e52
MISC metadata.xml 834 BLAKE2B af7dac2c7ce98d1a40e993e51e646fdadb328515d1aa1e3e8c508e30f47ae1bc25e71ddb774b7ab65126f4644e119aa2be1a01c075c783fcd5f5fa2d06f23e75 SHA512 8e6e2d99a1ed77eee5b511901c190b8e9b2dc12e9a83525463cb96db811cda03c4a7dc3bd6fe7bc83dff93bd5d202ac7a66f69f350f7ac0773a6e894e6b64a85
diff --git a/sci-geosciences/qmapshack/qmapshack-1.16.0-r1.ebuild b/sci-geosciences/qmapshack/qmapshack-1.16.0-r1.ebuild
deleted file mode 100644
index f9e37c1f0d2b..000000000000
--- a/sci-geosciences/qmapshack/qmapshack-1.16.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="GPS mapping utility"
-HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
-SRC_URI="https://github.com/Maproom/${PN}/archive/V_${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/quazip:0=[qt5(+)]
- dev-qt/designer:5
- dev-qt/qtdbus:5
- dev-qt/qtdeclarative:5[widgets]
- dev-qt/qthelp:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtprintsupport:5
- dev-qt/qtsql:5
- dev-qt/qtwebengine:5[widgets]
- >=sci-geosciences/routino-3.1.1
- sci-libs/alglib
- sci-libs/gdal:=
- >=sci-libs/proj-8:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-qt/linguist-tools:5"
-
-S="${WORKDIR}"/${PN}-V_${PV}
-
-src_prepare() {
- cmake_src_prepare
- xdg_src_prepare
-}
-
-src_install() {
- docompress -x /usr/share/doc/${PF}/html
- cmake_src_install
- mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html || die "mv Qt help failed"
-}