summaryrefslogtreecommitdiff
path: root/sci-geosciences
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 10:49:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 10:49:51 +0100
commitea3e1bbf643d1d8892f4df05e4f05c1b2a2125d8 (patch)
tree60dac1902fc2665fd22fc2e4e4a60186cc7e361b /sci-geosciences
parentefca79f216bfeffd55e7731fbf24126d093e1084 (diff)
gentoo auto-resync : 15:09:2023 - 10:49:51
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/Manifest.gzbin11414 -> 11416 bytes
-rw-r--r--sci-geosciences/mapserver/Manifest2
-rw-r--r--sci-geosciences/mapserver/mapserver-8.0.1.ebuild89
3 files changed, 4 insertions, 87 deletions
diff --git a/sci-geosciences/Manifest.gz b/sci-geosciences/Manifest.gz
index 5660c6619d64..4164fc680904 100644
--- a/sci-geosciences/Manifest.gz
+++ b/sci-geosciences/Manifest.gz
Binary files differ
diff --git a/sci-geosciences/mapserver/Manifest b/sci-geosciences/mapserver/Manifest
index 8dad8c17de3a..bab06b26431f 100644
--- a/sci-geosciences/mapserver/Manifest
+++ b/sci-geosciences/mapserver/Manifest
@@ -1,3 +1,3 @@
DIST mapserver-8.0.1.tar.gz 2950164 BLAKE2B 5b14006d513aa4422dfe33b1991a685936084c1fda8c736fb97e25d54f1d1bf30278b6f0ce3c8a1907eeecd7bd1554076065d3824e2055265dfcbc0de2b899e1 SHA512 dae14a7eb6b09f5461c19bff83ca8ed6c21ae84d451b2c854794efb25b144b7edbf2a33479dc53e78aa646e5196e81219b4a1f393ff824db4508204a2d0301d1
-EBUILD mapserver-8.0.1.ebuild 7122 BLAKE2B 022512b51bdb041f14fa6477067e94d50b1862d01b15abb7365811b0589de7a84a08ce753bd25ef7b8beeeff8889174e18f1ccf867659b2a64c1734dd926f29b SHA512 d23b82e2e318d4e9ae9d275c9aec8995c27bde53cdc2162cb1312a7fd20d04b0c2b47d585f359f8a5ac5394b37cadd1cc3c0f0221a26c1e83c6456aeb8c10d40
+EBUILD mapserver-8.0.1.ebuild 4940 BLAKE2B 51f02e80b40a9b1ae677d45a6da1d90a68f2ba8bd82027565a302be26315aec3d5a845d0aa0678095561786e32a9c07072ac090eeab9f1572969f20c80ced54a SHA512 8908f0f4ceb4f0140e76b7d2a50c36792e8995cb9e1776ada5cd8b5cc4e0a9507ae520fc289df138381d01db532f391fa240f520fe36e2655f74d5d02c2f1b38
MISC metadata.xml 497 BLAKE2B b0517aa597d42116849e9f7ecdbf2cb2b479f5c57c7f0fe413dab870555abe82ac5dc07c624cabf769bfd2332300f2860e40cfd1ed375bafa109a347b670232b SHA512 3d58797fb05f9c45359e9ac2302a2432e9b61d300f1c01b27ef562da860311e777b7675b0f162eb2c490cdea0440c9f7b9a3323a89feef01589385ec30a5b64d
diff --git a/sci-geosciences/mapserver/mapserver-8.0.1.ebuild b/sci-geosciences/mapserver/mapserver-8.0.1.ebuild
index c8bc5c5d9238..060fae52b9e2 100644
--- a/sci-geosciences/mapserver/mapserver-8.0.1.ebuild
+++ b/sci-geosciences/mapserver/mapserver-8.0.1.ebuild
@@ -3,19 +3,12 @@
EAPI=7
-# Variables for the miscellaneous bindings we provide
-PHP_EXT_OPTIONAL_USE="php"
-PHP_EXT_NAME="php_mapscriptng"
-PHP_EXT_SKIP_PHPIZE="yes"
-PHP_EXT_SKIP_PATCHES="yes"
-
-USE_PHP="php7-4"
PYTHON_COMPAT=( python3_{10..11} )
WEBAPP_MANUAL_SLOT=yes
WEBAPP_OPTIONAL=yes
-inherit cmake depend.apache perl-functions php-ext-source-r3 python-r1 webapp
+inherit cmake depend.apache perl-functions python-r1 webapp
DESCRIPTION="Development environment for building spatially enabled webapps"
HOMEPAGE="https://mapserver.org/"
@@ -26,7 +19,7 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
# NOTE: opengl removed for now as no support for it in upstream CMake
-IUSE="apache bidi cairo geos mysql oracle perl php postgis python"
+IUSE="apache bidi cairo geos mysql oracle perl postgis python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -37,7 +30,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
#
# The eclasses used normally try to run test suites themselves,
# or skip if nothing was found.
-# However, because of the php-ext-* eclass usage, this fails and would
+# However, because of the python-r1 eclass usage, this fails and would
# cause errors running non-existent tests, so we have to restrict here.
RESTRICT="test"
@@ -79,7 +72,6 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
perl? ( >=dev-lang/swig-4.0 )
- php? ( >=dev-lang/swig-4.0 )
python? (
>=dev-lang/swig-4.0
>=dev-python/setuptools-44.1.0
@@ -96,7 +88,6 @@ pkg_setup() {
src_prepare() {
cmake_src_prepare
- use php && php-ext-source-r3_src_prepare
use python && python_copy_sources
}
@@ -175,29 +166,6 @@ src_configure() {
python_foreach_impl cmake_src_configure
python_foreach_impl python_optimize
fi
-
- if use php ; then
- local slot=
- for slot in $(php_get_slots) ; do
- # Switch to the slot's build dir
- php_init_slot_env "${slot}"
-
- # Take a blank config each time
- # Add in only *this* slot's PHP includes dir, etc
- mycmakeargs=(
- $(_generate_cmake_args)
- "-DWITH_PHPNG=ON"
- "-DPHP_CONFIG_EXECUTABLE=${PHPCONFIG}"
- "-DPHP_INCLUDES=${PHPPREFIX}"
- )
-
- BUILD_DIR="${S}/php${slot}" cmake_src_configure
-
- # Return to where we left off, in case we add more
- # to this phase.
- cd "${S}" || die
- done
- fi
}
src_compile() {
@@ -206,21 +174,6 @@ src_compile() {
if use python ; then
python_foreach_impl cmake_src_compile
fi
-
- if use php ; then
- local slot=
- for slot in $(php_get_slots) ; do
- # Switch to the slot's build dir
- php_init_slot_env "${slot}"
-
- # Force cmake to build in it
- BUILD_DIR="${S}/php${slot}" cmake_src_compile
-
- # Return to where we left off, in case we add more
- # to this phase.
- cd "${S}" || die
- done
- fi
}
src_install() {
@@ -232,19 +185,6 @@ src_install() {
python_foreach_impl python_optimize
fi
- if use php ; then
- php-ext-source-r3_createinifiles
-
- local slot=
- for slot in $(php_get_slots) ; do
- php_init_slot_env "${slot}"
-
- BUILD_DIR="${S}/php${slot}" cmake_src_install
-
- cd "${S}" || die
- done
- fi
-
# Install this last because this build is the most "fully-featured"
cmake_src_install
@@ -255,31 +195,8 @@ src_install() {
fi
}
-pkg_preinst() {
- # We need to cache the value here of HAD_PHP because we want the
- # original package version, not the result of us installing a new one
- HAD_PHP=
- has_version 'sci-geosciences/mapserver[php]' && HAD_PHP=1
-}
-
pkg_postinst() {
use apache && webapp_pkg_postinst
-
- # Let upgrading (from a pre-rewrite version) users know that the PHP module changed
- local replacing_version=
- for replacing_version in ${REPLACING_VERSIONS} ; do
- if ver_test "7.6.0" -gt "${replacing_version}" ; then
- if use php && [[ ${HAD_PHP} -eq 1 ]] ; then
- elog "Note that MapServer has deprecated the old PHP extension"
- elog "You can read more at: "
- elog "URL: https://mapserver.org/MIGRATION_GUIDE.html#mapserver-7-2-to-7-4-migration"
- elog "This may involve porting some of your PHP scripts to use the new module."
- fi
-
- # Only show the message once
- break
- fi
- done
}
pkg_prerm() {