summaryrefslogtreecommitdiff
path: root/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/tilecache/tilecache-2.11-r1.ebuild')
-rw-r--r--sci-geosciences/tilecache/tilecache-2.11-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild b/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
new file mode 100644
index 000000000000..f52323268ed3
--- /dev/null
+++ b/sci-geosciences/tilecache/tilecache-2.11-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Web map tile caching system"
+HOMEPAGE="http://tilecache.org/"
+SRC_URI="http://${PN}.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pillow
+ dev-python/paste"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"
+
+PATCHES=( "${FILESDIR}/tilecache-2.11-pil.patch" )
+
+src_install() {
+ distutils-r1_src_install "--debian"
+}
+
+python_test() {
+ python setup.py test || die "Failed tests"
+}