summaryrefslogtreecommitdiff
path: root/sci-geosciences/routino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-geosciences/routino
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/Manifest2
-rw-r--r--sci-geosciences/routino/routino-3.3.2.ebuild31
2 files changed, 21 insertions, 12 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index d4c96f29f3f7..abb611e15775 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -3,5 +3,5 @@ AUX routino-3.3.2.patch 1771 BLAKE2B a40ebca2cbc81f479eca69222e679a1abef4c42bd3d
DIST routino-3.2.tgz 2463662 BLAKE2B 4be17e83105d95052a9fbe0158b15bf5d64b4f720fb1bb61cbbb5fcd61451b933507e4dcc8867bff5e8602c6e681e916e45328d2a0ce766e9ab37366984cf378 SHA512 f5be46d9c026fcd92658490630d9ff6e4827e84ee57ccbaae48f54372da37ab78de24432ab9fa1d6860304a9a2ac86061eb876c12b39e821693282c4d4aaefcf
DIST routino-3.3.2.tgz 2542029 BLAKE2B e74af857ef29d4ee4a08d8a2913180dfca747001f4afd59ad20a9ed355e654dc86d26fb1afb5486ece30ddf6b7cba7b60c52feae30af14086f2b4d5259451125 SHA512 5341a2ec063192754d641a4543260f4b3b3d84a7a9bfe745fca2082cdcc8bb7220bf37ed58aacf9e65eba4555432a6bdbb9747153a383dfff72e2aca01c66070
EBUILD routino-3.2.ebuild 719 BLAKE2B 2ebcbe7a5356b375512a682696f4bc39eb337f4a9f87362af1f003dd6c99423c4ce168fa2896590abcfc860412068d84ee80face8b3c871499042ab51c092ab6 SHA512 ea8d262efbe278b659b935bce78dcba5b1418d76edaf8f296c62315ee33533e8dd4d218b1f65f87399de63bb7762fe4a0e2cd2752ea3740993d5cdf23e40d1c4
-EBUILD routino-3.3.2.ebuild 1580 BLAKE2B 31c073b39f9423edefe212250014f96bfbd3f83decd1ac93d80820848164eed5e0f7747ff1cc50dd83fb2f4a811168be0e9bec49fc1681dbba2c11f6d0f14362 SHA512 99d11b799b210a4e97d3635d399ba456a68c427e35539de7ea94c8dfd33e904a26137186a514ce63f0f049e935e818a038dd6a70ea63419597c092b8836b992b
+EBUILD routino-3.3.2.ebuild 1634 BLAKE2B 75fffeac50b909ddb6ee26b9c1a3347fc86ddd8754cd2457c513a1dcc8a3b0526e3679532ee7c4e5ba9b79b9b6c20560ad841c91935eae387b44158b911804cf SHA512 d23c0795affec6903e85a4ef134bd1e6a16948d5ed450e77e5e7c9158002ae01e651f484928794396d239d4b2b3bbd390907a1074ee72547bf23572a51a865ef
MISC metadata.xml 893 BLAKE2B cdfadafcae0c3898788652b567a8145efb0f98aa819df589d32c49ead219222691b19361b90c8bc5153fef1659d3c2d7e6933a21fcb86db9dfa37ab774d8d2b5 SHA512 84bd42eadbfae10a8762f0d8e28d410d2bf6c69a02e38cf870a846b5f7431130116658e22de5b2411cca0965e027d2f5c71e02bcf6b5ce1e1a804f1c235f60ff
diff --git a/sci-geosciences/routino/routino-3.3.2.ebuild b/sci-geosciences/routino/routino-3.3.2.ebuild
index c910d4194d2c..0ea8e4a10d4e 100644
--- a/sci-geosciences/routino/routino-3.3.2.ebuild
+++ b/sci-geosciences/routino/routino-3.3.2.ebuild
@@ -1,32 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit toolchain-funcs distutils-r1
DESCRIPTION="Routing application based on openstreetmap data"
-HOMEPAGE="http://www.routino.org/"
-SRC_URI="http://www.routino.org/download/${P}.tgz"
+HOMEPAGE="https://routino.org/"
+SRC_URI="https://routino.org/download/${P}.tgz"
+
LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="python? ( ${PYTHON_DEPS}
- dev-lang/swig )"
+
+DEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig
+ )
+"
RDEPEND="python? ( ${PYTHON_DEPS} )"
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
src_prepare() {
- eapply "${FILESDIR}"/${P}.patch
+ default
sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
-e "s@CC=gcc@CC=$(tc-getCC)@" \
-e "s@LD=gcc@LD=$(tc-getCC)@" \
Makefile.conf || die "failed sed"
-
- eapply_user
}
src_compile() {
@@ -36,7 +45,7 @@ src_compile() {
if use python; then
pushd python > /dev/null
python_compile() {
- rm -f build/.timestamp
+ rm -f build/.timestamp || die
emake PYTHON=${EPYTHON}
}
python_foreach_impl python_compile