summaryrefslogtreecommitdiff
path: root/sci-geosciences/routino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-geosciences/routino
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/Manifest2
-rw-r--r--sci-geosciences/routino/routino-3.3.3.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index d9313801a4b1..810fbf1cf110 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -1,4 +1,6 @@
AUX routino-3.3.2.patch 1771 BLAKE2B a40ebca2cbc81f479eca69222e679a1abef4c42bd3db8417bd8bcc62c8d15a5ed2f43ae8b55e56870ca037b98de2c424f258d139dff11c0128ac60940f09ace6 SHA512 52cbd47e68b25a7c735d32a4bb51436ea45867cdb9f86bc3a55304674b80d33dcc41f845527659db345e118f2f56036a2265a98a177744b4cb1029c7a18e202e
DIST routino-3.3.2.tgz 2542029 BLAKE2B e74af857ef29d4ee4a08d8a2913180dfca747001f4afd59ad20a9ed355e654dc86d26fb1afb5486ece30ddf6b7cba7b60c52feae30af14086f2b4d5259451125 SHA512 5341a2ec063192754d641a4543260f4b3b3d84a7a9bfe745fca2082cdcc8bb7220bf37ed58aacf9e65eba4555432a6bdbb9747153a383dfff72e2aca01c66070
+DIST routino-3.3.3.tgz 2564198 BLAKE2B 0476e4afb2279c6a93b3d5192a1be580b0ee20fe07b5101c7d590bd3b74873e0205549c2fa621c6444eea0dd0cf0545c9fc054454e04f434d3e57ed750b1df3d SHA512 b037f6ef38b3abef4639d639c3564b42adc742d225108905d0cacb790e4a07593245c537b5550c43874cd6083f37b710b7aec02a0b0669c927804cf30ce34386
EBUILD routino-3.3.2.ebuild 1632 BLAKE2B 6daeac8ab82c7e148db3e0ac8737f93b48a45a62cfe4e5fbae7d247fee256defdc45ebf1e3e225e28749988cebc2ca793b3f203f120f4148facff34c41b37945 SHA512 1ae54bb4307df0a0330ab1bd19b9929315085ad81dd46b67b7ac90406e17d3e9d9197736ca341803ced53268c4137194e902cf79e75dab1c359da9aa19936fda
+EBUILD routino-3.3.3.ebuild 1641 BLAKE2B ab2bc3136f58dd31d3133105481cb41aa7a39e8f0b2358bdbe38db8f269051708049a471f4b925c6abe0591752d20ff2a9ee287d0db7df4ef03c4a1a59871cfc SHA512 7a17238445009ebd2737beb716873f77662c07e761754caf32002d3e67454553fa7777c1a905700973ce1c24b6ab60530d2f5c9ad974b42a1a418e767a784655
MISC metadata.xml 893 BLAKE2B cdfadafcae0c3898788652b567a8145efb0f98aa819df589d32c49ead219222691b19361b90c8bc5153fef1659d3c2d7e6933a21fcb86db9dfa37ab774d8d2b5 SHA512 84bd42eadbfae10a8762f0d8e28d410d2bf6c69a02e38cf870a846b5f7431130116658e22de5b2411cca0965e027d2f5c71e02bcf6b5ce1e1a804f1c235f60ff
diff --git a/sci-geosciences/routino/routino-3.3.3.ebuild b/sci-geosciences/routino/routino-3.3.3.ebuild
new file mode 100644
index 000000000000..7a46ac85f347
--- /dev/null
+++ b/sci-geosciences/routino/routino-3.3.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="Routing application based on openstreetmap data"
+HOMEPAGE="https://routino.org/"
+SRC_URI="https://routino.org/download/${P}.tgz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig
+ )
+"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.2.patch )
+
+src_prepare() {
+ default
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+}
+
+src_compile() {
+ emake -j1
+ rm README.txt || die "rm README.txt failed"
+ mv doc/README.txt . || die "mv doc/README.txt . failed"
+ if use python; then
+ pushd python > /dev/null
+ python_compile() {
+ rm -f build/.timestamp || die
+ emake PYTHON=${EPYTHON}
+ }
+ python_foreach_impl python_compile
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ emake test
+# if use python; then
+# pushd python > /dev/null
+# python_test() {
+# echo "######## ${EPYTHON} ########"
+# emake PYTHON=${EPYTHON} test
+# }
+# python_foreach_impl python_test
+# popd > /dev/null
+# fi
+}
+
+src_install() {
+ default
+ if use python; then
+ pushd python > /dev/null
+ python_install() {
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl python_install
+ newdoc README.txt README_python.txt
+ popd > /dev/null
+ fi
+
+}