summaryrefslogtreecommitdiff
path: root/sci-geosciences/routino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-geosciences/routino
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-geosciences/routino')
-rw-r--r--sci-geosciences/routino/Manifest2
-rw-r--r--sci-geosciences/routino/routino-3.3.3-r2.ebuild (renamed from sci-geosciences/routino/routino-3.3.3.ebuild)58
2 files changed, 33 insertions, 27 deletions
diff --git a/sci-geosciences/routino/Manifest b/sci-geosciences/routino/Manifest
index 41dda526bfd0..bcfa5cb6f800 100644
--- a/sci-geosciences/routino/Manifest
+++ b/sci-geosciences/routino/Manifest
@@ -1,4 +1,4 @@
AUX routino-3.3.2.patch 1771 BLAKE2B a40ebca2cbc81f479eca69222e679a1abef4c42bd3db8417bd8bcc62c8d15a5ed2f43ae8b55e56870ca037b98de2c424f258d139dff11c0128ac60940f09ace6 SHA512 52cbd47e68b25a7c735d32a4bb51436ea45867cdb9f86bc3a55304674b80d33dcc41f845527659db345e118f2f56036a2265a98a177744b4cb1029c7a18e202e
DIST routino-3.3.3.tgz 2564198 BLAKE2B 0476e4afb2279c6a93b3d5192a1be580b0ee20fe07b5101c7d590bd3b74873e0205549c2fa621c6444eea0dd0cf0545c9fc054454e04f434d3e57ed750b1df3d SHA512 b037f6ef38b3abef4639d639c3564b42adc742d225108905d0cacb790e4a07593245c537b5550c43874cd6083f37b710b7aec02a0b0669c927804cf30ce34386
-EBUILD routino-3.3.3.ebuild 1646 BLAKE2B ea2ffcbf13ac57706fd2f2f33aa0e7a61f02eef638ecead1628f7b8c2fa5ef1faba674e0f23734ba5e7169239ab60f22620fc1fbb84563d8d96980861b5d422d SHA512 f04972ec4cdc6bcbb5b7af24ab2295bf7d430e57c2eb5fe29884cb0bb4c9b02735c4ca310568cabdcb543955970d704f26bcdd5ecf56196752b630081c2947f1
+EBUILD routino-3.3.3-r2.ebuild 1639 BLAKE2B bfedac5a070ae7830d8b31036dd8cf5b3fd86e072f9fa8584b8e553f038b740183b92b297ef869221cf2d02f45f174905840b0fd302f9a15fc2aa0ae4ada4ff5 SHA512 7ca30165b7947eb305c57174d120d7c8f2b717e6adb729dff59499d0a680bdd41aaecc31924a9ac0430c4c4de7d9e2a2c21757290ece5f470ae11899ab3ef240
MISC metadata.xml 894 BLAKE2B e9854b11005fdab70046e42a963c65a4e921f2d05572c4591e0ee581316a8ba3d3a5a0df39cf2aa500b1a89bde29fd1aaa459962abb68fdc71b49abd9681db54 SHA512 1397fb38a051f523925f04ab1d77044f2bbbcb2957a724696b54d6c057d49d67e758ae3d5b3c925fbce95f35e95c8b3a191724021bb82d4aa35ea61bc2c2153a
diff --git a/sci-geosciences/routino/routino-3.3.3.ebuild b/sci-geosciences/routino/routino-3.3.3-r2.ebuild
index f10841c69c91..215869319f5a 100644
--- a/sci-geosciences/routino/routino-3.3.3.ebuild
+++ b/sci-geosciences/routino/routino-3.3.3-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit toolchain-funcs distutils-r1
DESCRIPTION="Routing application based on openstreetmap data"
@@ -40,43 +40,49 @@ src_prepare() {
src_compile() {
emake -j1
+
rm README.txt || die "rm README.txt failed"
mv doc/README.txt . || die "mv doc/README.txt . failed"
+
if use python; then
- pushd python > /dev/null
- python_compile() {
- rm -f build/.timestamp || die
- emake PYTHON=${EPYTHON}
- }
- python_foreach_impl python_compile
- popd > /dev/null
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
fi
}
+python_compile() {
+ rm -f build/.timestamp || die
+ emake PYTHON=${EPYTHON}
+}
+
src_test() {
emake test
-# if use python; then
-# pushd python > /dev/null
-# python_test() {
-# echo "######## ${EPYTHON} ########"
-# emake PYTHON=${EPYTHON} test
-# }
-# python_foreach_impl python_test
-# popd > /dev/null
-# fi
+
+ # Need to fix import issues with these
+ #if use python; then
+ # pushd python > /dev/null || die
+ # distutils-r1_src_test
+ # popd > /dev/null || die
+ #fi
+}
+
+python_test() {
+ emake PYTHON=${EPYTHON} test
}
src_install() {
default
+
if use python; then
- pushd python > /dev/null
- python_install() {
- esetup.py install
- python_optimize
- }
- python_foreach_impl python_install
+ pushd python > /dev/null || die
+ distutils-r1_src_install
newdoc README.txt README_python.txt
- popd > /dev/null
+ popd > /dev/null || die
fi
+}
+python_install() {
+ esetup.py install
+ python_optimize
}