summaryrefslogtreecommitdiff
path: root/sci-geosciences/readosm/readosm-1.1.0a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sci-geosciences/readosm/readosm-1.1.0a.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sci-geosciences/readosm/readosm-1.1.0a.ebuild')
-rw-r--r--sci-geosciences/readosm/readosm-1.1.0a.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-geosciences/readosm/readosm-1.1.0a.ebuild b/sci-geosciences/readosm/readosm-1.1.0a.ebuild
new file mode 100644
index 000000000000..2ef7cd525d42
--- /dev/null
+++ b/sci-geosciences/readosm/readosm-1.1.0a.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library to extract valid data from an Open Street Map input file"
+HOMEPAGE="https://www.gaia-gis.it/fossil/readosm"
+SRC_URI="https://www.gaia-gis.it/gaia-sins/${PN}-sources/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/expat
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}