summaryrefslogtreecommitdiff
path: root/sci-geosciences/qgis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /sci-geosciences/qgis/files
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'sci-geosciences/qgis/files')
-rw-r--r--sci-geosciences/qgis/files/qgis-3.4.7-default-qmldir.patch25
-rw-r--r--sci-geosciences/qgis/files/qgis-3.4.7-featuresummary.patch31
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-geosciences/qgis/files/qgis-3.4.7-default-qmldir.patch b/sci-geosciences/qgis/files/qgis-3.4.7-default-qmldir.patch
new file mode 100644
index 000000000000..97f8ac12858c
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.4.7-default-qmldir.patch
@@ -0,0 +1,25 @@
+From 9d095f7d502cbcea8c70c127be322568b71f6663 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 28 Apr 2019 12:41:51 +0200
+Subject: [PATCH] cmake: Fix DEFAULT_QML_DIR path to comply with LFS layout
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4626042ca4..fe93ff3c4f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -660,7 +660,7 @@ IF (WITH_CORE)
+ SET (DEFAULT_LIBEXEC_SUBDIR lib${LIB_SUFFIX}/qgis)
+ SET (DEFAULT_PLUGIN_SUBDIR lib${LIB_SUFFIX}/qgis/plugins)
+ SET (DEFAULT_INCLUDE_SUBDIR include/qgis)
+- SET (DEFAULT_QML_SUBDIR qml)
++ SET (DEFAULT_QML_SUBDIR ${DEFAULT_DATA_SUBDIR}/qml)
+
+ SET (DEFAULT_SERVER_MODULE_SUBDIR ${DEFAULT_LIBEXEC_SUBDIR}/server)
+ ENDIF (APPLE)
+--
+2.21.0
+
diff --git a/sci-geosciences/qgis/files/qgis-3.4.7-featuresummary.patch b/sci-geosciences/qgis/files/qgis-3.4.7-featuresummary.patch
new file mode 100644
index 000000000000..ec971cef7792
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-3.4.7-featuresummary.patch
@@ -0,0 +1,31 @@
+From 0744b51784b779eab4bb2e78ed084d31258b5b4d Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 28 Apr 2019 00:10:21 +0200
+Subject: [PATCH] cmake: Use FeatureSummary
+
+---
+ CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4dff8ea0f4..4626042ca4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,6 +71,8 @@ IF(NOT MSVC)
+ endif(USE_CCACHE)
+ endif(NOT MSVC)
+
++include(FeatureSummary)
++
+ # in generated makefiles use relative paths so the project dir is moveable
+ # Note commented out since it cause problems but it would be nice to resolve these and enable
+ #
+@@ -937,3 +939,5 @@ ENDIF (WITH_CORE)
+ IF (UNIX AND NOT APPLE)
+ ADD_SUBDIRECTORY(linux)
+ ENDIF (UNIX AND NOT APPLE)
++
++FEATURE_SUMMARY(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+--
+2.21.0
+