summaryrefslogtreecommitdiff
path: root/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild')
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
index 44e16db48041..78b4534c993e 100644
--- a/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
+++ b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake flag-o-matic git-r3
EGIT_REPO_URI="https://github.com/openstreetmap/${PN}.git"
DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
-HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql"
+HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql
+ https://github.com/openstreetmap/osm2pgsql"
SRC_URI=""
LICENSE="GPL-2"
@@ -20,7 +21,7 @@ COMMON_DEPEND="
app-arch/bzip2
dev-db/postgresql:=
dev-libs/expat
- sci-libs/proj
+ sci-libs/proj:=
sys-libs/zlib
lua? ( dev-lang/lua:= )
"
@@ -35,9 +36,10 @@ RDEPEND="${COMMON_DEPEND}
RESTRICT="test"
src_configure() {
+ append-cppflags -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1
local mycmakeargs=(
-DWITH_LUA=$(usex lua)
-DBUILD_TESTS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}