summaryrefslogtreecommitdiff
path: root/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild')
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
new file mode 100644
index 000000000000..44e16db48041
--- /dev/null
+++ b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+EGIT_REPO_URI="https://github.com/openstreetmap/${PN}.git"
+
+DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
+HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+lua"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ dev-db/postgresql:=
+ dev-libs/expat
+ sci-libs/proj
+ sys-libs/zlib
+ lua? ( dev-lang/lua:= )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-db/postgis
+"
+
+# Tries to connect to local postgres server and other shenanigans
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_LUA=$(usex lua)
+ -DBUILD_TESTS=OFF
+ )
+ cmake-utils_src_configure
+}