summaryrefslogtreecommitdiff
path: root/sci-geosciences/opencpn-plugin-route
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/opencpn-plugin-route
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/opencpn-plugin-route')
-rw-r--r--sci-geosciences/opencpn-plugin-route/Manifest4
-rw-r--r--sci-geosciences/opencpn-plugin-route/metadata.xml15
-rw-r--r--sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild37
-rw-r--r--sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild37
4 files changed, 93 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-route/Manifest b/sci-geosciences/opencpn-plugin-route/Manifest
new file mode 100644
index 000000000000..91946c8f72a1
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/Manifest
@@ -0,0 +1,4 @@
+DIST opencpn-plugin-route-1.2.tar.gz 373474 SHA256 e72b08948f0b4adaaca16ce438a450148138b2d95db039553c74f1a33eba44ea SHA512 4dcaa4592f72c6a093276689db5ffa8dae1ed3e0ac6790b85352a6a1942d8863c8f19dfd1110256df9ac28e8056442344852d7790ae97201efe965485a5faa26 WHIRLPOOL fa3a66b18b974718603f8048f7634a43d79d87cddb0f77367dfea3e9379929f2fbd78947b3e7dca50bc15316d1910dc0131b22ebf4265ba5cd20a8ebf99c64e7
+EBUILD opencpn-plugin-route-1.2.ebuild 792 SHA256 2e2ca39eec23c7973b82e636d020bbc9f6d8bb839d3bd694532762293a19b278 SHA512 65870aa219080b3ecb6158e1a7dfa14039cf3778624449ac68d49e7749660b8630a03240f06e77130d144221fcb84c12b59f25d244ec1bf5f61066d6d72ab95b WHIRLPOOL 848b98cb887de2fd8a349d0848448c3ee4940a87f84eb1780b21f10a818e58b40e1e07d20b191bc580be62c8011b419e94416378287782bb3cc6039ed6e76fd8
+EBUILD opencpn-plugin-route-9999.ebuild 792 SHA256 2e2ca39eec23c7973b82e636d020bbc9f6d8bb839d3bd694532762293a19b278 SHA512 65870aa219080b3ecb6158e1a7dfa14039cf3778624449ac68d49e7749660b8630a03240f06e77130d144221fcb84c12b59f25d244ec1bf5f61066d6d72ab95b WHIRLPOOL 848b98cb887de2fd8a349d0848448c3ee4940a87f84eb1780b21f10a818e58b40e1e07d20b191bc580be62c8011b419e94416378287782bb3cc6039ed6e76fd8
+MISC metadata.xml 463 SHA256 ae7dd3282da3913c2528b835bd886cc273ce9bf96f4a16568c3c52677892aef3 SHA512 56be58d5be8fc8adc1ad3f1fe85be7e0a5dce179e047796e3db6795f77f16b53461822525ef6ab807af07f672b53210760870e96789d0abaa56a3edc90df23eb WHIRLPOOL 1970ae62c28b7a47d617b41cd5289bab085c3c459696187a7026c573c7b08a73453078e54ff9d9d5b818259373e0ff13750338f24849ee52efabbd265e89142d
diff --git a/sci-geosciences/opencpn-plugin-route/metadata.xml b/sci-geosciences/opencpn-plugin-route/metadata.xml
new file mode 100644
index 000000000000..6e6d546794c3
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">SaltyPaws/route_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild
new file mode 100644
index 000000000000..c81e035e1c04
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="route_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/SaltyPaws/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/SaltyPaws/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Route Plotting Plugin for OpenCPN"
+HOMEPAGE="https://github.com/SaltyPaws/route_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild
new file mode 100644
index 000000000000..c81e035e1c04
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-route/opencpn-plugin-route-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="route_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/SaltyPaws/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/SaltyPaws/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Route Plotting Plugin for OpenCPN"
+HOMEPAGE="https://github.com/SaltyPaws/route_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}