summaryrefslogtreecommitdiff
path: root/sci-geosciences/opencpn-plugin-otcurrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-geosciences/opencpn-plugin-otcurrent
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-geosciences/opencpn-plugin-otcurrent')
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/Manifest4
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild27
-rw-r--r--sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild27
3 files changed, 28 insertions, 30 deletions
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/Manifest b/sci-geosciences/opencpn-plugin-otcurrent/Manifest
index 11f2e103cd84..4f1423225ea8 100644
--- a/sci-geosciences/opencpn-plugin-otcurrent/Manifest
+++ b/sci-geosciences/opencpn-plugin-otcurrent/Manifest
@@ -1,4 +1,4 @@
DIST opencpn-plugin-otcurrent-1.2.tar.gz 184391 BLAKE2B 498dbe2533cb8867d4f87766f245d353494be1db5e955a320c6b9906a5edbca634645017c84fe1a6c145520b355b3c49767a5c012d621de88b7b6801d6d27407 SHA512 04564e0fcafe0f338d52a2fe7cf1a00c5d53d4ecbbac3264203ddc5ed4dd1e237b45d206314dfc493ea4649491a03872158a4d61a6dd0658dd54a20b43502263
-EBUILD opencpn-plugin-otcurrent-1.2.ebuild 773 BLAKE2B 4048495a269f43306327008350ba5a04e28f5171108f5909a34366ed83e9e196f7965669abc7698892162d99419568133d66c301fb35ae42c3c92b9516ed5a6d SHA512 1b1361ac803916a669214b8d46df938b21c3dc72cb2db8db452c786a33af22ccf57276bb0f34dd8e4ca14d685dda774aea8c56274378e535e16554b9bc6ce445
-EBUILD opencpn-plugin-otcurrent-9999.ebuild 773 BLAKE2B 4048495a269f43306327008350ba5a04e28f5171108f5909a34366ed83e9e196f7965669abc7698892162d99419568133d66c301fb35ae42c3c92b9516ed5a6d SHA512 1b1361ac803916a669214b8d46df938b21c3dc72cb2db8db452c786a33af22ccf57276bb0f34dd8e4ca14d685dda774aea8c56274378e535e16554b9bc6ce445
+EBUILD opencpn-plugin-otcurrent-1.2.ebuild 740 BLAKE2B a1e410691c47bab4f225757f1c920f3b048dc8a413b20a4715819bd8a4de508606d0c8109b4927d8251ec27ca009edbb4f49c725b6a1f605db7c2bb553ac4940 SHA512 0be5cb3c23d7a73bb547b610e6e00d1fe92f42e7db46d3cf8a78c743b03fd7a4fb18468377f6d4b2eaa518e41f7792cbea880c8ec5dc7867c469818a1de991a9
+EBUILD opencpn-plugin-otcurrent-9999.ebuild 740 BLAKE2B a1e410691c47bab4f225757f1c920f3b048dc8a413b20a4715819bd8a4de508606d0c8109b4927d8251ec27ca009edbb4f49c725b6a1f605db7c2bb553ac4940 SHA512 0be5cb3c23d7a73bb547b610e6e00d1fe92f42e7db46d3cf8a78c743b03fd7a4fb18468377f6d4b2eaa518e41f7792cbea880c8ec5dc7867c469818a1de991a9
MISC metadata.xml 465 BLAKE2B 4307b579615e38be351c2bcad023c8379b8007a654c6372420c508365ada065a4f159dd0149729c897f6c2aaac73736cb4968d32007bb88b94021b5b3d29edfa SHA512 31acd1d3a12d14d1e96df8a381187e3bcb970518f48e843d054852be222c83302750ad51d5f0721d100cede415202927c078c5e2a98cdb082985beb0b110332b
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
index 0d88a9a5e632..d7fcccf5a579 100644
--- a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
+++ b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-1.2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="otcurrent_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/Rasbats/otcurrent_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}
diff --git a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
index 0d88a9a5e632..d7fcccf5a579 100644
--- a/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-otcurrent/opencpn-plugin-otcurrent-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER="3.0"
+inherit cmake wxwidgets
+
MY_PN="otcurrent_pi"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
- inherit git-r3 cmake-utils wxwidgets
else
- SRC_URI="
- https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- "
- inherit cmake-utils wxwidgets
+ SRC_URI="https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
@@ -22,15 +22,14 @@ HOMEPAGE="https://github.com/Rasbats/otcurrent_pi"
LICENSE="GPL-2+"
SLOT="0"
-IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
- >=sci-geosciences/opencpn-4.2.0
- sys-devel/gettext
-"
+ >=sci-geosciences/opencpn-4.2.0"
DEPEND="${RDEPEND}"
-src_prepare() {
- need-wxwidgets unicode
- cmake-utils_src_prepare
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
}