summaryrefslogtreecommitdiff
path: root/sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-4.0.0.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-4.0.0.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-4.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-4.0.0.ebuild b/sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-4.0.0.ebuild
new file mode 100644
index 000000000000..f8093a00ebdc
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-dr/opencpn-plugin-dr-4.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake wxwidgets
+
+MY_PN="DR_pi"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Rasbats/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Rasbats/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Dead Reckoning Positions Plugin for OpenCPN"
+HOMEPAGE="https://github.com/Rasbats/DR_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ sci-geosciences/opencpn:="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}/cmake.patch"
+)
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
+}