summaryrefslogtreecommitdiff
path: root/sci-geosciences/opencpn-plugin-dr/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sci-geosciences/opencpn-plugin-dr/files
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sci-geosciences/opencpn-plugin-dr/files')
-rw-r--r--sci-geosciences/opencpn-plugin-dr/files/cmake.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-dr/files/cmake.patch b/sci-geosciences/opencpn-plugin-dr/files/cmake.patch
new file mode 100644
index 000000000000..ab0bb813c321
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-dr/files/cmake.patch
@@ -0,0 +1,41 @@
+diff -ur DR_pi-4.0.0.orig/CMakeLists.txt DR_pi-4.0.0/CMakeLists.txt
+--- DR_pi-4.0.0.orig/CMakeLists.txt 2021-11-04 00:32:44.000000000 -1000
++++ DR_pi-4.0.0/CMakeLists.txt 2021-11-29 00:11:03.998266321 -1000
+@@ -61,9 +61,10 @@
+ )
+ include(Targets)
+ create_targets(${FLATPAK_MANIFEST})
+-if ("${BUILD_TYPE}" STREQUAL "")
+- return ()
+-endif ()
++#if ("${BUILD_TYPE}" STREQUAL "")
++# return ()
++#endif ()
++include(PluginLibs)
+
+ if (NOT ${BUILD_TYPE} STREQUAL "flatpak")
+ # Build package as required (flatpak already dealt with).
+diff -ur DR_pi-4.0.0.orig/cmake/PluginInstall.cmake DR_pi-4.0.0/cmake/PluginInstall.cmake
+--- DR_pi-4.0.0.orig/cmake/PluginInstall.cmake 2021-11-04 00:32:44.000000000 -1000
++++ DR_pi-4.0.0/cmake/PluginInstall.cmake 2021-11-29 00:10:04.241099544 -1000
+@@ -11,7 +11,7 @@
+ # the Free Software Foundation; either version 3 of the License, or
+ # (at your option) any later version.
+
+-include(Metadata)
++#include(Metadata)
+
+ if (APPLE)
+ install(
+diff -ur DR_pi-4.0.0.orig/cmake/Targets.cmake DR_pi-4.0.0/cmake/Targets.cmake
+--- DR_pi-4.0.0.orig/cmake/Targets.cmake 2021-11-04 00:32:44.000000000 -1000
++++ DR_pi-4.0.0/cmake/Targets.cmake 2021-11-29 00:10:18.954386822 -1000
+@@ -19,7 +19,7 @@
+ return()
+ endif ()
+
+-include(Metadata)
++#include(Metadata)
+
+ if (UNIX AND NOT APPLE AND NOT QT_ANDROID)
+ set(_LINUX ON)