summaryrefslogtreecommitdiff
path: root/sci-geosciences/mapserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sci-geosciences/mapserver
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sci-geosciences/mapserver')
-rw-r--r--sci-geosciences/mapserver/Manifest2
-rw-r--r--sci-geosciences/mapserver/mapserver-7.6.2.ebuild289
2 files changed, 291 insertions, 0 deletions
diff --git a/sci-geosciences/mapserver/Manifest b/sci-geosciences/mapserver/Manifest
index a692a8efde17..5d7cab32079e 100644
--- a/sci-geosciences/mapserver/Manifest
+++ b/sci-geosciences/mapserver/Manifest
@@ -1,3 +1,5 @@
DIST mapserver-7.6.0.tar.gz 2713965 BLAKE2B 35e81b470afba58b1cf8cc63f70e6cc230a338c4066d38e8aa57d34a55e7414e9e3eeb6cc9c6d54ac8f60d076b90d25e23354f33f35c235d3d1d85d4f19979e7 SHA512 6e8a4639a025d3bdeaa74599ea10b58fbd20fc87367d39ccc9c29586a599d47ee4c45f6fe16dc76d593b3d7c51e26f8ca9d8656c5c3a3636181824d3aa26db36
+DIST mapserver-7.6.2.tar.gz 2715806 BLAKE2B 230e4f52c526d72ac7f46cfe4ef8e547d7ae74c01d75637ad301d4e69b90d301f02ecb8fe7d838c9ee15c022ed7980aa2f9236e08a6daedafb65a2499a9473e5 SHA512 842c2cf891df6c8dc630fac5419caa31701d732a748264f7d5b6cceaf192fa420f1863fdd18cc791a417dcdc800fed5c3e5c43ac688142f32a1a6edda4c9f791
EBUILD mapserver-7.6.0.ebuild 7301 BLAKE2B b9d2f090e15cad539c0976c36c4e2c02456eed16ca725a2ef59ac4cab898f2fd97478f56179a7c606c4d5a8d5aab7bc896c0b0729897a8c0710b26a4245ab1c9 SHA512 36a143de7a376fcee8f3770f22a9be3b5fab29e6df2c438e76000bc8ec144850581735f394dddcb2463d11a60cfedcb558d304a95d863c8137921dfaf5deb175
+EBUILD mapserver-7.6.2.ebuild 7303 BLAKE2B 36c8f9119155751f19d4c693fa305a1f2aa4b7b1c3d8ffcb515888f6c1bf6c32377300ab4f6c9a08644b9eba7d63080c699d8905df3a0ccc16731e036efea9c8 SHA512 ef937ae7b6a16ccf27f52a37bf1731f3731bce6811fac6a22134061a1500a78669e7c1da9e93a8c4738a7267aa94e65a6a13884a5c607c15fdc5416c5708f031
MISC metadata.xml 496 BLAKE2B 5903d53c86d30548162025cfed484a3405ea3a9bd611d475177a355a374b7a4bbf73d439a1c1457176d3f7f58355da06d842327407437c89cab426473be22bab SHA512 2dc21e4e1a785b4dff3de94bc3c621dfd4c3dfe092761681b4ffc536532f7f87b6a9fbbd0dc82895132ebd3cdb0f5750e6fe77b681c49d5996d9233096478a8e
diff --git a/sci-geosciences/mapserver/mapserver-7.6.2.ebuild b/sci-geosciences/mapserver/mapserver-7.6.2.ebuild
new file mode 100644
index 000000000000..98676a2de015
--- /dev/null
+++ b/sci-geosciences/mapserver/mapserver-7.6.2.ebuild
@@ -0,0 +1,289 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTE: We have to stick with EAPI 6 for now because of the
+# depend.apache eclass.
+EAPI=6
+
+# Variables for the miscellaneous bindings we provide
+PHP_EXT_OPTIONAL_USE="php"
+PHP_EXT_NAME="php_mapscriptng"
+PHP_EXT_SKIP_PHPIZE="yes"
+
+USE_PHP="php7-2 php7-3 php7-4"
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+WEBAPP_MANUAL_SLOT=yes
+WEBAPP_OPTIONAL=yes
+
+# NOTE: Similarly, we cannot go cmake-utils -> cmake until we're on EAPI 7
+inherit cmake-utils depend.apache eapi7-ver perl-functions php-ext-source-r3 python-r1 webapp
+
+DESCRIPTION="Development environment for building spatially enabled webapps"
+HOMEPAGE="https://mapserver.org/"
+SRC_URI="https://download.osgeo.org/mapserver/${P}.tar.gz"
+
+LICENSE="Boost-1.0 BSD BSD-2 ISC MIT tcltk"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+# NOTE: opengl removed for now as no support for it in upstream CMake
+IUSE="apache bidi cairo geos mysql oracle perl php postgis python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Tests:
+# Included tests (tests/*) are seriously outdated
+# Upstream's main test suite (msautotest/*) is not in the release tarball,
+# and upstream sets 'export-ignore' for that directory.
+#
+# The eclasses used normally try to run test suites themselves,
+# or skip if nothing was found.
+# However, because of the php-ext-* eclass usage, this fails and would
+# cause errors running non-existent tests, so we have to restrict here.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/expat-2.2.8
+ dev-libs/libxml2:2=
+ dev-libs/libxslt[crypt]
+ >=dev-libs/protobuf-c-1.3.2:=
+ >=media-libs/freetype-2.9.1-r3
+ >=media-libs/gd-2.0.12:=[truetype,jpeg,png,zlib]
+ >=media-libs/giflib-5.2.1:=
+ >=media-libs/libpng-1.6.37:=
+ >=net-misc/curl-7.69.1
+ >=sci-libs/gdal-3.0.4:=[oracle?]
+ >=sci-libs/proj-6.2.1:=
+ virtual/jpeg
+ virtual/libiconv
+ >=x11-libs/agg-2.5-r3
+ apache? (
+ app-admin/webapp-config
+ dev-libs/fcgi
+ )
+ bidi? (
+ dev-libs/fribidi
+ media-libs/harfbuzz:=
+ )
+ cairo? ( x11-libs/cairo )
+ geos? ( sci-libs/geos )
+ mysql? ( dev-db/mysql-connector-c:= )
+ oracle? ( dev-db/oracle-instantclient:= )
+ perl? ( dev-lang/perl:= )
+ postgis? (
+ dev-db/postgis
+ dev-db/postgresql:=
+ )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ perl? ( >=dev-lang/swig-4.0 )
+ php? ( >=dev-lang/swig-4.0 )
+ python? (
+ >=dev-lang/swig-4.0
+ >=dev-python/setuptools-44.1.0
+ )
+"
+
+want_apache2 apache
+
+pkg_setup() {
+ use apache && webapp_pkg_setup
+ use perl && perl_set_version
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ use php && php-ext-source-r3_src_prepare
+ use python && python_copy_sources
+}
+
+_generate_cmake_args() {
+ # Provides a simple, bare config for bindings to build upon
+ # Need WITH_WMS=ON or build fails
+ local args=(
+ "-DCMAKE_SKIP_RPATH=ON"
+ "-DINSTALL_LIB_DIR=/usr/$(get_libdir)"
+ "-DWITH_CAIRO=OFF"
+ "-DWITH_FCGI=OFF"
+ "-DWITH_FRIBIDI=OFF"
+ "-DWITH_GEOS=OFF"
+ "-DWITH_GIF=OFF"
+ "-DWITH_HARFBUZZ=OFF"
+ "-DWITH_ICONV=OFF"
+ "-DWITH_PROTOBUFC=OFF"
+ "-DWITH_POSTGIS=OFF"
+ "-DWITH_WMS=ON"
+ "-DWITH_WCS=OFF"
+ "-DWITH_WFS=OFF"
+ )
+
+ echo "${args[@]}"
+}
+
+src_configure() {
+ # NOTE: We could make this based on _generate_cmake_args, but
+ # then we wouldn't be as-explicit about what is enabled/not,
+ # and reliant on defaults not changing.
+ # Readability and maintainability is better this way.
+ local mycmakeargs=(
+ "-DCMAKE_SKIP_RPATH=ON"
+ "-DINSTALL_LIB_DIR=/usr/$(get_libdir)"
+ "-DWITH_CLIENT_WMS=ON"
+ "-DWITH_CLIENT_WFS=ON"
+ "-DWITH_CURL=ON"
+ "-DWITH_GIF=ON"
+ "-DWITH_ICONV=ON"
+ "-DWITH_KML=ON"
+ "-DWITH_LIBXML2=ON"
+ "-DWITH_PHPNG=OFF"
+ "-DWITH_PROTOBUFC=ON"
+ "-DWITH_SOS=ON"
+ "-DWITH_WMS=ON"
+ "-DWITH_WFS=ON"
+ "-DWITH_WCS=ON"
+ "-DWITH_XMLMAPFILE=ON"
+ "-DWITH_APACHE_MODULE=$(usex apache ON OFF)"
+ "-DWITH_CAIRO=$(usex cairo ON OFF)"
+ "-DWITH_FCGI=$(usex apache ON OFF)"
+ "-DWITH_GEOS=$(usex geos ON OFF)"
+ "-DWITH_ORACLESPATIAL=$(usex oracle ON OFF)"
+ "-DWITH_MYSQL=$(usex mysql ON OFF)"
+ "-DWITH_FRIBIDI=$(usex bidi ON OFF)"
+ "-DWITH_HARFBUZZ=$(usex bidi ON OFF)"
+ "-DWITH_POSTGIS=$(usex postgis ON OFF)"
+ "-DWITH_PERL=$(usex perl ON OFF)"
+ )
+
+ use perl && mycmakeargs+=( "-DCUSTOM_PERL_SITE_ARCH_DIR=$(perl_get_raw_vendorlib)" )
+
+ # Configure the standard build first
+ cmake-utils_src_configure
+
+ # Minimal build for bindings
+ # Note that we use _generate_cmake_args to get a clean config each time, then add
+ # in options as appropriate. Otherwise we'd get contamination between bindings.
+ if use python ; then
+ mycmakeargs=(
+ $(_generate_cmake_args)
+ "-DWITH_PYTHON=ON"
+ )
+
+ python_foreach_impl cmake-utils_src_configure
+ python_foreach_impl python_optimize
+ fi
+
+ if use php ; then
+ local slot=
+ for slot in $(php_get_slots) ; do
+ # Switch to the slot's build dir
+ php_init_slot_env "${slot}"
+
+ # Take a blank config each time
+ # Add in only *this* slot's PHP includes dir, etc
+ mycmakeargs=(
+ $(_generate_cmake_args)
+ "-DWITH_PHPNG=ON"
+ "-DPHP_CONFIG_EXECUTABLE=${PHPCONFIG}"
+ "-DPHP_INCLUDES=${PHPPREFIX}"
+ )
+
+ BUILD_DIR="${S}/php${slot}" cmake-utils_src_configure
+
+ # Return to where we left off, in case we add more
+ # to this phase.
+ cd "${S}" || die
+ done
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use python ; then
+ python_foreach_impl cmake-utils_src_compile
+ fi
+
+ if use php ; then
+ local slot=
+ for slot in $(php_get_slots) ; do
+ # Switch to the slot's build dir
+ php_init_slot_env "${slot}"
+
+ # Force cmake to build in it
+ BUILD_DIR="${S}/php${slot}" cmake-utils_src_compile
+
+ # Return to where we left off, in case we add more
+ # to this phase.
+ cd "${S}" || die
+ done
+ fi
+}
+
+src_install() {
+ # Needs to be first
+ use apache && webapp_src_preinst
+
+ if use python ; then
+ python_foreach_impl cmake-utils_src_install
+ python_foreach_impl python_optimize
+ fi
+
+ if use php ; then
+ php-ext-source-r3_createinifiles
+
+ local slot=
+ for slot in $(php_get_slots) ; do
+ php_init_slot_env "${slot}"
+
+ BUILD_DIR="${S}/php${slot}" cmake-utils_src_install
+
+ cd "${S}" || die
+ done
+ fi
+
+ # Install this last because this build is the most "fully-featured"
+ cmake-utils_src_install
+
+ if use apache ; then
+ # We need a mapserver symlink available in cgi-bin
+ dosym ../../../../../../../usr/bin/mapserv /usr/share/webapps/${PN}/${PV}/hostroot/cgi-bin/mapserv
+ webapp_src_install
+ fi
+}
+
+pkg_preinst() {
+ # We need to cache the value here of HAD_PHP because we want the
+ # original package version, not the result of us installing a new one
+ HAD_PHP=
+ has_version 'sci-geosciences/mapserver[php]' && HAD_PHP=1
+}
+
+pkg_postinst() {
+ use apache && webapp_pkg_postinst
+
+ # Let upgrading (from a pre-rewrite version) users know that the PHP module changed
+ local replacing_version=
+ for replacing_version in ${REPLACING_VERSIONS} ; do
+ if ver_test "7.6.0" -gt "${replacing_version}" ; then
+ if use php && [[ ${HAD_PHP} -eq 1 ]] ; then
+ elog "Note that MapServer has deprecated the old PHP extension"
+ elog "You can read more at: "
+ elog "URL: https://mapserver.org/MIGRATION_GUIDE.html#mapserver-7-2-to-7-4-migration"
+ elog "This may involve porting some of your PHP scripts to use the new module."
+ fi
+
+ # Only show the message once
+ break
+ fi
+ done
+}
+
+pkg_prerm() {
+ use apache && webapp_pkg_prerm
+}