summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
commitee93fbc2bb111cf895ae00cc1877c68f0eafaf2a (patch)
treef4cdf4b4814dfa35e701a066e3bc3c50f6afd7cf /sci-geosciences/grass
parentdbd6eaafcce6a59fa9b3323124c38fa17aa88e26 (diff)
gentoo auto-resync : 21:03:2024 - 01:00:11
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/Manifest2
-rw-r--r--sci-geosciences/grass/grass-8.3.2.ebuild276
2 files changed, 278 insertions, 0 deletions
diff --git a/sci-geosciences/grass/Manifest b/sci-geosciences/grass/Manifest
index 6a23eda40e3a..7ac21507b90e 100644
--- a/sci-geosciences/grass/Manifest
+++ b/sci-geosciences/grass/Manifest
@@ -1,5 +1,7 @@
AUX grass-flock.patch 577 BLAKE2B 0f4e0b06e1d8273cb954be9596a68adbd51b099b0a19bf2d4dc695de3a06bffc4df42eedca76977d552a26578238ffb10fb1b2b5242c4b6ffda83eaba7c41764 SHA512 36d8408f553ebfeb5cdc97c43ffae3ce6f77b713069d0d30d734748fb812800d4dafc76921d95fa8455c4ec4a55311703499f4aec97ad13b97b9549ab463cb3c
DIST grass-8.3.1.tar.gz 68491177 BLAKE2B 58513c8c273b55831bca764c9e61e54b92c075ea2f4ff3c2f059ebcce98f25694ee03a25bef7a3e1c443165dd9493d3ce469233be3b65596dc28da166c12d174 SHA512 416a1b3eccb71f63576b36b963b7ddd8063ae73cefb8aa94431ade0ad74d699beb28635de8ba3a73cbd28304e5049dde2e75fb0f4c2747c81cb62c86b25c3793
+DIST grass-8.3.2.tar.gz 68662576 BLAKE2B 214bc6aea6904e88339e7f2d80f5dbc1c549928eed08ae0734789165af9e4cd7d8a882c67607c2670f2fdd4584615eac95c1ada9e5312abc6b59e0cb48124615 SHA512 6523e2c0eae183fddeaa015e63283febfbae4953e809ff41bcc4ab95aa1055162b08c65365f973124608ff7b01aa907a1a0ec96c9f31884c657f236e56c0eab0
EBUILD grass-8.3.1.ebuild 7070 BLAKE2B 24db4f7bc33845d9123e30a2dabd537097efd47066942322454de31b0b99c390524b408079c718a1e686b93d4d43f0426bff334c9e77cfd81222eff172b3656d SHA512 d68bdeb3add17d3f09809ec5c3c3c8e6d5701280a96181e57891db01bcddf188dc961eb8411bd674f6f6e7d7edd315e6c19a26b757bca6b3e60cb4ecb94147c5
+EBUILD grass-8.3.2.ebuild 7071 BLAKE2B 8031beb6a5c6f85125923bc770baa65f54f9e0f0771b8751ca5459c0d762e92778be5abdc267cc6d05ee0704967b5ed5ee814af78f7b8ef0cc9b2584b65d4a3a SHA512 f788c378b09eeb01506c139e9d01b92d67e3eb1398cbef7e127b4825c2fdcbfdebd38025b3083360ffa4fca9b33491058fc76ff9f24507af7e5d1b81876292c7
EBUILD grass-9999.ebuild 7011 BLAKE2B 9d9ae0535426d4d9c9e41e513e0427069bb859861871a305161d2df8c4c4abfbbdf6ec8c0db32000960b867b0edb5a0139785e202b5a786b753f4d51e60f8825 SHA512 3d4c5fa1b50269fee75b96856309daa66adce2c14ff9eb2feda8d09383312d3c00745b307247c52de0934c5f64c3448af5afaf465bf8fa3c58f9118ffbbe47ad
MISC metadata.xml 1209 BLAKE2B d3b487c34e4282b9b60b3ff92eca7d609abca4950793877a17e4f48ac6363e84fea831ed0902206986b0abd601a5bdeaaf7db19db079b32b85641750e3f36442 SHA512 6a65b8141b2ad880368915bf2676e5fa5d42e6fcb710fa8e9b2098613ed6dac356302ac1635ad139d7ea560ec25d83f79d94833e53365f26063cd6ffee3debbc
diff --git a/sci-geosciences/grass/grass-8.3.2.ebuild b/sci-geosciences/grass/grass-8.3.2.ebuild
new file mode 100644
index 000000000000..b719d57f438c
--- /dev/null
+++ b/sci-geosciences/grass/grass-8.3.2.ebuild
@@ -0,0 +1,276 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite" # bug 572440
+
+inherit desktop flag-o-matic python-single-r1 toolchain-funcs xdg
+
+DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
+HOMEPAGE="https://grass.osgeo.org/"
+
+LICENSE="GPL-2"
+
+if [[ ${PV} =~ "9999" ]]; then
+ SLOT="0/8.3"
+else
+ SLOT="0/$(ver_cut 1-2 ${PV})"
+fi
+
+GVERSION=${SLOT#*/}
+MY_PM="${PN}${GVERSION}"
+MY_PM="${MY_PM/.}"
+
+if [[ ${PV} =~ "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
+else
+ MY_P="${P/_rc/RC}"
+ SRC_URI="https://grass.osgeo.org/${MY_PM}/source/${MY_P}.tar.gz"
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~ppc ~x86"
+ fi
+
+ S="${WORKDIR}/${MY_P}"
+fi
+
+IUSE="blas bzip2 cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ opengl? ( X )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-admin/eselect-1.2
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+ sci-libs/gdal:=
+ sys-libs/gdbm:=
+ sys-libs/ncurses:=
+ sci-libs/proj:=
+ sys-libs/zlib
+ media-libs/libglvnd
+ media-libs/glu
+ blas? (
+ virtual/cblas[eselect-ldso(+)]
+ virtual/blas[eselect-ldso(+)]
+ )
+ bzip2? ( app-arch/bzip2:= )
+ fftw? ( sci-libs/fftw:3.0= )
+ geos? ( sci-libs/geos:= )
+ lapack? ( virtual/lapack[eselect-ldso(+)] )
+ las? ( sci-geosciences/liblas )
+ mysql? ( dev-db/mysql-connector-c:= )
+ netcdf? ( sci-libs/netcdf:= )
+ odbc? ( dev-db/unixODBC )
+ opencl? ( virtual/opencl )
+ opengl? ( virtual/opengl )
+ pdal? ( >=sci-libs/pdal-2.0.0:= )
+ png? ( media-libs/libpng:= )
+ postgres? ( >=dev-db/postgresql-8.4:= )
+ readline? ( sys-libs/readline:= )
+ sqlite? ( dev-db/sqlite:3 )
+ tiff? ( media-libs/tiff:= )
+ truetype? ( media-libs/freetype:2 )
+ X? (
+ $(python_gen_cond_dep '
+ >=dev-python/matplotlib-1.2[wxwidgets,${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/wxpython-4.1:4.0[${PYTHON_USEDEP}]
+ ')
+ x11-libs/cairo[X]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ )
+ zstd? ( app-arch/zstd:= )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ app-alternatives/yacc
+ app-alternatives/lex
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? ( dev-lang/swig )"
+
+PATCHES=(
+ # bug 746590
+ "${FILESDIR}/${PN}-flock.patch"
+)
+
+pkg_setup() {
+ if use lapack; then
+ local mylapack=$(eselect lapack show)
+ if [[ -z "${mylapack/.*reference.*/}" ]] && \
+ [[ -z "${mylapack/.*atlas.*/}" ]]; then
+ ewarn "You need to set lapack to atlas or reference. Do:"
+ ewarn " eselect lapack set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ if use blas; then
+ local myblas=$(eselect blas show)
+ if [[ -z "${myblas/.*reference.*/}" ]] && \
+ [[ -z "${myblas/.*atlas.*/}" ]]; then
+ ewarn "You need to set blas to atlas or reference. Do:"
+ ewarn " eselect blas set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix unversioned python calls
+ sed -e "s:=python3:=${EPYTHON}:" -i "${S}/lib/init/grass.sh" || die
+ sed -e "s:= python3:= ${EPYTHON}:" -i "${S}/include/Make/Platform.make.in" || die
+
+ default
+
+ # When patching the build system, avoid running autoheader here. The file
+ # config.in.h is maintained manually upstream. Changes to it may lead to
+ # undefined behavior. See bug #866554.
+ # AT_NOEAUTOHEADER=1 eautoreconf
+
+ ebegin "Fixing python shebangs"
+ python_fix_shebang -q "${S}"
+ eend $?
+
+ # For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
+ shopt -s nullglob
+ local mesa_cards=$(echo -n /dev/dri/card* /dev/dri/render* | sed 's/ /:/g')
+ if test -n "${mesa_cards}"; then
+ addpredict "${mesa_cards}"
+ fi
+ local ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+ if test -n "${ati_cards}"; then
+ addpredict "${ati_cards}"
+ fi
+ shopt -u nullglob
+ addpredict /dev/nvidiactl
+}
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862579
+ # https://github.com/OSGeo/grass/issues/3506
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ addwrite /dev/dri/renderD128
+
+ local myeconfargs=(
+ --enable-shared
+ --disable-w11
+ --without-opendwg
+ --with-regex
+ --with-gdal="${EPREFIX}"/usr/bin/gdal-config
+ --with-proj-includes="${EPREFIX}"/usr/include/proj
+ --with-proj-libs="${EPREFIX}"/usr/$(get_libdir)
+ --with-proj-share="${EPREFIX}"/usr/share/proj/
+ $(use_with cxx)
+ $(use_with tiff)
+ $(use_with png libpng "${EPREFIX}"/usr/bin/libpng-config)
+ $(use_with postgres)
+ $(use_with mysql)
+ $(use_with mysql mysql-includes "${EPREFIX}"/usr/include/mysql)
+ $(use_with sqlite)
+ $(use_with opengl)
+ $(use_with odbc)
+ $(use_with fftw)
+ $(use_with blas)
+ $(use_with lapack)
+ $(use_with X cairo)
+ $(use_with truetype freetype)
+ $(use_with truetype freetype-includes "${EPREFIX}"/usr/include/freetype2)
+ $(use_with nls)
+ $(use_with readline)
+ $(use_with threads pthread)
+ $(use_with openmp)
+ $(use_with opencl)
+ $(use_with bzip2 bzlib)
+ $(use_with pdal pdal "${EPREFIX}"/usr/bin/pdal-config)
+ $(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
+ $(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
+ $(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
+ $(use_with X x)
+ $(use_with zstd)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # we don't want to link against embedded mysql lib
+ emake CC="$(tc-getCC)" MYSQLDLIB=""
+}
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ INST_DIR=/usr/$(get_libdir)/${MY_PM} \
+ prefix=/usr/ BINDIR=/usr/bin \
+ install
+
+ pushd "${ED}"/usr/$(get_libdir)/${MY_PM} >/dev/null || die
+
+ local HTML_DOCS=( docs/html/. )
+ einstalldocs
+
+ # translations
+ if use nls; then
+ insinto /usr/share/locale
+ doins -r locale/.
+ fi
+
+ popd >/dev/null || die
+
+ # link libraries in the ~standard~ place
+ local f file
+ for f in "${ED}"/usr/$(get_libdir)/${MY_PM}/lib/*; do
+ file="${f##*/}"
+ dosym ${MY_PM}/lib/${file} /usr/$(get_libdir)/${file}
+ done
+
+ # link headers in the ~standard~ place
+ dodir /usr/include/
+ dosym ../$(get_libdir)/${MY_PM}/include/grass /usr/include/grass
+
+ # set proper python interpreter
+ sed -e "s:os.environ\[\"GRASS_PYTHON\"\] = \"python3\":\
+os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
+ -i "${ED}"/usr/bin/grass || die
+
+ if use X; then
+ local GUI="--gui"
+ make_desktop_entry "/usr/bin/grass ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
+ doicon -s 48 gui/icons/${PN}-48x48.png
+ fi
+
+ # install .pc file so other apps know where to look for grass
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins grass.pc
+
+ # fix weird +x on tcl scripts
+ find "${ED}" -name "*.tcl" -exec chmod +r-x '{}' \; || die
+}
+
+pkg_postinst() {
+ use X && xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ use X && xdg_pkg_postrm
+}