summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /sci-geosciences/grass
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/Manifest3
-rw-r--r--sci-geosciences/grass/files/grass-7.8.5-bool.patch164
-rw-r--r--sci-geosciences/grass/grass-7.8.5.ebuild2
3 files changed, 168 insertions, 1 deletions
diff --git a/sci-geosciences/grass/Manifest b/sci-geosciences/grass/Manifest
index cfc3c17f3a56..4531a480c8ad 100644
--- a/sci-geosciences/grass/Manifest
+++ b/sci-geosciences/grass/Manifest
@@ -1,5 +1,6 @@
AUX grass-7.8-flock.patch 577 BLAKE2B 0f4e0b06e1d8273cb954be9596a68adbd51b099b0a19bf2d4dc695de3a06bffc4df42eedca76977d552a26578238ffb10fb1b2b5242c4b6ffda83eaba7c41764 SHA512 36d8408f553ebfeb5cdc97c43ffae3ce6f77b713069d0d30d734748fb812800d4dafc76921d95fa8455c4ec4a55311703499f4aec97ad13b97b9549ab463cb3c
+AUX grass-7.8.5-bool.patch 4472 BLAKE2B b48a2138b9299e91eb15ebe62f29f0a677dfc690477c2997c36fb5e3261ae64d1d3445b3fb4a241a39c504591b07af121e92f1ef9f9efb3ade01e82974f8955a SHA512 1dc95cddca38ea5e8200176a92bb412f4a3295eae18e770a6db3aa0d8cfbf11116dce1c9970bd03d78ee69d23254d2e85637f0a00208aff7aa428e52d631121b
DIST grass-7.8.5.tar.gz 61801712 BLAKE2B d7a929e28ea050285f47dd84093c6db85e00aeab6c397fbb63ac0e6ccac391d2dcad0d3fad18924ecae74b57638b7e3ccf1c8ef4a3a44e63b32f5651bf3f6c71 SHA512 054923e31c163b50537e89636da97cdb705f3a77e566ef869b8aa77303b1c6fa3040f198a2cdc639b773843fe38e50c40149ef683beb0cd2dcf1ca2f77d3dd65
-EBUILD grass-7.8.5.ebuild 6941 BLAKE2B fb4f2f5cfa068cc90b45f94fd5ddc19415a66b7fce9f34b5b3c6d71002de226e192f4740e140e9444a616e8498bf4b616e3718448e21fd1d85df2d73cb42a9b7 SHA512 80397ff07c02942ddb2d7ffe2ade1ba88c6baa5563ceddf20d707cb522c2703c6615acd83e29581735f3d8e989436c2e1672be68d4e680032be38f9a9132b130
+EBUILD grass-7.8.5.ebuild 6993 BLAKE2B a772460a6bc1ce8c2b50bd68dafb4b98c0771bab4ed72e99f685064081f7f9e1edb3abfc9fb308579e864f12beb282383029e89455ab73e4c235ebdc5ec81117 SHA512 cf69543c0883fe7d93bedb72280d04ca8055c6659bc84a6016a86c58c273487aba68948c84b6bc5ff3c84223c375d5ac4c32f7ca53dd175c2e19ded5c2a223b6
EBUILD grass-9999.ebuild 6869 BLAKE2B a70777bdbcfa1bd020d7f64a6dbcd74194075c18a9bc753fa0cfaf7113c9a1fe8f087e6f3a7ec0ab77d6eca08eac0ce5bad401e95686baec0c3bd0c28618bda9 SHA512 20ff6e8b55ba0090f4beb9750ce67ed3746f443568397a636f4c82dac2eb705dfa73b3541c00ba6b232a7f609a891ef3424fa291cb104e59384d3cdc553346de
MISC metadata.xml 1088 BLAKE2B 4a9d470738d4860ae6e841976ba21974a18c97759c61cc4677d9707c8fb2220f998999368247ed1b19bfc45d7c53624d0ffec9c4aefad951e270f07c43fdbe4f SHA512 0ba4c779c3c0f3ed226fbf7c53e291341513c78e4a5d9ef228cab5436dacfa686cf8fad28aa3143f5036603fcccaf538b5607f48a86138be42af4aead4d147bf
diff --git a/sci-geosciences/grass/files/grass-7.8.5-bool.patch b/sci-geosciences/grass/files/grass-7.8.5-bool.patch
new file mode 100644
index 000000000000..fddcb9f6df88
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-7.8.5-bool.patch
@@ -0,0 +1,164 @@
+diff --git a/include/gis.h b/include/gis.h
+index 46bb06c52f..333651b938 100644
+--- a/include/gis.h
++++ b/include/gis.h
+@@ -23,6 +23,8 @@
+ /* System include files */
+ #include <stdio.h>
+ #include <stdarg.h>
++#include <stdbool.h>
++
+
+ /* Grass and local include files */
+ #include <grass/config.h>
+@@ -51,13 +53,14 @@ static const char *GRASS_copyright __attribute__ ((unused))
+ #define G_gisinit(pgm) G__gisinit(GIS_H_VERSION, (pgm))
+ #define G_no_gisinit() G__no_gisinit(GIS_H_VERSION)
+
+-/* Define TRUE and FALSE for boolean comparisons */
++/* For boolean values and comparisons use the C99 type 'bool' with values 'true' */
++/* and 'false' For historical reasons 'TRUE' and 'FALSE' are still valid. */
+ #ifndef TRUE
+-#define TRUE 1
++#define TRUE true
+ #endif
+
+ #ifndef FALSE
+-#define FALSE 0
++#define FALSE false
+ #endif
+
+ #if (defined(_FILE_OFFSET_BITS) && _FILE_OFFSET_BITS == 64) || (__APPLE__ && __LP64__)
+diff --git a/lib/lidar/lidar.h b/lib/lidar/lidar.h
+index 89a25de3bf..978894ea74 100644
+--- a/lib/lidar/lidar.h
++++ b/lib/lidar/lidar.h
+@@ -62,9 +62,6 @@
+ /* INTERPOLATOR */
+ #define P_BILINEAR 1
+ #define P_BICUBIC 0
+- /* Boolean definitions */
+-#define TRUE 1
+-#define FALSE 0
+
+ /*----------------------------------------------------------------------------------------------------------*/
+ /*STRUCTS DECLARATION */
+diff --git a/raster/r.param.scale/param.h b/raster/r.param.scale/param.h
+index 9c1dab4e81..2512fedaa2 100644
+--- a/raster/r.param.scale/param.h
++++ b/raster/r.param.scale/param.h
+@@ -18,8 +18,6 @@
+ /* 'blank' edge around raster. */
+ #define MAX_WSIZE 499 /* Maximum dimensions of window. */
+ /* Some useful labels. */
+-#define TRUE 1
+-#define FALSE 0
+
+ #define RAD2DEG M_R2D
+ #define DEG2RAD M_D2R
+diff --git a/raster/r.surf.idw/main.h b/raster/r.surf.idw/main.h
+index 33164f43cb..47028e7444 100644
+--- a/raster/r.surf.idw/main.h
++++ b/raster/r.surf.idw/main.h
+@@ -1,8 +1,6 @@
+ #include <grass/raster.h>
+
+ #define SHORT short
+-#define TRUE 1
+-#define FALSE 0
+
+ #define MELEMENT struct Melement
+ MELEMENT {
+diff --git a/raster3d/r3.showdspf/Ball.c b/raster3d/r3.showdspf/Ball.c
+index fb3b79882f..ae3ec3933a 100644
+--- a/raster3d/r3.showdspf/Ball.c
++++ b/raster3d/r3.showdspf/Ball.c
+@@ -7,8 +7,6 @@
+ #include "Ball.h"
+ #include "BallMath.h"
+ #include <stdio.h>
+-#define TRUE 1
+-#define FALSE 0
+
+ HMatrix mId = { {1, 0, 0, 0}
+ , {0, 1, 0, 0}
+diff --git a/raster3d/r3.showdspf/togif.c b/raster3d/r3.showdspf/togif.c
+index 589f243a8d..b48236b33f 100644
+--- a/raster3d/r3.showdspf/togif.c
++++ b/raster3d/r3.showdspf/togif.c
+@@ -324,9 +324,6 @@ static int ditherrow(unsigned short *r, unsigned short *g, unsigned short *b,
+ *
+ *****************************************************************************/
+
+-#define TRUE 1
+-#define FALSE 0
+-
+
+ /************************** BumpPixel() ********************************/
+ /*
+diff --git a/vector/v.hull/chull.c b/vector/v.hull/chull.c
+index 1ad97396fa..584af5d8ba 100644
+--- a/vector/v.hull/chull.c
++++ b/vector/v.hull/chull.c
+@@ -29,10 +29,6 @@
+
+ #include "globals.h"
+
+-/*Define Boolean type */
+-typedef enum
+-{ BFALSE, BTRUE } bool;
+-
+ /* Define vertex indices. */
+ #define X 0
+ #define Y 1
+@@ -76,10 +72,10 @@ struct tFaceStructure
+ };
+
+ /* Define flags */
+-#define ONHULL BTRUE
+-#define REMOVED BTRUE
+-#define VISIBLE BTRUE
+-#define PROCESSED BTRUE
++#define ONHULL true
++#define REMOVED true
++#define VISIBLE true
++#define PROCESSED true
+
+ /* Global variable definitions */
+ tVertex vertices = NULL;
+@@ -436,7 +432,7 @@ bool AddOne(tVertex p)
+ tFace f;
+ tEdge e, temp;
+ long int vol;
+- bool vis = BFALSE;
++ bool vis = false;
+
+
+ /* Mark faces visible from p. */
+@@ -446,7 +442,7 @@ bool AddOne(tVertex p)
+
+ if (vol < 0) {
+ f->visible = VISIBLE;
+- vis = BTRUE;
++ vis = true;
+ }
+ f = f->next;
+ } while (f != faces);
+@@ -454,7 +450,7 @@ bool AddOne(tVertex p)
+ /* If no faces are visible from p, then p is inside the hull. */
+ if (!vis) {
+ p->onhull = !ONHULL;
+- return BFALSE;
++ return false;
+ }
+
+ /* Mark edges in interior of visible region for deletion.
+@@ -470,7 +466,7 @@ bool AddOne(tVertex p)
+ e->newface = MakeConeFace(e, p);
+ e = temp;
+ } while (e != edges);
+- return BTRUE;
++ return true;
+ }
+
+ /*---------------------------------------------------------------------
diff --git a/sci-geosciences/grass/grass-7.8.5.ebuild b/sci-geosciences/grass/grass-7.8.5.ebuild
index eb00d1ab6a89..755437aec9cf 100644
--- a/sci-geosciences/grass/grass-7.8.5.ebuild
+++ b/sci-geosciences/grass/grass-7.8.5.ebuild
@@ -82,6 +82,8 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
# bug 746590
"${FILESDIR}/${PN}-7.8-flock.patch"
+ # bug 792801
+ "${FILESDIR}/${PN}-7.8.5-bool.patch"
)
pkg_setup() {