summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /sci-geosciences/grass
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/Manifest1
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild262
2 files changed, 263 insertions, 0 deletions
diff --git a/sci-geosciences/grass/Manifest b/sci-geosciences/grass/Manifest
index a13aca8d836f..c52a88107cf6 100644
--- a/sci-geosciences/grass/Manifest
+++ b/sci-geosciences/grass/Manifest
@@ -3,4 +3,5 @@ DIST grass-7.8.4.tar.gz 61791074 BLAKE2B 9234ff11c9f780c350d26c94b92b1dd87e00b84
DIST grass-7.8.5.tar.gz 61801712 BLAKE2B d7a929e28ea050285f47dd84093c6db85e00aeab6c397fbb63ac0e6ccac391d2dcad0d3fad18924ecae74b57638b7e3ccf1c8ef4a3a44e63b32f5651bf3f6c71 SHA512 054923e31c163b50537e89636da97cdb705f3a77e566ef869b8aa77303b1c6fa3040f198a2cdc639b773843fe38e50c40149ef683beb0cd2dcf1ca2f77d3dd65
EBUILD grass-7.8.4.ebuild 6955 BLAKE2B 346e166fcfcf361898eb92ef2cc121cc45a7f1ed9ecfbf21c3f3378cb1960ef46eb159d3af8eaa9e5e579f79694ca2053293c6718d861f2be3d3fd5e93b66701 SHA512 7ef8a4655cfe07f4b7f1a904a49975fd40b475c8b3af375a11b00c31d7163a105e0e5d73130cb5bd2f1336bb484f47c9b588df5879a94c6ddb0c1f3e72f4e000
EBUILD grass-7.8.5.ebuild 6943 BLAKE2B 4305e0aebe3a6003f9b5eba3f6bacbc77100dafdfad53c75ea8636de6d0a71e70f7f4f09f8529cb3ae12e555c0ba04cd69347a363bfe6ab3fa7c50c595a0391c SHA512 e860008ff54b797b70a5e3e15df40b422138ae25e1e2525960aa5c61b372eaf6b9e24e070c87aad50e823c75e106b204ce6e3a1df1dcd155fc10e28d84186463
+EBUILD grass-9999.ebuild 6938 BLAKE2B dc511eb75c66a24d3f9532e1b9ab6434db4ccfa75949ec39112629051274be8758c3a3e8f3dd7c2e898cf2c9ad500950db9b1f554985c03723b55595564a407b SHA512 dca61e9ec300dd15872e05cc68c12a69f2c1860005d344608d142cc3a3fae10da63a1908d3e5268f17095aa0666c254d234a3a985a2210558bc3507dddcb8fab
MISC metadata.xml 1058 BLAKE2B fcaa70c36866e086db663b4f5fb00f7a0ba4d725af2c69752e060134203758bf8b094f958dae363c9343f60ced6f9958d59ad5cab775affbf4234ae39b227e92 SHA512 eefd4994f62f769eb2359c20871d2ad816713186e6b536afa4493d363b086a37d156a8220f54432fc94199854ba98a97eb995e1e00f228f0ea4add1f395ae6e0
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
new file mode 100644
index 000000000000..b2455ab8dc84
--- /dev/null
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -0,0 +1,262 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite" # bug 572440
+WANT_AUTOCONF="2.1"
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools desktop flag-o-matic git-r3 python-single-r1 toolchain-funcs wxwidgets xdg
+
+PV="7.9"
+MY_PM=${PN}$(ver_cut 1-2 ${PV})
+MY_PM=${MY_PM/.}
+
+DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
+HOMEPAGE="https://grass.osgeo.org/"
+EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
+
+LICENSE="GPL-2"
+SLOT="0/7.9"
+IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl openmp png postgres readline sqlite threads tiff truetype X zstd"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-admin/eselect-1.2
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+ sci-libs/gdal
+ sys-libs/gdbm
+ sys-libs/ncurses:0=
+ sci-libs/proj
+ sci-libs/xdrfile
+ sys-libs/zlib
+ media-libs/libglvnd
+ media-libs/glu
+ blas? (
+ virtual/cblas[eselect-ldso(+)]
+ virtual/blas[eselect-ldso(+)]
+ )
+ fftw? ( sci-libs/fftw:3.0= )
+ geos? ( sci-libs/geos )
+ lapack? ( virtual/lapack[eselect-ldso(+)] )
+ liblas? ( sci-geosciences/liblas )
+ mysql? ( dev-db/mysql-connector-c:= )
+ netcdf? ( sci-libs/netcdf )
+ odbc? ( dev-db/unixODBC )
+ opencl? ( virtual/opencl )
+ png? ( media-libs/libpng:0= )
+ postgres? ( >=dev-db/postgresql-8.4:= )
+ readline? ( sys-libs/readline:0= )
+ sqlite? ( dev-db/sqlite:3 )
+ tiff? ( media-libs/tiff:0= )
+ truetype? ( media-libs/freetype:2 )
+ X? (
+ dev-python/wxpython:4.0
+ x11-libs/cairo[X,opengl]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ )
+ zstd? ( app-arch/zstd )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? ( dev-lang/swig )"
+
+pkg_setup() {
+ if use lapack; then
+ local mylapack=$(eselect lapack show)
+ if [[ -z "${mylapack/.*reference.*/}" ]] && \
+ [[ -z "${mylapack/.*atlas.*/}" ]]; then
+ ewarn "You need to set lapack to atlas or reference. Do:"
+ ewarn " eselect lapack set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ if use blas; then
+ local myblas=$(eselect blas show)
+ if [[ -z "${myblas/.*reference.*/}" ]] && \
+ [[ -z "${myblas/.*atlas.*/}" ]]; then
+ ewarn "You need to set blas to atlas or reference. Do:"
+ ewarn " eselect blas set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix unversioned python calls
+ sed -e "s:=python3:=${EPYTHON}:" -i "${S}/lib/init/grass.sh" || die
+ sed -e "s:= python3:= ${EPYTHON}:" -i "${S}/include/Make/Platform.make.in" || die
+
+ default
+ eautoreconf
+
+ ebegin "Fixing python shebangs"
+ python_fix_shebang -q "${S}"
+ eend $?
+
+ # For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
+ shopt -s nullglob
+ local mesa_cards=$(echo -n /dev/dri/card* /dev/dri/render* | sed 's/ /:/g')
+ if test -n "${mesa_cards}"; then
+ addpredict "${mesa_cards}"
+ fi
+ local ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+ if test -n "${ati_cards}"; then
+ addpredict "${ati_cards}"
+ fi
+ shopt -u nullglob
+ addpredict /dev/nvidiactl
+}
+
+src_configure() {
+ if use X; then
+ local WX_BUILD=yes
+ setup-wxwidgets
+ fi
+
+ addwrite /dev/dri/renderD128
+
+ local myeconfargs=(
+ --enable-shared
+ --disable-w11
+ --without-opendwg
+ --with-regex
+ --with-gdal="${EPREFIX}"/usr/bin/gdal-config
+ --with-proj-includes="${EPREFIX}"/usr/include/proj
+ --with-proj-libs="${EPREFIX}"/usr/$(get_libdir)
+ --with-proj-share="${EPREFIX}"/usr/share/proj/
+ $(use_with cxx)
+ $(use_with tiff)
+ $(use_with png)
+ $(use_with postgres)
+ $(use_with mysql)
+ $(use_with mysql mysql-includes "${EPREFIX}"/usr/include/mysql)
+ $(use_with sqlite)
+ $(use_with odbc)
+ $(use_with fftw)
+ $(use_with blas)
+ $(use_with lapack)
+ $(use_with X cairo)
+ $(use_with truetype freetype)
+ $(use_with truetype freetype-includes "${EPREFIX}"/usr/include/freetype2)
+ $(use_with nls)
+ $(use_with readline)
+ $(use_with threads pthread)
+ $(use_with openmp)
+ $(use_with opencl)
+ $(use_with liblas liblas "${EPREFIX}"/usr/bin/liblas-config)
+ $(use_with X wxwidgets "${WX_CONFIG}")
+ $(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
+ $(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
+ $(use_with X x)
+ $(use_with zstd)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # we don't want to link against embedded mysql lib
+ emake CC="$(tc-getCC)" MYSQLDLIB=""
+}
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ INST_DIR="${ED}"/usr/$(get_libdir)/${MY_PM} \
+ prefix="${ED}"/usr/ BINDIR="${ED}"/usr/bin \
+ PREFIX="${ED}"/usr/ \
+ install
+
+ pushd "${ED}"/usr/$(get_libdir)/${MY_PM} >/dev/null || die
+
+ local HTML_DOCS=( docs/html/. )
+ einstalldocs
+
+ # translations
+ if use nls; then
+ insinto /usr/share/locale
+ doins -r locale/.
+ fi
+
+ popd >/dev/null || die
+
+ # link libraries in the ~standard~ place
+ local f file
+ for f in "${ED}"/usr/$(get_libdir)/${MY_PM}/lib/*; do
+ file="${f##*/}"
+ dosym ${MY_PM}/lib/${file} /usr/$(get_libdir)/${file}
+ done
+
+ # link headers in the ~standard~ place
+ dodir /usr/include/
+ dosym ../$(get_libdir)/${MY_PM}/include/grass /usr/include/grass
+
+ # fix paths in addons makefile includes
+ local scriptMakeDir="${ED}"/usr/$(get_libdir)/${MY_PM}/include/Make/
+ for f in "${scriptMakeDir}"/*; do
+ file="${f##*/}"
+ echo sed -i "s|${ED}|/|g" "${scriptMakeDir}/${file}" || die
+ sed -i "s|${ED}|/|g" "${scriptMakeDir}/${file}" || die
+ done
+
+ # get proper folder for grass path in script
+ local gisbase=/usr/$(get_libdir)/${MY_PM}
+ sed -e "s:GISBASE = os.path.normpath(\"${D}/usr/$(get_libdir)/${MY_PM}\"):\
+GISBASE = os.path.normpath(\"${gisbase}\"):" \
+ -i "${ED}"/usr/bin/${MY_PM} || die
+
+ # get proper fonts path for fontcap
+ sed -i \
+ -e "s|${ED}/usr/${MY_PM}|${EPREFIX}/usr/$(get_libdir)/${MY_PM}|" \
+ "${ED}"${gisbase}/etc/fontcap || die
+
+ # set proper python interpreter
+ sed -e "s:os.environ\['GRASS_PYTHON'\] = \"python3\":\
+os.environ\['GRASS_PYTHON'\] = \"${EPYTHON}\":" \
+ -i "${ED}"/usr/bin/${MY_PM} || die
+
+ # set proper GISDBASE directory path in the demolocation .grassrc79 file
+ sed -e "s:GISDBASE\:.*$:GISDBASE\: ${gisbase}:" \
+ -i "${ED}"${gisbase}/demolocation/.grassrc79 || die
+
+ if use X; then
+ local GUI="-gui"
+ [[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
+ make_desktop_entry "/usr/bin/${MY_PM} ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
+ doicon -s 48 gui/icons/${PN}-48x48.png
+ fi
+
+ # install .pc file so other apps know where to look for grass
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins grass.pc
+
+ # fix weird +x on tcl scripts
+ find "${ED}" -name "*.tcl" -exec chmod +r-x '{}' \; || die
+}
+
+pkg_postinst() {
+ use X && xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ use X && xdg_pkg_postrm
+}