summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass/grass-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /sci-geosciences/grass/grass-9999.ebuild
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'sci-geosciences/grass/grass-9999.ebuild')
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 33808453c9c7..8b286969e78a 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -13,7 +13,6 @@ DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizu
HOMEPAGE="https://grass.osgeo.org/"
LICENSE="GPL-2"
-SLOT="0/8.3"
GVERSION=${SLOT#*/}
MY_PM="${PN}${GVERSION}"
@@ -22,8 +21,10 @@ MY_PM="${MY_PM/.}"
if [[ ${PV} =~ "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
+ SLOT="0/8.3"
else
MY_P="${P/_rc/RC}"
+ SLOT="0/$(ver_cut 1-2 ${PV})"
SRC_URI="https://grass.osgeo.org/${MY_PM}/source/${MY_P}.tar.gz"
if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64 ~ppc ~x86"
@@ -32,7 +33,7 @@ else
S="${WORKDIR}/${MY_P}"
fi
-IUSE="blas cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
+IUSE="blas cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
opengl? ( X )"
@@ -65,6 +66,7 @@ RDEPEND="
odbc? ( dev-db/unixODBC )
opencl? ( virtual/opencl )
opengl? ( virtual/opengl )
+ pdal? ( >=sci-libs/pdal-2.0.0:0= )
png? ( media-libs/libpng:0= )
postgres? ( >=dev-db/postgresql-8.4:= )
readline? ( sys-libs/readline:0= )
@@ -179,6 +181,7 @@ src_configure() {
$(use_with threads pthread)
$(use_with openmp)
$(use_with opencl)
+ $(use_with pdal pdal "${EPREFIX}"/usr/bin/pdal-config)
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
$(use_with X wxwidgets "${WX_CONFIG}")
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)