summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass/grass-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-geosciences/grass/grass-9999.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-geosciences/grass/grass-9999.ebuild')
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild31
1 files changed, 16 insertions, 15 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 965bd4beb28c..4e0eaf89a49f 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="sqlite" # bug 572440
@@ -17,10 +17,11 @@ HOMEPAGE="https://grass.osgeo.org/"
EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
LICENSE="GPL-2"
-SLOT="0/7.9"
-IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl openmp png postgres readline sqlite threads tiff truetype X zstd"
+SLOT="0/8.0"
+IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}"
+ ${PYTHON_REQUIRED_USE}
+ opengl? ( X )"
RDEPEND="
${PYTHON_DEPS}
@@ -29,10 +30,10 @@ RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
')
- sci-libs/gdal
- sys-libs/gdbm
+ sci-libs/gdal:=
+ sys-libs/gdbm:=
sys-libs/ncurses:0=
- sci-libs/proj
+ sci-libs/proj:=
sci-libs/xdrfile
sys-libs/zlib
media-libs/libglvnd
@@ -42,13 +43,14 @@ RDEPEND="
virtual/blas[eselect-ldso(+)]
)
fftw? ( sci-libs/fftw:3.0= )
- geos? ( sci-libs/geos )
+ geos? ( sci-libs/geos:= )
lapack? ( virtual/lapack[eselect-ldso(+)] )
liblas? ( sci-geosciences/liblas )
mysql? ( dev-db/mysql-connector-c:= )
- netcdf? ( sci-libs/netcdf )
+ netcdf? ( sci-libs/netcdf:= )
odbc? ( dev-db/unixODBC )
opencl? ( virtual/opencl )
+ opengl? ( virtual/opengl )
png? ( media-libs/libpng:0= )
postgres? ( >=dev-db/postgresql-8.4:= )
readline? ( sys-libs/readline:0= )
@@ -57,7 +59,7 @@ RDEPEND="
truetype? ( media-libs/freetype:2 )
X? (
dev-python/wxpython:4.0
- x11-libs/cairo[X,opengl]
+ x11-libs/cairo[X,opengl?]
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
@@ -150,6 +152,7 @@ src_configure() {
$(use_with mysql)
$(use_with mysql mysql-includes "${EPREFIX}"/usr/include/mysql)
$(use_with sqlite)
+ $(use_with opengl)
$(use_with odbc)
$(use_with fftw)
$(use_with blas)
@@ -215,13 +218,11 @@ src_install() {
sed -i "s|${ED}|/|g" "${scriptMakeDir}/${file}" || die
done
- mv ${D}/usr/bin/grass ${D}/usr/bin/${MY_PM} || die
-
# get proper folder for grass path in script
local gisbase=/usr/$(get_libdir)/${MY_PM}
sed -e "s:GISBASE = os.path.normpath(\"${D}/usr/$(get_libdir)/${MY_PM}\"):\
GISBASE = os.path.normpath(\"${gisbase}\"):" \
- -i "${ED}"/usr/bin/${MY_PM} || die
+ -i "${ED}"/usr/bin/grass || die
# get proper fonts path for fontcap
sed -i \
@@ -231,7 +232,7 @@ GISBASE = os.path.normpath(\"${gisbase}\"):" \
# set proper python interpreter
sed -e "s:os.environ\[\"GRASS_PYTHON\"\] = \"python3\":\
os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
- -i "${ED}"/usr/bin/${MY_PM} || die
+ -i "${ED}"/usr/bin/grass || die
# set proper GISDBASE directory path in the demolocation .grassrc80 file
sed -e "s:GISDBASE\:.*$:GISDBASE\: ${gisbase}:" \
@@ -240,7 +241,7 @@ os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
if use X; then
local GUI="-gui"
[[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
- make_desktop_entry "/usr/bin/${MY_PM} ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
+ make_desktop_entry "/usr/bin/grass ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
doicon -s 48 gui/icons/${PN}-48x48.png
fi