summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass/grass-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /sci-geosciences/grass/grass-9999.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'sci-geosciences/grass/grass-9999.ebuild')
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 4e0eaf89a49f..d0b73c80b283 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,15 +9,15 @@ WX_GTK_VER="3.0-gtk3"
inherit autotools desktop git-r3 python-single-r1 toolchain-funcs wxwidgets xdg
-MY_P="${PN}8.0"
-MY_PM="${MY_P/.}"
-
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
LICENSE="GPL-2"
-SLOT="0/8.0"
+SLOT="0/8.1"
+GVERSION=${SLOT#*/}
+MY_P="${PN}${GVERSION}"
+MY_PM="${MY_P/.}"
IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -234,9 +234,9 @@ GISBASE = os.path.normpath(\"${gisbase}\"):" \
os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
-i "${ED}"/usr/bin/grass || die
- # set proper GISDBASE directory path in the demolocation .grassrc80 file
+ # set proper GISDBASE directory path in the demolocation .grassrc${GVERSION//.} file
sed -e "s:GISDBASE\:.*$:GISDBASE\: ${gisbase}:" \
- -i "${ED}"${gisbase}/demolocation/.grassrc80 || die
+ -i "${ED}"${gisbase}/demolocation/.grassrc${GVERSION//.} || die
if use X; then
local GUI="-gui"