summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /sci-geosciences/gpsd
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/Manifest3
-rw-r--r--sci-geosciences/gpsd/gpsd-3.17-r3.ebuild168
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild9
3 files changed, 175 insertions, 5 deletions
diff --git a/sci-geosciences/gpsd/Manifest b/sci-geosciences/gpsd/Manifest
index 806cd15b3431..ecfdf1f1a293 100644
--- a/sci-geosciences/gpsd/Manifest
+++ b/sci-geosciences/gpsd/Manifest
@@ -5,5 +5,6 @@ AUX gpsd.conf-2 198 BLAKE2B c72808d1b43c8f1d97d97369d3f95fe2726a7972ea08915dcd35
AUX gpsd.init-2 825 BLAKE2B 340bd992093d81067cef4329e50e4daa6e663ae214e560080ee58f99fbde742272979ca8b843c47ad6f1c2038d5bcab5c7886a963881bcf09079fb1ec1730aae SHA512 51319247eb78c3021d3eb897cb5d6026cc09d46a532a245a835459ed525947ffb6239f08126dd7e344de52e3b0387226bce060191ec3f14f99fc9f255d96f8ea
DIST gpsd-3.17.tar.gz 8755304 BLAKE2B d1f82b5734fd90fe903a6f2fe8835fe8292fe3e729306e7abe4054821971fece4c23f382c08a233503f07ad66b7b3a02a52a000e55c08491bf254ab6e99378b5 SHA512 71085053f600730e0f2de269c59ce0a17ae106ef01403f02d78418b267c6adb9818d541fba59eb23bf71cdb67c5442c82b4948d262ef7e74bb993dcae677a1b1
EBUILD gpsd-3.17-r2.ebuild 4605 BLAKE2B ae605e7afa0995de4d44d854674af3d90270cf1e14becd4e64985f59afff68ef925d8597158f3eb6fbec752b3cb3e0fb518693d304bdb23d890421ddfd1ee1ba SHA512 481f9df3dc6bf931f090a73d12ecadeb929dbe4a3bef4d274826c2a4e7017e3ae34bb50fd4bf5ef10d8a6aa42ab020097c909cb38d06324232e1484125f73183
-EBUILD gpsd-9999.ebuild 4723 BLAKE2B 6dd464eed24c3eaa6d1c9d0aa7c5841d28e492934bb4e4397f49ffb73ea8cac08d404c762d61abd368511c4fe23caa6f32c223b9a7410c75ec347adb2a2710b4 SHA512 a8d26da64fcbe69f1dd8bff80928424202d76d94d524428b68606918f521c2236b76b37fe2a30976e3d58e0674cfa0c4212512fff6f842b525636e16ff60e04e
+EBUILD gpsd-3.17-r3.ebuild 4629 BLAKE2B 78fdb2fb9e6bd96dcbbe6a775b5dd575b76511da17ecefa450e9923d4b0126526f4cd9ee11ae8e351e59a21c96567831754713a6752be371fab4e2076c863199 SHA512 da4de6ccd8b65323796bf7f1dd02c63e03599a1cce6b19a1eaafe55cb8ff148a4fda6931acdb0e1fa0da541633b097afb3784e2736b60860d9eafd22b525ca09
+EBUILD gpsd-9999.ebuild 4747 BLAKE2B 35b27062bb061c181550a0ca6ef7e7a77a271abfa882983bbf1cee1f2f178e132eeae4140974d15b1bbaac279642b86cdb5926fc171268a1410ba09ee90be051 SHA512 457d0269b9c66244bf2cf45e5e5f40c82cc4770cff7460588781035b48602c6d388c9bcb051df17d061366aa1bc40eaa9edce06ff4cb9628b8a3bc81de3d0096
MISC metadata.xml 950 BLAKE2B a2250377cdd4f1e827e7fe7dd5f8707316e8cbe9552f4ca2e56828e138d2d2b31d5c6cc930247c8666c9546fbe8dad618b2c38a34b6caac7f9e82ca620806ef3 SHA512 a5e8e60afc8c02e769cf496caa30003173455d82554378457ee7350bcc64b57a88b697cf2284a7a56f008461a33d260d167ce866bde0710e235f684e201a5bf8
diff --git a/sci-geosciences/gpsd/gpsd-3.17-r3.ebuild b/sci-geosciences/gpsd/gpsd-3.17-r3.ebuild
new file mode 100644
index 000000000000..4a84dbffcc3a
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-3.17-r3.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python2_7 )
+SCONS_MIN_VERSION="1.2.1"
+
+inherit eutils udev user multilib distutils-r1 scons-utils toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
+ inherit git-2
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 arm ~ppc ~ppc64 x86"
+fi
+
+DESCRIPTION="GPS daemon and library for USB/serial GPS devices and GPS/mapping clients"
+HOMEPAGE="http://catb.org/gpsd/"
+
+LICENSE="BSD"
+SLOT="0/23"
+
+GPSD_PROTOCOLS=(
+ aivdm ashtech earthmate evermore fury fv18 garmin garmintxt geostar
+ gpsclock isync itrax mtk3301 navcom nmea0183 nmea2000 ntrip oceanserver
+ oncore passthrough rtcm104v2 rtcm104v3 sirf skytraq superstar2 tnt
+ tripmate tsip ublox
+)
+IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency_timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
+REQUIRED_USE="X? ( python )
+ gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ qt5? ( cxx )"
+
+RDEPEND="
+ bluetooth? ( net-wireless/bluez )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ncurses? ( sys-libs/ncurses:= )
+ ntp? ( || (
+ net-misc/ntp
+ net-misc/chrony
+ ) )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ )
+ python? ( ${PYTHON_DEPS} )
+ usb? ( virtual/libusb:1 )
+ X? ( dev-python/pygobject:3[cairo,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sys-devel/bc )"
+
+# xml packages are for man page generation
+if [[ ${PV} == *9999* ]] ; then
+ DEPEND+="
+ app-text/xmlto
+ =app-text/docbook-xml-dtd-4.1*"
+fi
+
+src_prepare() {
+ # Make sure our list matches the source.
+ local src_protocols=$(echo $(
+ sed -n '/# GPS protocols/,/# Time service/{s:#.*::;s:[(",]::g;p}' "${S}"/SConstruct | awk '{print $1}' | LC_ALL=C sort
+ ) )
+ if [[ ${src_protocols} != ${GPSD_PROTOCOLS[*]} ]] ; then
+ eerror "Detected protocols: ${src_protocols}"
+ eerror "Ebuild protocols: ${GPSD_PROTOCOLS[*]}"
+ die "please sync ebuild & source"
+ fi
+
+ epatch "${FILESDIR}"/${P}-do_not_rm_library.patch
+
+ # Avoid useless -L paths to the install dir
+ sed -i \
+ -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
+ SConstruct || die
+
+ use python && distutils-r1_src_prepare
+}
+
+python_prepare_all() {
+ python_export_best
+ # Extract python info out of SConstruct so we can use saner distribute
+ pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
+ local pybins=$(pyvar python_progs | tail -1)
+ local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
+ local packet=$("${PYTHON}" -c "${pysrcs}; print(python_extensions['gps/packet'])")
+ local client=$("${PYTHON}" -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
+ sed \
+ -e "s|@VERSION@|$(pyvar gpsd_version)|" \
+ -e "s|@URL@|$(pyvar website)|" \
+ -e "s|@EMAIL@|$(pyvar devmail)|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
+ -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ myesconsargs=(
+ prefix="${EPREFIX}/usr"
+ libdir="\$prefix/$(get_libdir)"
+ udevdir="$(get_udevdir)"
+ chrpath=False
+ gpsd_user=gpsd
+ gpsd_group=uucp
+ nostrip=True
+ manbuild=False
+ shared=$(usex !static True False)
+ $(use_scons bluetooth bluez)
+ $(use_scons cxx libgpsmm)
+ $(use_scons debug clientdebug)
+ $(use_scons dbus dbus_export)
+ $(use_scons ipv6)
+ $(use_scons latency_timing timing)
+ $(use_scons ncurses)
+ $(use_scons ntp ntpshm)
+ $(use_scons ntp pps)
+ $(use_scons X python)
+ $(use_scons qt5 qt)
+ $(use_scons shm shm_export)
+ $(use_scons sockets socket_export)
+ $(use_scons usb)
+ )
+
+ use X && myesconsargs+=( xgps=1 )
+ use qt5 && myesconsargs+=( qt_versioned=5 )
+
+ # enable specified protocols
+ local protocol
+ for protocol in ${GPSD_PROTOCOLS[@]} ; do
+ myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
+ done
+}
+
+src_compile() {
+ export CHRPATH=
+ tc-export CC CXX PKG_CONFIG
+ export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
+ escons
+
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ DESTDIR="${D}" escons install $(usex udev udev-install "")
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd
+
+ use python && distutils-r1_src_install
+}
+
+pkg_preinst() {
+ # Run the gpsd daemon as gpsd and group uucp; create it here
+ # as it doesn't seem to be needed during compile/install ...
+ enewuser gpsd -1 -1 -1 "uucp"
+}
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 98fba863a5a6..e3db55c44b07 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -30,10 +30,11 @@ GPSD_PROTOCOLS=(
tripmate tsip ublox
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth dbus debug ipv6 latency_timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency_timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
REQUIRED_USE="X? ( python )
gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
- python? ( ${PYTHON_REQUIRED_USE} )"
+ python? ( ${PYTHON_REQUIRED_USE} )
+ qt5? ( cxx )"
RDEPEND="
bluetooth? ( net-wireless/bluez )
@@ -115,10 +116,10 @@ src_configure() {
gpsd_group=uucp
nostrip=True
python=False
- libgpsmm=True
manbuild=False
shared=$(usex !static True False)
$(use_scons bluetooth bluez)
+ $(use_scons cxx libgpsmm)
$(use_scons debug clientdebug)
$(use_scons dbus dbus_export)
$(use_scons ipv6)
@@ -126,7 +127,7 @@ src_configure() {
$(use_scons ncurses)
$(use_scons ntp ntpshm)
$(use_scons ntp pps)
- $(use_scons qt5 libQgpsmm)
+ $(use_scons qt5 qt)
$(use_scons shm shm_export)
$(use_scons sockets socket_export)
$(use_scons usb)