summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsd/gpsd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
commit4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (patch)
treef7640b8b96a04499f1ce44a2cad122d45a8373bd /sci-geosciences/gpsd/gpsd-9999.ebuild
parent48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (diff)
gentoo resync : 21.12.2017
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-9999.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index cd3ef4ffa066..cb88e5860ea5 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=5
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python2_7 )
@@ -30,28 +30,35 @@ GPSD_PROTOCOLS=(
tripmate tsip ublox
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 latency_timing ncurses ntp python qt4 +shm +sockets static test udev usb X"
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 latency_timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
REQUIRED_USE="X? ( python )
gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="X? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
- ncurses? ( sys-libs/ncurses:= )
+RDEPEND="
bluetooth? ( net-wireless/bluez )
- usb? ( virtual/libusb:1 )
dbus? (
sys-apps/dbus
dev-libs/dbus-glib
)
- ntp? ( || ( net-misc/ntp net-misc/chrony ) )
- qt4? ( dev-qt/qtgui:4 )
- python? ( ${PYTHON_DEPS} )"
+ ncurses? ( sys-libs/ncurses:= )
+ ntp? ( || (
+ net-misc/ntp
+ net-misc/chrony
+ ) )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ )
+ python? ( ${PYTHON_DEPS} )
+ usb? ( virtual/libusb:1 )
+ X? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( sys-devel/bc )"
# xml packages are for man page generation
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
DEPEND+="
app-text/xmlto
=app-text/docbook-xml-dtd-4.1*"
@@ -108,6 +115,7 @@ src_configure() {
gpsd_group=uucp
nostrip=True
python=False
+ qt_versioned=5
manbuild=False
shared=$(usex !static True False)
$(use_scons bluetooth bluez)
@@ -121,7 +129,7 @@ src_configure() {
$(use_scons ntp pps)
$(use_scons shm shm_export)
$(use_scons sockets socket_export)
- $(use_scons qt4 libQgpsmm)
+ $(use_scons qt5 libQgpsmm)
$(use_scons usb)
)