summaryrefslogtreecommitdiff
path: root/sci-geosciences/gnome-maps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
commitf85858c81a721c7fc89c1ab8df19e3a213dc27cd (patch)
tree3f0aeb33e434ee50b99bcc8b54158bc6169a41f2 /sci-geosciences/gnome-maps
parent16857b69f990738d17bc5842e3e49a6e82d1428d (diff)
gentoo auto-resync : 18:07:2024 - 12:29:01
Diffstat (limited to 'sci-geosciences/gnome-maps')
-rw-r--r--sci-geosciences/gnome-maps/Manifest2
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-46.11.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 1487ee82b26d..fb424eb4b5e9 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1,5 @@
DIST gnome-maps-45.5.tar.xz 3141872 BLAKE2B 3064a7ba2e96eaca7c5ad3a66874eb05bde1e675076003f3470ab5bb3bab04525e83e09a2239524247e1963af768d3e36512cbe3bc4dfe05dd951570b4488567 SHA512 cfcf616c331b8feebd79e31585a7f6f0aa05d3cf48713930635585a7d069996ec8c739b6bc1528b649d01c59307a39402d46a27c5e773d1e6b9b6a46362af35b
+DIST gnome-maps-46.11.tar.xz 3195792 BLAKE2B 6942a3801e738e981c7b462f23363c92e164c7cea55b650b9ef65fdc623e8bf279c11ef459af2ba91bc077288dff86d54fef9f3bfb1e00832bdffdc2f076f783 SHA512 c34f4535af6db93eca7ed7b7be0778bbfdae53aba1a32ec4882a84d82eeff6d82a365ef4ac18b3f55a829e044d680869827c5b897ddeb12b16a17d08f50f9ba1
EBUILD gnome-maps-45.5.ebuild 1261 BLAKE2B 55ac07cd882f454a6d66038215b8f397a3e0ee346c3fa077328c70d504b003afed0dc96ed70b1c3ce00a163b6194e36a9b8aa1f5652e2f7b073a5138791af199 SHA512 3fd9dd29d285b0be51564310786a8c8d4663d46963f9c029588cfc72bfcdad51e68b3338e2448c4bfc954b812f5a0cd88d37df7df3dd87173d0dfbfae9220dea
+EBUILD gnome-maps-46.11.ebuild 1284 BLAKE2B fbd0324966c4f59ac41608e0df171eb21f38fe7b3a1ffeb8db228060e1944f2a6389e052338a6d7fa43d4dea6600c45d802fce3d4619cc41b779500abeb82aae SHA512 b268bc6b786a6aa0903f737085c919785c6a363e83b835ae0df68a871a2becfc2922c3e69e3c1edfa686933ab46f7e4b5f1c1e1a5767305d90f085ddda951ccb
MISC metadata.xml 351 BLAKE2B 720552be0df0a6687b1c65211e4532bcdf2f76a1dbc2cfedf801876006bdef781b6e7a3caab9f61a6d5a17fcb73caaa194bb54d356fd903c6ba3d8849c1e8ae5 SHA512 cb4a26c3d4dbcdc7e6ba7cd7136cddf8633002eab39741c4fe5d033bd3154d17d002d475c8f5370aae652ba1b34f952ce1401ea8d71d22ad4ea4aae364fe9645
diff --git a/sci-geosciences/gnome-maps/gnome-maps-46.11.ebuild b/sci-geosciences/gnome-maps/gnome-maps-46.11.ebuild
new file mode 100644
index 000000000000..3ce5ef68e79e
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-46.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://apps.gnome.org/Maps/"
+
+LICENSE="CC0-1.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.4_alpha:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ dev-libs/libportal:=[introspection]
+ >=media-libs/libshumate-1.2_alpha:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+ >=gnome-base/librsvg-2.0
+ >=dev-libs/json-glib-1.0
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}