summaryrefslogtreecommitdiff
path: root/sci-geosciences/gnome-maps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sci-geosciences/gnome-maps
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sci-geosciences/gnome-maps')
-rw-r--r--sci-geosciences/gnome-maps/Manifest2
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-40.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 2297fcd58d32..00d39a7bd8e8 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1,5 @@
DIST gnome-maps-40.1.tar.xz 3543432 BLAKE2B adfffdcf6e3730414ebdf1da0727ee3c20d02b7e1c57f13070d5a08d9895d24f91ad452efac1465e881912f93fe4417cb255ff62324920ae73d482183d50cdbc SHA512 319d819737f6b370cd5344d4483e06781e362930610dbc4745641a208e71f753bf894693009690a6fe04bceac75ab5aa7788ae2511425cd0bd2b9229a5d0111c
+DIST gnome-maps-40.2.tar.xz 3542008 BLAKE2B 65f23bf61e2e3c24afa80b74400dd929510c91ec463aa7e36759b1ddc60814538e21d883df37b98b5d4da851705e5f8e78e9d54a8b50a9cfd490a3e965f34b87 SHA512 6214ebeb8f5dc5fb28e0aab659a2b9f56d6b0c7b9248cd3482a268a6694ca04c75d91686a7029ec96904efcfca91a028d66d17b6311efa7e95b76379c68f6a0e
EBUILD gnome-maps-40.1.ebuild 1487 BLAKE2B 455f501a0654cdae1c74a92391c3cde774d7ea6f9ce8f208700b820d40911fe17a44e49f279a47a123f97fbc645f78cb6e28c47e691f4c0eb07fdabd39143443 SHA512 e3210f34b4ca43f83436b2ee7896be63f95e87d862d79dc7351f7003b8c3335c42f68e37848b529e57c6ed8d71db206fffa073923ce6fe66c8321ef1acb68579
+EBUILD gnome-maps-40.2.ebuild 1489 BLAKE2B 941c151bfc2d1bd975db5dbc5eef7957b2a8cd767d9aacb56c6980123f230d055093b52787067ffe94ce7f4b3e93190249507b80e0b3ef8451d5ed639f7abe0e SHA512 f11ae943a1f93b14eec7baefa23401974659e2c3e33e63cd02779981afddfedcebd0b9c0b0e6ff124186a49a512331ff7c14b4ea1fdb2109011c9e7e377f7f13
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/sci-geosciences/gnome-maps/gnome-maps-40.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-40.2.ebuild
new file mode 100644
index 000000000000..eb37149677c7
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-40.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ x11-libs/pango[introspection]
+ >=dev-libs/gjs-1.66.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libhandy-0.84:1=
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10:=
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}