summaryrefslogtreecommitdiff
path: root/sci-geosciences/gnome-maps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-27 03:10:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-27 03:10:45 +0100
commit9e68aee0e16e4b361fe06f9566c74b4bb2a22a27 (patch)
tree419e98a8690f9f840b62b1a2013e04141d0342c0 /sci-geosciences/gnome-maps
parenta20b8556104c163a81183ff983af8123e40f16c5 (diff)
gentoo auto-resync : 27:05:2023 - 03:10:45
Diffstat (limited to 'sci-geosciences/gnome-maps')
-rw-r--r--sci-geosciences/gnome-maps/Manifest2
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 615bd99087e7..cf1026f19bcf 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1,5 @@
DIST gnome-maps-44.1.tar.xz 2349152 BLAKE2B e544427972f98d13c5c072c234006c081fc000048956cdd795f47225bc73771d655f048bd3ca7d2478f9afd23d50b6f26df95a08ec24b92c1d80a2280a9d2f60 SHA512 918a490491b86aa2648dae844dd910be5e4dff339544a6286d35c341bb11acfa1587de04fe2f2b3aff46c57c4175fc0bad50c28a253ffea8bacf274c0ca42f72
+DIST gnome-maps-44.2.tar.xz 2349116 BLAKE2B 52fd29cfa89ab76c6b041d9ae77453b75e5f9d2fe2de12d0ba1f283c4d16920156e9dffd54dfd0add9a37e66c3a4c49bb4ad43d4733f41301325f281e15fe458 SHA512 ea435f3a5a3ed9e4c3054e3fbb2f3dad253f0150f7555c734d06db3a039ece356c61294a664945b5165b004001d8724428aaed527ba0ca55fae2f7d37833e6a7
EBUILD gnome-maps-44.1.ebuild 1212 BLAKE2B cf3df69380ce7050a1b0bba86c7e8ed8b50f6d11f7cafc66c18a841e66b09d3780d3e0a44bb205593f465f01026654f4fb5546d6b0e4dfc1fab6c685ceaf2f63 SHA512 787f09f67d58f3c5f2dec635eace4aa8862a3d53a6b3ee6b194f81af9776bc596181bc8964d15674bc88f1ec0a6a0889466fe36fd50582c8b58551c3f9e50df8
+EBUILD gnome-maps-44.2.ebuild 1214 BLAKE2B 2bd90c48cca20d84ef7573502c3a51b43049fe7e415eb85ad824a7c45e28e37a41fb6ad53c96c4b5efc4c9ea0600dd1cb1e9a8e5e52b4752c3ebb797f555927c SHA512 3b05fbf10b4f502b1a27154a4d00ff6c0e4e8edec78c1ab81bc00ab0f60e9cf2e12a293adc08c79469b148a5a039d7c225e439b33d3001cfaf640e179a2b0531
MISC metadata.xml 351 BLAKE2B 720552be0df0a6687b1c65211e4532bcdf2f76a1dbc2cfedf801876006bdef781b6e7a3caab9f61a6d5a17fcb73caaa194bb54d356fd903c6ba3d8849c1e8ae5 SHA512 cb4a26c3d4dbcdc7e6ba7cd7136cddf8633002eab39741c4fe5d033bd3154d17d002d475c8f5370aae652ba1b34f952ce1401ea8d71d22ad4ea4aae364fe9645
diff --git a/sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild
new file mode 100644
index 000000000000..b7701c61f77d
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}