summaryrefslogtreecommitdiff
path: root/sci-geosciences/GeographicLib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sci-geosciences/GeographicLib
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sci-geosciences/GeographicLib')
-rw-r--r--sci-geosciences/GeographicLib/GeographicLib-1.51-r1.ebuild111
-rw-r--r--sci-geosciences/GeographicLib/Manifest3
-rw-r--r--sci-geosciences/GeographicLib/metadata.xml12
3 files changed, 125 insertions, 1 deletions
diff --git a/sci-geosciences/GeographicLib/GeographicLib-1.51-r1.ebuild b/sci-geosciences/GeographicLib/GeographicLib-1.51-r1.ebuild
new file mode 100644
index 000000000000..50bc12fbb31a
--- /dev/null
+++ b/sci-geosciences/GeographicLib/GeographicLib-1.51-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake distutils-r1
+
+MY_PN="${PN,,}"
+
+DESCRIPTION="C++ library for converting geographic coordinate systems"
+HOMEPAGE="https://sourceforge.net/projects/geographiclib/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/19"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc examples python"
+# To-Do:find out why this doesn't work
+# 105/167 Test #105: GeodSolve82 ......................***Failed
+# Required regular expression not found. Regex=[20\.0010* 0\.0* 180\.0* 20\.0010* 0\.0* 180\.0* 0\.0* 0\.0* 0\.0* 1\.0* 1\.0* -?0
+RESTRICT="test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ >=app-doc/doxygen-1.8.7
+ >=dev-lang/perl-5.26.1-r1
+ >=dev-python/sphinx-1.6.3-r2
+ >=sys-apps/util-linux-2.31
+ )
+"
+
+distutils_enable_tests setup.py
+# there are additional docs in the python dir
+distutils_enable_sphinx python/doc
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use python; then
+ pushd "python" || die
+ distutils-r1_python_prepare_all
+ popd || die
+ fi
+}
+
+src_configure() {
+ export GEODATAPATH="/usr/share/${MY_PN}"
+
+ local mycmakeargs=(
+ -DGEOGRAPHICLIB_DOCUMENTATION=$(usex doc ON OFF)
+ -DGEOGRAPHICLIB_LIB_TYPE="SHARED"
+ -DGEOGRAPHICLIB_DATA="${GEODATAPATH}"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use python; then
+ pushd "python" || die
+ python_foreach_impl distutils-r1_python_compile
+ popd || die
+ python_compile_all
+ fi
+}
+
+src_test() {
+ # Only 1 failing test in the C code, python passes for me
+ cmake_src_test
+
+ if use python; then
+ pushd "python" || die
+ python_foreach_impl python_test
+ popd || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+
+ # remove python things added by the cmake_src_install function
+ rm -r "${D}/usr/$(get_libdir)/python" || die
+ # if use python we re-add these python files for each implementation
+ if use python; then
+ pushd "python" || die
+ python_foreach_impl distutils-r1_python_install
+ popd || die
+ fi
+
+ #TODO: find out if java stuff need something
+
+ # Installs to wrong doc dir for some reason
+ # Also happens with USE="-doc"
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+
+ insinto "/usr/share/maxima/${MY_PN}"
+ doins -r maxima/.
+
+ find "${D}" -name "*.la" -delete || die
+}
diff --git a/sci-geosciences/GeographicLib/Manifest b/sci-geosciences/GeographicLib/Manifest
index e9324c2f4c7f..87e449a0caaa 100644
--- a/sci-geosciences/GeographicLib/Manifest
+++ b/sci-geosciences/GeographicLib/Manifest
@@ -1,5 +1,6 @@
DIST GeographicLib-1.50.1.tar.gz 2463854 BLAKE2B bed7d003dee92e794af993d8fef6cbf1233f9e3f37f53dd6026f16a237dba46bb4d4e2db7adea7931b632bb419288c9731c79cf65f15a4f35e95e8ada34a8f42 SHA512 1db874f30957a0edb8a1df3eee6db73cc993629e3005fe912e317a4ba908e7d7580ce483bb0054c4b46370b8edaec989609fb7e4eb6ba00c80182db43db436f1
DIST GeographicLib-1.51.tar.gz 2470362 BLAKE2B 5e0a0f44d3b0c62ed7e28285b240cab07a7592e5bf4b181c25b62d8462bb7e2c21f6fcb09577c5f766578803c4b303fdb69af006d3ae62a8b5cb80e92b76236f SHA512 34487a09fa94a34d24179cfe9fd2e5fdda28675966703ca137cbfe6cc88760c2fbde55f76c464de060b58bfe0a516e22c0f59318cf85ae7cc01c5c6a73dd6ead
EBUILD GeographicLib-1.50.1.ebuild 681 BLAKE2B baf824caf5142d9491de3aec3c6d04b6f6d9ba8e0d3a432f693b2d5b456bc3871d71556bdc18168453443807a740b0cd4eabd884606b804e64723c721065c36d SHA512 da5adf122a846ad28c0890163048d728ce8e14b261c002165888e84282ae40b6cf2d478d80ab793792795907eb24a71e38bb1df1b4fa175dd366affc2955a46e
+EBUILD GeographicLib-1.51-r1.ebuild 2512 BLAKE2B bd54d4b4de21675fe3f38591b14168de50eccad4eb5a7df4f4b73ac3748f41b03e305d4ba01dbe01a4bad409bae26ec143370cc34ea16b5ff283d4b7cd020ccb SHA512 838e0014e0e09ebcef32ebe7b45f4cdfd8d7edc36671d13268ddbe9a5f89ccb73d91670ec4a4eb00bb94b04c17e03478776070a91fba45131c26f0b500314201
EBUILD GeographicLib-1.51.ebuild 681 BLAKE2B 83c23bbd938a3fc24dc88aa68b1d9a5a2568b868a3d014f1056016ab53ba77157c3296e544cdb3d8a438227547b3a4f96931b20f80d25f8a0369524b78e28c5c SHA512 fc69f3b0a756b037e9fa4bfbc577deb52ea5536da868bacb31a92719907a56854d8dc266390ddd7c057491474f44a81fb82524a50928d8d630e5a075b519b365
-MISC metadata.xml 249 BLAKE2B 05e1e70021900498f37045733d9cf72175655cc72ef45d5cc5593c6fe6c04bf8a1895a6b40470e31ba15254dbf2c0e71dca9da3e1a7e7a0c76ffea90ca518f82 SHA512 f6c1880cb315572548c1cea0233124f8dfb99091c9dff06484f02847e4a6ab4bbecd627f2d561ef3d666c99c240195031294d170024fd2549dec228b7058bb71
+MISC metadata.xml 874 BLAKE2B d5534e73295e7cabf3d0b80547846b04cb5174a9c23f75a41e57e82a207bad3bd41232add45109e75cce6a10b4be311ebfa0bb7006d50ee611013aa1e3f13d87 SHA512 735095b1d41ee490568eea0572e3543bf85f44618d92ade74c4ff98c7dde1bcc5b9dd35942f0a3861dfab7066816eecefd741331563006425fc02f1cfd4ffaf3
diff --git a/sci-geosciences/GeographicLib/metadata.xml b/sci-geosciences/GeographicLib/metadata.xml
index 74ced8bea005..efc517b37248 100644
--- a/sci-geosciences/GeographicLib/metadata.xml
+++ b/sci-geosciences/GeographicLib/metadata.xml
@@ -5,4 +5,16 @@
<email>ros@gentoo.org</email>
<name>Gentoo ROS Project</name>
</maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>charles@karney.com</email>
+ <name>Charles Karney</name>
+ </maintainer>
+ <doc lang="en">https://geographiclib.sourceforge.io/html</doc>
+ <bugs-to>https://sourceforge.net/p/geographiclib/bugs/</bugs-to>
+ <remote-id type="sourceforge">geographiclib</remote-id>
+ </upstream>
+ <longdescription lang="en">
+GeographicLib is a small set of C++ classes for converting between geographic, UTM, UPS, MGRS, and geocentric coordinates, for gravity (e.g., EGM2008), geoid, and geomagnetic field (e.g., WMM2010) calculations, and for solving geodesic problems.
+ </longdescription>
</pkgmetadata>