summaryrefslogtreecommitdiff
path: root/sci-geosciences/GeographicLib/GeographicLib-1.51.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /sci-geosciences/GeographicLib/GeographicLib-1.51.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'sci-geosciences/GeographicLib/GeographicLib-1.51.ebuild')
-rw-r--r--sci-geosciences/GeographicLib/GeographicLib-1.51.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-geosciences/GeographicLib/GeographicLib-1.51.ebuild b/sci-geosciences/GeographicLib/GeographicLib-1.51.ebuild
new file mode 100644
index 000000000000..3721cff16459
--- /dev/null
+++ b/sci-geosciences/GeographicLib/GeographicLib-1.51.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ classes for performing conversions between geographic coordinates"
+HOMEPAGE="https://geographiclib.sourceforge.io/"
+SRC_URI="mirror://sourceforge/geographiclib/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/19"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? ( >=app-doc/doxygen-1.8.7 )
+"
+
+src_configure() {
+ econf \
+ --disable-static
+ # Automagic deps..
+ sed -e "s/SUBDIRS =.*$/SUBDIRS = src man tools $(usex doc doc "") include cmake/" -i Makefile || die
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}