summaryrefslogtreecommitdiff
path: root/sci-electronics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-11 12:45:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-11 12:45:52 +0000
commit8b4349b75818953123e2d4b80963181a9640c8e3 (patch)
treebd5d9faded1a62202daa603120c8ccd5216c79e9 /sci-electronics
parente96f09a840f1ac865c504febe44bad831c63750e (diff)
gentoo auto-resync : 11:03:2024 - 12:45:51
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/Manifest.gzbin8854 -> 8855 bytes
-rw-r--r--sci-electronics/ghdl/Manifest2
-rw-r--r--sci-electronics/ghdl/ghdl-4.0.0.ebuild90
3 files changed, 92 insertions, 0 deletions
diff --git a/sci-electronics/Manifest.gz b/sci-electronics/Manifest.gz
index 4b17af70bc7b..007200ef1e15 100644
--- a/sci-electronics/Manifest.gz
+++ b/sci-electronics/Manifest.gz
Binary files differ
diff --git a/sci-electronics/ghdl/Manifest b/sci-electronics/ghdl/Manifest
index 1c9e6f59830e..d9fc837fce0b 100644
--- a/sci-electronics/ghdl/Manifest
+++ b/sci-electronics/ghdl/Manifest
@@ -1,4 +1,6 @@
AUX ghdl-4.0.0_pre20231218-no-pyunit.patch 689 BLAKE2B 2df3df07e290240b2e99422fda33d2ccee9f01a5f3c3aa3535e40ab66bf5de95cbef3821a3e31b0f36b82f5bc90e078e9d2f9424ea5226f7c671ce4dec571458 SHA512 9149bb90346b0c97683a4ed7056cecb727f4ff9a5b89f8b4046983475cd40937f363438129304c72199442bcc3ad948f2c86cb38b6bd0d314dba9199f34a37a6
+DIST ghdl-4.0.0.tar.gz 7683124 BLAKE2B 2b43f1a24c9fb30f754ae6326b21fd52991f3bd69fc1c2dfbd3064d950cef74f7e66f2a846778e6429fbfae07d349f913993d91c52ec53cdad894b06f810cb03 SHA512 95b08274f2ed54556fbe2e72ce52605d9ca8269b535306348d25a259615a0610b59a61fb4458e0c1e548570361af15d45d89941bf4ab4afd2fafb10b07e69cae
DIST ghdl-4.0.0_pre20231218.tar.gz 7761842 BLAKE2B d5b3ae4c28b245881681695cee74eca1d69092d8089cb1ec042f42d26e62aa420ace8f04899023d98259d845ea89700d77c453b892c176d4d1b367ac7a8237a6 SHA512 6b9ac7221bee5b8ec2cc7971fbad5aff615839aa3c3170fa39079c68e65da8b4a8d60f5c53d9fa88146c9f865b0d8a059fd03358e20b660b6543cf1b0c0b0c84
+EBUILD ghdl-4.0.0.ebuild 1545 BLAKE2B 66abc7147d7e1429b118e04fe968efc11770bfee6eaa376868f845794772bfca2ccab165babad0e9067e6a71fe4ae27ca830c6784914a927ae4ac4a7ef5417dc SHA512 9ad1336bc12d219366e3a47a9630b785816da296bb89b3d809e9c811b26f5c762c49220cc0378fc9f7dfdaabdcafab9a43d65d533b73e4a6287fe0825b8b5b74
EBUILD ghdl-4.0.0_pre20231218.ebuild 1536 BLAKE2B d644b99e060c854adf055e521db0cc73ad6bea7e11f14e77f675aae8bd0954dfa90de2a9533860c0af8cc134d874320b245ea0aff1902458fb38c3a488366f65 SHA512 3042ddcef7a6d0aab0a43a9da6a5f718ed81330d06fc1a4681b79759e4ac37c0e504c63fbb219f815dd8e4e509679c6287cbfef47726e26f7564af284da0cfac
MISC metadata.xml 1462 BLAKE2B a403ab50a3463fc26ddfb6ad65aa2cfe9782e98b74cd91fe24ef81678e7c52a2211b0bcad27accc4cd57db281ed23ad5d8697ae69dd8b67c623465949d6d3434 SHA512 4bd4c20a8fbbdaa80a63373f81bd96144e110371403832627aba81a7a95d073ee73922516a6d5c193898affbeb8bd7f1ce9fc4203faa13464cf39ba809c82d5d
diff --git a/sci-electronics/ghdl/ghdl-4.0.0.ebuild b/sci-electronics/ghdl/ghdl-4.0.0.ebuild
new file mode 100644
index 000000000000..fb194d074563
--- /dev/null
+++ b/sci-electronics/ghdl/ghdl-4.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ADA_COMPAT=( gnat_2021 )
+LLVM_MAX_SLOT=17 # Check "configure" script for supported LLVM versions.
+
+inherit ada edo llvm toolchain-funcs
+
+DESCRIPTION="Open-source analyzer, compiler, and simulator for VHDL 2008/93/87"
+HOMEPAGE="https://ghdl.github.io/ghdl/
+ https://github.com/ghdl/ghdl/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/ghdl/${PN}.git"
+else
+ SRC_URI="https://github.com/ghdl/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="llvm"
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+RDEPEND="
+ ${ADA_DEPS}
+ llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/patchelf
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.0.0_pre20231218-no-pyunit.patch" )
+
+pkg_setup() {
+ ada_pkg_setup
+
+ use llvm && llvm_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i "s|ar rc|$(tc-getAR) rc|g" Makefile.in || die
+}
+
+src_configure() {
+ tc-export CC CXX
+
+ local -a myconf=(
+ # Build.
+ --disable-werror
+
+ # Install location.
+ --libdir=$(get_libdir)
+ --prefix=/usr
+
+ # Features.
+ --enable-libghdl
+ --enable-synth
+ )
+
+ if use llvm ; then
+ myconf+=( --with-llvm-config=llvm-config )
+ fi
+
+ # Not a autotools script!
+ edo sh ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ patchelf --set-soname libghw.so lib/libghw.so || die
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.a' -delete || die
+}