summaryrefslogtreecommitdiff
path: root/sci-electronics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /sci-electronics
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/Manifest.gzbin9733 -> 9900 bytes
-rw-r--r--sci-electronics/drahnr-oregano/Manifest3
-rw-r--r--sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild68
-rw-r--r--sci-electronics/drahnr-oregano/metadata.xml21
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-electronics/Manifest.gz b/sci-electronics/Manifest.gz
index 23f0ff84127d..d754d518deed 100644
--- a/sci-electronics/Manifest.gz
+++ b/sci-electronics/Manifest.gz
Binary files differ
diff --git a/sci-electronics/drahnr-oregano/Manifest b/sci-electronics/drahnr-oregano/Manifest
new file mode 100644
index 000000000000..e05f0415a1f9
--- /dev/null
+++ b/sci-electronics/drahnr-oregano/Manifest
@@ -0,0 +1,3 @@
+DIST drahnr-oregano-0.84.40.tar.gz 1879082 BLAKE2B 8b8e0ffc6af0205018bb1a415f1f0e067d30f8c86681f145b8000a71d414c540c32cfb99af48b9e7c4a1b1e71cebbe76b22c05ccd511797ba7db2efdc8de2079 SHA512 f4e38ccf09f148cbe609ccfebe3d3476e6b385f4d002cb951ed0d488d84f65557c0fcac986c6e7657684a07d7f7dac4dda663278ed85363de0dcf48f8d02f73e
+EBUILD drahnr-oregano-0.84.40.ebuild 1766 BLAKE2B 81d40972dc1b48fdf3c821a07fd830fae3edcd224d8ed6bf240f072241dedf0b424b5eee975176e5e5379e0768c9451eed30430d29a750dc935723c7af07522b SHA512 66ffaf033246f6994a4ad2c5342f852a4eb0ca0ed58c7c09cb5aee3fbfd5839a9bc62fba5bb3ead82a11ffb6b01c14b123266978f71c112991d9bd60c97e023e
+MISC metadata.xml 724 BLAKE2B fe414b214433f33f0e4a6787389f3169a1e892df0a815848bd56d939f0760afe23b74ace96d842eb2a1552332e60264be0245933e696616f6c7b90476ebddc41 SHA512 733a85af3d7f9205df6fb78456b334be12f56ba316abcd9c3cd21d7774807f8d58907a549482625c4d6dfcacdb7d8c1101bf2748566791ac7924b7a9136d02af
diff --git a/sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild b/sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild
new file mode 100644
index 000000000000..2ce8945195d8
--- /dev/null
+++ b/sci-electronics/drahnr-oregano/drahnr-oregano-0.84.40.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit gnome2-utils python-any-r1 waf-utils xdg-utils
+
+DESCRIPTION="Application for the schematic capturing and simulation of electrical circuits"
+HOMEPAGE="https://github.com/drahnr/oregano"
+SRC_URI="https://github.com/drahnr/oregano/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/oregano-${PV}"
+
+COMMON_DEP="dev-libs/glib:2
+ dev-libs/libxml2:2
+ x11-libs/goocanvas:2.0
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0"
+
+DEPEND="${COMMON_DEP}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+RDEPEND="${COMMON_DEP}
+ || ( gnome-base/dconf gnome-base/gconf )
+ sci-electronics/electronics-menu"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] ; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() { waf-utils_src_configure; }
+
+src_install() {
+ waf-utils_src_install --no-xdg --no-install-gschema
+ docompress -x /usr/share/doc/${PF}/{dev-docs,sequence}
+ dodoc -r docs/{dev-docs,sequence,user-docs}
+ insinto /usr/share/glib-2.0/schemas
+ doins data/settings/io.ahoi.oregano.gschema.xml
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ elog "Note: You'll need to emerge your prefered simulation backend"
+ elog "such as sci-electronics/ngspice (preferred) or sci-electronics/gnucap"
+ elog "for simulation to work."
+ elog "As an alternative generate a netlist and use sci-electronics/spice"
+ elog "from the command line for simulation."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/sci-electronics/drahnr-oregano/metadata.xml b/sci-electronics/drahnr-oregano/metadata.xml
new file mode 100644
index 000000000000..da419bd7c8af
--- /dev/null
+++ b/sci-electronics/drahnr-oregano/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ktrace@yandex.ru</email>
+ <name>Victor Kustov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Oregano is an application for schematic capture and simulation of electrical
+ circuits. The actual simulation is performed by Berkeley Spice, or GNUcap or
+ the new generation ngspice.
+ It's alive fork of <pkg>sci-electronics/oregano</pkg>
+ </longdescription>
+ <upstream>
+ <remote-id type="github">drahnr/oregano</remote-id>
+ </upstream>
+</pkgmetadata>