summaryrefslogtreecommitdiff
path: root/sci-electronics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-11 10:37:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-11 10:37:57 +0100
commit0b8c99da2b9c4eff53a33240b8c9f6db6dcba3db (patch)
treeec65222e960955380a3947019766a4db63f18a5f /sci-electronics
parentf8d2edf76d3901ebc1ace32c33a4d547fd5eee63 (diff)
gentoo auto-resync : 11:09:2023 - 10:37:57
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/Manifest.gzbin9030 -> 9027 bytes
-rw-r--r--sci-electronics/splat/Manifest2
-rw-r--r--sci-electronics/splat/files/splat-1.4.2-drop-register-keyword.patch22
-rw-r--r--sci-electronics/splat/splat-1.4.2-r1.ebuild92
4 files changed, 116 insertions, 0 deletions
diff --git a/sci-electronics/Manifest.gz b/sci-electronics/Manifest.gz
index 549819ad6254..cc901d5ce9d5 100644
--- a/sci-electronics/Manifest.gz
+++ b/sci-electronics/Manifest.gz
Binary files differ
diff --git a/sci-electronics/splat/Manifest b/sci-electronics/splat/Manifest
index 474145ce4c31..7f6de278b98e 100644
--- a/sci-electronics/splat/Manifest
+++ b/sci-electronics/splat/Manifest
@@ -1,4 +1,6 @@
AUX splat-1.2.2-gcc43.patch 180 BLAKE2B 9f6101e7fc1625e0660f871079da0d072b12d6514f57afd71be8c7c521f0098768ae70dfc103831803dcc7a96d545c897abca4ca110d49e310eb983a18292225 SHA512 01ecd4cd08575d354c94d78e02c9117ef613e71664f7fed9b64239907051f4170e56dc9dc9368ec08fa67d81fdc9bb67805e3eacb7c40a9663e52dd2d81d0638
+AUX splat-1.4.2-drop-register-keyword.patch 765 BLAKE2B 0bab9addfd794532f91941d356ec829f98a44a0c1ff87790416f55d00aec26dc278e877342972e9940608e64889194ceb7a53951e2336388ecf43cd639777960 SHA512 a00188f148a062b3a50ea119552048dc54b27b0b662172a625054a2f85d91c8285cd6ebb8b4cd7cf6cae244e83858d76fddc70ece84b466acb3d3882cdc25db7
DIST splat-1.4.2.tar.bz2 356823 BLAKE2B 7e4fe835128ae88b6d44d87159a5eab8652eed26876a637e613f57177ebfca8df7433455b53124318a2a0277bd09ca2cb9ce74ab205f5c6d1417fa736934b3fa SHA512 223b6184b1df35052709ba3b0e8679b9f6a2933c98ac433b0f07cd93b07213f55399a6eeb8e955a86fb59d13e09d891fc085ac17594f561268da239c30e885bb
+EBUILD splat-1.4.2-r1.ebuild 2169 BLAKE2B 8928d0ab4ee5d2d1d1f78a3391a41f442cc338f7ad675f0c96bd90e27b3c6424bb633cf1d99e3dcb87c846cf347496bf3a66acc131efe882c4e13ee39e7ba933 SHA512 660b8e99bfe1bd4c7f3731a0a78e2febc91d10c16e72aaf2b581cb09079815d0d4a1732fee996e9a70784e55ff280d389ccbff9fca36e9745676c66dda5911a4
EBUILD splat-1.4.2.ebuild 2114 BLAKE2B cc1973f7cdb66137addc32f89f32f5349819110f8c41a21c49cdfd9fe354bc591fcbbabfe1214a433244da51f050d8f478872dc8ffe2c48730c37f67c7530c9e SHA512 5812f517eae1bea8c5a222adbd56a7b0f0a2f4fd94bc5032bb6d179d460650fe41621b45e7ee354c7ef0427fe3c8af7fe1f4b5fc12e07738392d996d9f12a499
MISC metadata.xml 741 BLAKE2B ffc835bb2e8728ebfc7f40976fb50192248452968ee81e5dae59884315609b61d0bdad59d7f19dd13ba44deb0ee512288559e7c844e46b97a64a74af5b79dca6 SHA512 71478cad23f2114750884908d7f2e2da38568118c13c9df37051578a1fde7685301bb692c857d082229b64df6529fa7a71ce9338b714d9250ebf7a5f1a281a55
diff --git a/sci-electronics/splat/files/splat-1.4.2-drop-register-keyword.patch b/sci-electronics/splat/files/splat-1.4.2-drop-register-keyword.patch
new file mode 100644
index 000000000000..4445b06f2057
--- /dev/null
+++ b/sci-electronics/splat/files/splat-1.4.2-drop-register-keyword.patch
@@ -0,0 +1,22 @@
+Register keyword was deprecated in C++14 and removed in C++17
+Bug: https://bugs.gentoo.org/898168
+--- a/splat.cpp
++++ b/splat.cpp
+@@ -567,7 +567,7 @@ double ElevationAngle(struct site source, struct site destination)
+ (downtilt), as referenced to a normal to the center of
+ the earth. */
+
+- register double a, b, dx;
++ double a, b, dx;
+
+ a=GetElevation(destination)+destination.alt+earthradius;
+ b=GetElevation(source)+source.alt+earthradius;
+@@ -2727,7 +2727,7 @@ void PlotPath(struct site source, struct site destination, char mask_value)
+
+ char block;
+ int x, y;
+- register double cos_xmtr_angle, cos_test_angle, test_alt;
++ double cos_xmtr_angle, cos_test_angle, test_alt;
+ double distance, rx_alt, tx_alt;
+
+ ReadPath(source,destination);
diff --git a/sci-electronics/splat/splat-1.4.2-r1.ebuild b/sci-electronics/splat/splat-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..e8c4e8321e79
--- /dev/null
+++ b/sci-electronics/splat/splat-1.4.2-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="RF Signal Propagation, Loss, And Terrain analysis tool"
+HOMEPAGE="https://www.qsl.net/kd2bd/splat.html"
+SRC_URI="https://www.qsl.net/kd2bd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc hires l10n_es"
+
+DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.2-gcc43.patch
+ "${FILESDIR}"/${PN}-1.4.2-drop-register-keyword.patch
+)
+
+src_configure() {
+ # fake resulting file from interactive configuration script
+ # using default resolution
+ cat <<- EOF > "${S}/splat.h" || die
+ /* Parameters for 3 arc-second standard resolution mode of operation */
+ #define MAXPAGES 9
+ #define HD_MODE 0
+ EOF
+ if use hires; then
+ # fake resulting file from interactive configuration script
+ # using default resolution
+ cat <<- EOF > "${S}/hires.h" || die
+ /* Parameters for 3 arc-second hires resolution mode of operation */
+ #define MAXPAGES 9
+ #define HD_MODE 1
+ EOF
+ fi
+}
+
+src_compile() {
+ tc-export CC CXX
+
+ cp {splat,rfsplat}.cpp || die
+ emake LDLIBS="-lm -lbz2" -E "rfsplat: itwom3.0.o"
+ if use hires; then
+ cp {hires,splat}.h || die
+ cp {splat,rfsplat-hd}.cpp || die
+ emake LDLIBS="-lm -lbz2" -E "rfsplat-hd: itwom3.0.o"
+ fi
+
+ cd utils || die
+
+ emake citydecoder usgs2sdf
+ emake LDLIBS=-lbz2 srtm2sdf
+ emake LDLIBS=-lm bearing
+}
+
+src_install() {
+ local SPLAT_LANG="english"
+ use l10n_es && SPLAT_LANG="spanish"
+ # splat binary
+ dobin rfsplat
+
+ use hires && dobin rfsplat-hd
+
+ # utilities
+ dobin utils/{citydecoder,usgs2sdf,srtm2sdf,postdownload,bearing}
+ newman docs/${SPLAT_LANG}/man/splat.man rfsplat.1
+
+ dodoc CHANGES README utils/fips.txt
+ newdoc utils/README README.UTILS
+
+ use doc && dodoc docs/${SPLAT_LANG}/{pdf/splat.pdf,postscript/splat.ps}
+
+ #sample data
+ docinto sample_data
+ dodoc -r sample_data/.
+}
+
+pkg_postinst() {
+ elog "The original SPLAT! command got renamed to 'rfsplat' to avoid"
+ elog "filename collision with app-portage/splat."
+ elog ""
+ elog "Be aware that it is still referenced as 'splat' in the documentation."
+}